All of lore.kernel.org
 help / color / mirror / Atom feed
From: Wei Yang <richardw.yang@linux.intel.com>
To: akpm@linux-foundation.org
Cc: linux-mm@kvack.org, linux-kernel@vger.kernel.org,
	Wei Yang <richardw.yang@linux.intel.com>
Subject: [PATCH 0/4] mm/page_alloc.c: cleanup on check page
Date: Sun, 19 Jan 2020 21:14:04 +0800	[thread overview]
Message-ID: <20200119131408.23247-1-richardw.yang@linux.intel.com> (raw)

The patch set does some cleanup related to check page:

* extract the common part to do check page 
* rename two functions for consistent name convention
* remove two unnecessary variable assignments

No functional change.

Wei Yang (4):
  mm/page_alloc.c: extract commom part to check page
  mm/page_alloc.c: rename free_pages_check_bad() to
    check_free_page_bad()
  mm/page_alloc.c: rename free_pages_check() to check_free_page()
  mm/page_alloc.c: bad_[reason|flags] is not necessary when PageHWPoison

 mm/page_alloc.c | 50 ++++++++++++++++++++++---------------------------
 1 file changed, 22 insertions(+), 28 deletions(-)

-- 
2.17.1


             reply	other threads:[~2020-01-19 13:14 UTC|newest]

Thread overview: 13+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-01-19 13:14 Wei Yang [this message]
2020-01-19 13:14 ` [PATCH 1/4] mm/page_alloc.c: extract commom part to check page Wei Yang
2020-01-19 22:06   ` David Rientjes
2020-01-19 22:06     ` David Rientjes
2020-01-20  0:33     ` Wei Yang
2020-01-19 13:14 ` [PATCH 2/4] mm/page_alloc.c: rename free_pages_check_bad() to check_free_page_bad() Wei Yang
2020-01-19 22:07   ` David Rientjes
2020-01-19 22:07     ` David Rientjes
2020-01-20  0:36     ` Wei Yang
2020-01-19 13:14 ` [PATCH 3/4] mm/page_alloc.c: rename free_pages_check() to check_free_page() Wei Yang
2020-01-19 13:14 ` [PATCH 4/4] mm/page_alloc.c: bad_[reason|flags] is not necessary when PageHWPoison Wei Yang
2020-01-19 22:07   ` David Rientjes
2020-01-19 22:07     ` David Rientjes

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20200119131408.23247-1-richardw.yang@linux.intel.com \
    --to=richardw.yang@linux.intel.com \
    --cc=akpm@linux-foundation.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-mm@kvack.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.