All of lore.kernel.org
 help / color / mirror / Atom feed
From: Johan Hovold <johan@kernel.org>
To: edes <edes@gmx.net>
Cc: linux-usb@vger.kernel.org, linux-kernel@vger.kernel.org
Subject: Re: kernel 5.4.11: problems with usb sound cards
Date: Sat, 1 Feb 2020 15:10:09 +0100	[thread overview]
Message-ID: <20200201141009.GK10381@localhost> (raw)
In-Reply-To: <20200201105829.5682c887@acme7.acmenet>

On Sat, Feb 01, 2020 at 10:58:29AM -0300, edes wrote:
> Hello, list, I hope this is the right place to post this problem.
> 
> Changes introduced in 5.4.11 (seemingly, in drivers/usb/core/config.c)
> cause problems with at least some models of USB sound cards.
> 
> I have a Sound Devices USBPre2, a high quality sound card that until
> 5.4.10 always worked perfectly out of the box as a standard USB audio
> device.
> 
> Beginning with 5.4.11 and up to 5.5.0, when the sound card is connected,
> dmesg shows:
> 
> [ 1310.743135] usb 3-10.3: new high-speed USB device number 6 using
> xhci_hcd
> [ 1310.755472] usb 3-10.3: config 1 interface 2 altsetting 1 has
> a duplicate endpoint with address 0x85, skipping
> [ 1310.755474] usb 3-10.3: config 1 interface 2 altsetting 2 has a
> duplicate endpoint with address 0x85, skipping
> [ 1310.755852] usb 3-10.3: New USB device found, idVendor=0926,
> idProduct=0202, bcdDevice= 1.00
> [ 1310.755853] usb 3-10.3: New USB device strings: Mfr=1, Product=2,
> SerialNumber=3
> [ 1310.755854] usb 3-10.3: Product: USBPre2
> [ 1310.755855] usb 3-10.3: Manufacturer: Sound Devices
> [ 1310.755855] usb 3-10.3: SerialNumber: HB1116132005
> [ 1310.756803] usb 3-10.3: 1:3 : UAC_AS_GENERAL descriptor not found
> [ 1310.757550] hid-generic 0003:0926:0202.0005: hiddev96: USB HID v1.01
> Device
> [Sound Devices USBPre2] on usb-0000:00:14.0-10.3/input3
> [ 1310.773161] systemd-udevd[3856]: controlC0: Process '/usr/sbin/alsactl
> restore 0' failed with exit code 99.
> 
> No capture device is created under /dev/snd, and the card works only as a
> playback device.

Can you please post the output of "lsusb -v" for this device on 5.4.10
and 5.4.11, respectively?

Johan

  reply	other threads:[~2020-02-01 14:10 UTC|newest]

Thread overview: 10+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-02-01 13:58 edes
2020-02-01 14:10 ` Johan Hovold [this message]
2020-02-01 16:26   ` edes
2020-02-02 10:19     ` Johan Hovold
2020-02-02 13:41       ` Johan Hovold
2020-02-02 23:28         ` edes
2020-02-03  7:57           ` Takashi Iwai
2020-02-03  8:29             ` Johan Hovold
2020-02-03  9:54               ` Takashi Iwai
2020-02-03  8:42           ` Johan Hovold

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20200201141009.GK10381@localhost \
    --to=johan@kernel.org \
    --cc=edes@gmx.net \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-usb@vger.kernel.org \
    --subject='Re: kernel 5.4.11: problems with usb sound cards' \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.