All of lore.kernel.org
 help / color / mirror / Atom feed
From: David Gibson <david@gibson.dropbear.id.au>
To: Greg Kurz <groug@kaod.org>
Cc: lvivier@redhat.com, Thomas Huth <thuth@redhat.com>,
	Xiao Guangrong <xiaoguangrong.eric@gmail.com>,
	"Michael S. Tsirkin" <mst@redhat.com>,
	aik@ozlabs.ru, farosas@linux.ibm.com,
	Mark Cave-Ayland <mark.cave-ayland@ilande.co.uk>,
	qemu-devel@nongnu.org, Igor Mammedov <imammedo@redhat.com>,
	qemu-ppc@nongnu.org, clg@kaod.org,
	Paolo Bonzini <pbonzini@redhat.com>,
	"Edgar E. Iglesias" <edgar.iglesias@gmail.com>,
	paulus@samba.org
Subject: Re: [PATCH v6 11/18] target/ppc: Only calculate RMLS derived RMA limit on demand
Date: Thu, 27 Feb 2020 15:33:41 +1100	[thread overview]
Message-ID: <20200227043341.GL41629@umbus.fritz.box> (raw)
In-Reply-To: <20200226142453.6d47fb6b@bahia.home>

[-- Attachment #1: Type: text/plain, Size: 6887 bytes --]

On Wed, Feb 26, 2020 at 02:24:53PM +0100, Greg Kurz wrote:
> On Tue, 25 Feb 2020 10:37:17 +1100
> David Gibson <david@gibson.dropbear.id.au> wrote:
> 
> > When the LPCR is written, we update the env->rmls field with the RMA limit
> > it implies.  Simplify things by just calculating the value directly from
> > the LPCR value when we need it.
> > 
> > It's possible this is a little slower, but it's unlikely to be significant,
> > since this is only for real mode accesses in a translation configuration
> > that's not used very often, and the whole thing is behind the qemu TLB
> > anyway.  Therefore, keeping the number of state variables down and not
> > having to worry about making sure it's always in sync seems the better
> > option.
> > 
> 
> This patch also refactors the code of ppc_hash64_update_vrma(), which
> is definitely an improvement, but seems a bit unrelated to the title...
> I'd personally make it a separate patch but you decide of course :)

Ah, dang it, botched rebase damage.  There are a couple of hunks here
that are supposed to be in the next patch.  I think I've sorted it out
now.

> 
> Also, a cosmetic remark. See below.
> 
> > Signed-off-by: David Gibson <david@gibson.dropbear.id.au>
> > Reviewed-by: Cédric Le Goater <clg@kaod.org>
> > ---
> >  target/ppc/cpu.h        |  1 -
> >  target/ppc/mmu-hash64.c | 84 ++++++++++++++++++++---------------------
> >  2 files changed, 40 insertions(+), 45 deletions(-)
> > 
> > diff --git a/target/ppc/cpu.h b/target/ppc/cpu.h
> > index 8077fdb068..f9871b1233 100644
> > --- a/target/ppc/cpu.h
> > +++ b/target/ppc/cpu.h
> > @@ -1046,7 +1046,6 @@ struct CPUPPCState {
> >      uint64_t insns_flags2;
> >  #if defined(TARGET_PPC64)
> >      ppc_slb_t vrma_slb;
> > -    target_ulong rmls;
> >  #endif
> >  
> >      int error_code;
> > diff --git a/target/ppc/mmu-hash64.c b/target/ppc/mmu-hash64.c
> > index dd0df6fd01..ac21c14f68 100644
> > --- a/target/ppc/mmu-hash64.c
> > +++ b/target/ppc/mmu-hash64.c
> > @@ -791,6 +791,35 @@ static target_ulong rmls_limit(PowerPCCPU *cpu)
> >      }
> >  }
> >  
> > +static int build_vrma_slbe(PowerPCCPU *cpu, ppc_slb_t *slb)
> > +{
> > +    CPUPPCState *env = &cpu->env;
> > +    target_ulong lpcr = env->spr[SPR_LPCR];
> > +    uint32_t vrmasd = (lpcr & LPCR_VRMASD) >> LPCR_VRMASD_SHIFT;
> > +    target_ulong vsid = SLB_VSID_VRMA | ((vrmasd << 4) & SLB_VSID_LLP_MASK);
> > +    int i;
> > +
> > +    for (i = 0; i < PPC_PAGE_SIZES_MAX_SZ; i++) {
> > +        const PPCHash64SegmentPageSizes *sps = &cpu->hash64_opts->sps[i];
> > +
> > +        if (!sps->page_shift) {
> > +            break;
> > +        }
> > +
> > +        if ((vsid & SLB_VSID_LLP_MASK) == sps->slb_enc) {
> > +            slb->esid = SLB_ESID_V;
> > +            slb->vsid = vsid;
> > +            slb->sps = sps;
> > +            return 0;
> > +        }
> > +    }
> > +
> > +    error_report("Bad page size encoding in LPCR[VRMASD]; LPCR=0x"
> > +                 TARGET_FMT_lx"\n", lpcr);
> > +
> > +    return -1;
> > +}
> > +
> >  int ppc_hash64_handle_mmu_fault(PowerPCCPU *cpu, vaddr eaddr,
> >                                  int rwx, int mmu_idx)
> >  {
> > @@ -844,8 +873,10 @@ int ppc_hash64_handle_mmu_fault(PowerPCCPU *cpu, vaddr eaddr,
> >  
> >              goto skip_slb_search;
> >          } else {
> > +            target_ulong limit = rmls_limit(cpu);
> > +
> >              /* Emulated old-style RMO mode, bounds check against RMLS */
> > -            if (raddr >= env->rmls) {
> > +            if (raddr >= limit) {
> >                  if (rwx == 2) {
> >                      ppc_hash64_set_isi(cs, SRR1_PROTFAULT);
> >                  } else {
> > @@ -1007,8 +1038,9 @@ hwaddr ppc_hash64_get_phys_page_debug(PowerPCCPU *cpu, target_ulong addr)
> >                  return -1;
> >              }
> >          } else {
> > +            target_ulong limit = rmls_limit(cpu);
> 
> Maybe add an empty line like you did above for consistency and better
> readability ?

Ok, done.

> 
> Anyway, feel free to add:
> 
> Reviewed-by: Greg Kurz <groug@kaod.org>
> 
> >              /* Emulated old-style RMO mode, bounds check against RMLS */
> > -            if (raddr >= env->rmls) {
> > +            if (raddr >= limit) {
> >                  return -1;
> >              }
> >              return raddr | env->spr[SPR_RMOR];
> > @@ -1043,53 +1075,18 @@ void ppc_hash64_tlb_flush_hpte(PowerPCCPU *cpu, target_ulong ptex,
> >  static void ppc_hash64_update_vrma(PowerPCCPU *cpu)
> >  {
> >      CPUPPCState *env = &cpu->env;
> > -    const PPCHash64SegmentPageSizes *sps = NULL;
> > -    target_ulong esid, vsid, lpcr;
> >      ppc_slb_t *slb = &env->vrma_slb;
> > -    uint32_t vrmasd;
> > -    int i;
> > -
> > -    /* First clear it */
> > -    slb->esid = slb->vsid = 0;
> > -    slb->sps = NULL;
> >  
> >      /* Is VRMA enabled ? */
> > -    if (!ppc_hash64_use_vrma(env)) {
> > -        return;
> > -    }
> > -
> > -    /*
> > -     * Make one up. Mostly ignore the ESID which will not be needed
> > -     * for translation
> > -     */
> > -    lpcr = env->spr[SPR_LPCR];
> > -    vsid = SLB_VSID_VRMA;
> > -    vrmasd = (lpcr & LPCR_VRMASD) >> LPCR_VRMASD_SHIFT;
> > -    vsid |= (vrmasd << 4) & (SLB_VSID_L | SLB_VSID_LP);
> > -    esid = SLB_ESID_V;
> > -
> > -    for (i = 0; i < PPC_PAGE_SIZES_MAX_SZ; i++) {
> > -        const PPCHash64SegmentPageSizes *sps1 = &cpu->hash64_opts->sps[i];
> > -
> > -        if (!sps1->page_shift) {
> > -            break;
> > +    if (ppc_hash64_use_vrma(env)) {
> > +        if (build_vrma_slbe(cpu, slb) == 0) {
> > +            return;
> >          }
> > -
> > -        if ((vsid & SLB_VSID_LLP_MASK) == sps1->slb_enc) {
> > -            sps = sps1;
> > -            break;
> > -        }
> > -    }
> > -
> > -    if (!sps) {
> > -        error_report("Bad page size encoding esid 0x"TARGET_FMT_lx
> > -                     " vsid 0x"TARGET_FMT_lx, esid, vsid);
> > -        return;
> >      }
> >  
> > -    slb->vsid = vsid;
> > -    slb->esid = esid;
> > -    slb->sps = sps;
> > +    /* Otherwise, clear it to indicate error */
> > +    slb->esid = slb->vsid = 0;
> > +    slb->sps = NULL;
> >  }
> >  
> >  void ppc_store_lpcr(PowerPCCPU *cpu, target_ulong val)
> > @@ -1098,7 +1095,6 @@ void ppc_store_lpcr(PowerPCCPU *cpu, target_ulong val)
> >      CPUPPCState *env = &cpu->env;
> >  
> >      env->spr[SPR_LPCR] = val & pcc->lpcr_mask;
> > -    env->rmls = rmls_limit(cpu);
> >      ppc_hash64_update_vrma(cpu);
> >  }
> >  
> 

-- 
David Gibson			| I'll have my music baroque, and my code
david AT gibson.dropbear.id.au	| minimalist, thank you.  NOT _the_ _other_
				| _way_ _around_!
http://www.ozlabs.org/~dgibson

[-- Attachment #2: signature.asc --]
[-- Type: application/pgp-signature, Size: 833 bytes --]

  reply	other threads:[~2020-02-27 21:56 UTC|newest]

Thread overview: 45+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-02-24 23:37 [PATCH v6 00/18] target/ppc: Correct some errors with real mode handling David Gibson
2020-02-24 23:37 ` [PATCH v6 01/18] pseries: Update SLOF firmware image David Gibson
2020-02-24 23:37 ` [PATCH v6 02/18] ppc: Remove stub support for 32-bit hypervisor mode David Gibson
2020-02-25  6:31   ` Greg Kurz
2020-02-24 23:37 ` [PATCH v6 03/18] ppc: Remove stub of PPC970 HID4 implementation David Gibson
2020-02-24 23:37 ` [PATCH v6 04/18] target/ppc: Correct handling of real mode accesses with vhyp on hash MMU David Gibson
2020-02-25 10:29   ` Greg Kurz
2020-02-24 23:37 ` [PATCH v6 05/18] target/ppc: Introduce ppc_hash64_use_vrma() helper David Gibson
2020-02-25  0:12   ` Fabiano Rosas
2020-02-25 10:30   ` Greg Kurz
2020-02-24 23:37 ` [PATCH v6 06/18] spapr, ppc: Remove VPM0/RMLS hacks for POWER9 David Gibson
2020-02-25 11:29   ` Greg Kurz
2020-02-25 15:58     ` Greg Kurz
2020-02-26  1:00       ` David Gibson
2020-02-24 23:37 ` [PATCH v6 07/18] target/ppc: Remove RMOR register from POWER9 & POWER10 David Gibson
2020-02-25 11:30   ` Greg Kurz
2020-02-24 23:37 ` [PATCH v6 08/18] target/ppc: Use class fields to simplify LPCR masking David Gibson
2020-02-25 15:48   ` Greg Kurz
2020-02-24 23:37 ` [PATCH v6 09/18] target/ppc: Streamline calculation of RMA limit from LPCR[RMLS] David Gibson
2020-02-25 17:05   ` Greg Kurz
2020-02-25 22:47     ` Greg Kurz
2020-02-26  1:04       ` David Gibson
2020-02-26  7:56         ` Greg Kurz
2020-02-27  4:25           ` David Gibson
2020-02-24 23:37 ` [PATCH v6 10/18] target/ppc: Correct RMLS table David Gibson
2020-02-26  8:23   ` Greg Kurz
2020-02-24 23:37 ` [PATCH v6 11/18] target/ppc: Only calculate RMLS derived RMA limit on demand David Gibson
2020-02-26 13:24   ` Greg Kurz
2020-02-27  4:33     ` David Gibson [this message]
2020-02-24 23:37 ` [PATCH v6 12/18] target/ppc: Don't store VRMA SLBE persistently David Gibson
2020-02-25  0:25   ` Fabiano Rosas
2020-02-26 13:29   ` Greg Kurz
2020-02-24 23:37 ` [PATCH v6 13/18] spapr: Don't use weird units for MIN_RMA_SLOF David Gibson
2020-02-25  7:49   ` Cédric Le Goater
2020-02-26 13:32   ` Greg Kurz
2020-02-24 23:37 ` [PATCH v6 14/18] spapr,ppc: Simplify signature of kvmppc_rma_size() David Gibson
2020-02-24 23:37 ` [PATCH v6 15/18] spapr: Don't attempt to clamp RMA to VRMA constraint David Gibson
2020-02-24 23:37 ` [PATCH v6 16/18] spapr: Don't clamp RMA to 16GiB on new machine types David Gibson
2020-02-24 23:37 ` [PATCH v6 17/18] spapr: Clean up RMA size calculation David Gibson
2020-02-25 11:07   ` Philippe Mathieu-Daudé
2020-02-26  1:08     ` David Gibson
2020-02-26 13:37   ` Greg Kurz
2020-02-27  6:04     ` David Gibson
2020-02-24 23:37 ` [PATCH v6 18/18] spapr: Fold spapr_node0_size() into its only caller David Gibson
2020-02-26 14:47   ` Greg Kurz

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20200227043341.GL41629@umbus.fritz.box \
    --to=david@gibson.dropbear.id.au \
    --cc=aik@ozlabs.ru \
    --cc=clg@kaod.org \
    --cc=edgar.iglesias@gmail.com \
    --cc=farosas@linux.ibm.com \
    --cc=groug@kaod.org \
    --cc=imammedo@redhat.com \
    --cc=lvivier@redhat.com \
    --cc=mark.cave-ayland@ilande.co.uk \
    --cc=mst@redhat.com \
    --cc=paulus@samba.org \
    --cc=pbonzini@redhat.com \
    --cc=qemu-devel@nongnu.org \
    --cc=qemu-ppc@nongnu.org \
    --cc=thuth@redhat.com \
    --cc=xiaoguangrong.eric@gmail.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.