All of lore.kernel.org
 help / color / mirror / Atom feed
From: Arkadiusz Hiler <arkadiusz.hiler@intel.com>
To: Kunal Joshi <kunal1.joshi@intel.com>
Cc: igt-dev@lists.freedesktop.org, petri.latvala@intel.com
Subject: Re: [igt-dev] [PATCH i-g-t v4] tests/kms_chamelium: Add support to validate RGB/YUV pixel formats
Date: Fri, 6 Mar 2020 16:29:20 +0200	[thread overview]
Message-ID: <20200306142920.a3g65eixtqkwnucc@ahiler-desk1.fi.intel.com> (raw)
In-Reply-To: <1583452975-8507-2-git-send-email-kunal1.joshi@intel.com>

On Fri, Mar 06, 2020 at 05:32:55AM +0530, Kunal Joshi wrote:
> Currently, only hard coded pixel formats are validated which are not
> generic across platforms which leads to SKIPS.
> Added support to validate only those pixel formats which are supported by
> platform. Covering both RGB and YUV pixel formats.
> 
> v2: added support for RGB pixel formats (Swati)
> v3: simplified constraint and made it more readable (Petri)
> v4: -used igt_format_str instead of macro to print fourcc code (Ville)
>     -dropped patch#1 because of above change
> 
> Signed-off-by: Kunal Joshi <kunal1.joshi@intel.com>
> ---
>  tests/kms_chamelium.c | 124 +++++++++++++++++++-------------------------------
>  1 file changed, 48 insertions(+), 76 deletions(-)
> 
> diff --git a/tests/kms_chamelium.c b/tests/kms_chamelium.c
> index 5c4a189..a0ec925 100644
> --- a/tests/kms_chamelium.c
> +++ b/tests/kms_chamelium.c
> @@ -2612,6 +2612,14 @@ static const struct edid *get_edid(enum test_edid edid)
>  			if (chamelium_port_get_type(port) == \
>  			    DRM_MODE_CONNECTOR_ ## type__)
>  
> +#define connector_subtest_start(name__, type__)              \
> +	igt_subtest_with_dynamic(name__)                     \
> +		for_each_port(p, port)                       \
> +			if (chamelium_port_get_type(port) == \
> +			    DRM_MODE_CONNECTOR_ ## type__) {
> +
> +#define connector_subtest_end }

I agree with petri on having explicit {}. All the other macros are
following that, e.g.: igt_subtest.

#define connector_subtest_start(name__, type__)              \
       igt_subtest_with_dynamic(name__)                     \
               for_each_port(p, port)                       \
                       if (chamelium_port_get_type(port) == \
                           DRM_MODE_CONNECTOR_ ## type__)


connector_subtest_start("hdmi-rgb-pixel-format", HDMIA) {
 /* ... */
}

> @@ -2817,54 +2825,31 @@ igt_main
>  					       CHAMELIUM_CHECK_CRC, 3);
>  
>  		igt_describe(test_display_one_mode_desc);
> -		connector_subtest("hdmi-crc-argb8888", HDMIA)
> -			test_display_one_mode(&data, port, DRM_FORMAT_ARGB8888,
> -					      CHAMELIUM_CHECK_CRC, 1);
> -
> -		igt_describe(test_display_one_mode_desc);
> -		connector_subtest("hdmi-crc-abgr8888", HDMIA)
> -			test_display_one_mode(&data, port, DRM_FORMAT_ABGR8888,
> -					      CHAMELIUM_CHECK_CRC, 1);
> -
> -		igt_describe(test_display_one_mode_desc);
> -		connector_subtest("hdmi-crc-xrgb8888", HDMIA)
> -			test_display_one_mode(&data, port, DRM_FORMAT_XRGB8888,
> -					      CHAMELIUM_CHECK_CRC, 1);
> +		connector_subtest_start("hdmi-rgb-pixel-format", HDMIA)

you are dropping few thing from the titles, especially information that
this is chamelium CRC tests

how about naming them:
  hdmi-crc-nonplanar-formats instead of rgb
  hdmi-crc-planar-formats instead of yuv

and then having the dunamic subsubtests named after the format alone, so
the end result would be like this:

igt@kms_chamelium@hdmi-crc-nonplanar-formats@rgb888

other than that looks good to me, thanks! :-)

-- 
Cheers,
Arek
_______________________________________________
igt-dev mailing list
igt-dev@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/igt-dev

  parent reply	other threads:[~2020-03-06 14:29 UTC|newest]

Thread overview: 8+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-03-06  0:02 [igt-dev] [PATCH i-g-t v4] Test platform supported pixel formats through chamelium Kunal Joshi
2020-03-06  0:02 ` [igt-dev] [PATCH i-g-t v4] tests/kms_chamelium: Add support to validate RGB/YUV pixel formats Kunal Joshi
2020-03-06 13:06   ` Petri Latvala
2020-03-09  1:07     ` Kunal Joshi
2020-03-06 14:29   ` Arkadiusz Hiler [this message]
2020-03-09  1:09     ` Kunal Joshi
2020-03-06  7:47 ` [igt-dev] ✓ Fi.CI.BAT: success for " Patchwork
2020-03-07  1:24 ` [igt-dev] ✓ Fi.CI.IGT: " Patchwork

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20200306142920.a3g65eixtqkwnucc@ahiler-desk1.fi.intel.com \
    --to=arkadiusz.hiler@intel.com \
    --cc=igt-dev@lists.freedesktop.org \
    --cc=kunal1.joshi@intel.com \
    --cc=petri.latvala@intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.