From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: X-Spam-Checker-Version: SpamAssassin 3.4.0 (2014-02-07) on aws-us-west-2-korg-lkml-1.web.codeaurora.org X-Spam-Level: * X-Spam-Status: No, score=1.5 required=3.0 tests=HEADER_FROM_DIFFERENT_DOMAINS, PDS_HP_HELO_NORDNS,RDNS_NONE,SPF_HELO_NONE,SPF_NONE autolearn=no autolearn_force=no version=3.4.0 Received: from mail-pl1-f195.google.com ([209.85.214.195]:39416 "EHLO mail-pl1-f195.google.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1729921AbgCKQRa (ORCPT ); Wed, 11 Mar 2020 12:17:30 -0400 Received: by mail-pl1-f195.google.com with SMTP id j20so1323224pll.6 for ; Wed, 11 Mar 2020 09:17:30 -0700 (PDT) Date: Wed, 11 Mar 2020 09:17:26 -0700 From: Matthias Kaehlcke To: Doug Anderson Cc: Maulik Shah , Andy Gross , Bjorn Andersson , Rajendra Nayak , Evan Green , Stephen Boyd , Lina Iyer , linux-arm-msm , LKML Subject: Re: [RFT PATCH 1/9] drivers: qcom: rpmh-rsc: Clean code reading/writing regs/cmds Message-ID: <20200311161726.GA144492@google.com> References: <20200306235951.214678-1-dianders@chromium.org> <20200306155707.RFT.1.I1b754137e8089e46cf33fc2ea270734ec3847ec4@changeid> <85758e97-8c0c-5c4e-24ad-d3e8b2b01d3c@codeaurora.org> MIME-Version: 1.0 Content-Type: text/plain; charset=utf-8 Content-Disposition: inline In-Reply-To: Sender: linux-kernel-owner@vger.kernel.org List-ID: Hi, On Wed, Mar 11, 2020 at 08:03:27AM -0700, Doug Anderson wrote: > Hi, > > On Wed, Mar 11, 2020 at 1:47 AM Maulik Shah wrote: > > > > Hi, > > > > On 3/7/2020 5:29 AM, Douglas Anderson wrote: > > > This patch makes two changes, both of which should be no-ops: > > > > > > 1. Make read_tcs_reg() / read_tcs_cmd() symmetric to write_tcs_reg() / > > > write_tcs_cmd(). > > > > i agree that there are two different write function doing same thing except last addition (RSC_DRV_CMD_OFFSET * cmd_id) > > > > can you please rename write_tcs_cmd() to write_tcs_reg(), add above operation in it, and then remove existing write_tcs_reg(). > > this way we have only one read and one write function. > > > > so at the end we will two function as, > > > > static u32 read_tcs_reg(struct rsc_drv *drv, int reg, int tcs_id, int cmd_id) > > { > > return readl_relaxed(drv->tcs_base + reg + RSC_DRV_TCS_OFFSET * tcs_id + > > RSC_DRV_CMD_OFFSET * cmd_id); > > } > > > > static void write_tcs_reg(struct rsc_drv *drv, int reg, int tcs_id, int cmd_id, > > u32 data) > > { > > writel_relaxed(data, drv->tcs_base + reg + RSC_DRV_TCS_OFFSET * tcs_id + > > RSC_DRV_CMD_OFFSET * cmd_id); > > } > > I can if you insist and this is still better than the existing > (inconsistent) code. > > ...but I still feel that having two functions adds value here. > > > Anyone else who is CCed want to weigh in and tie break? I agree with Doug, having two functions makes the code that calls them clearer. It makes it evident when a command is read/written and doesn't require a useless extra parameter when accessing a non-command register. > > > 2. Change the order of operations in the above functions to make it > > > more obvious to me what the math is doing. Specifically first you > > > want to find the right TCS, then the right register, and then > > > multiply by the command ID if necessary. > > With above change, i don't think you need to re-order this. > > specifically from tcs->base, we find right "reg" first and if it happens to be tcs then intended tcs, and then cmd inside tcs. > > There was never any "need" to re-order. That math works out to be the > same. This is just clearer. > > As an example, let's look at this: > > struct point { > int x; > int y; > }; > struct point points[10]; > > Let's say you have: > void *points_base = &(points[0]); > > ...and now you want to find &(points[5].y). What does your math look like? > > a) points_base + (sizeof(struct point) * 5) + 4 ; > > ...or... > > b) points_base + 4 + (sizeof(struct point) * 5); > > > Both calculations give the same result, but I am arguring that "a)" is > more intuitive. Specifically you deal with the array access first and > then deal with the offset within the structure that you found. +1