All of lore.kernel.org
 help / color / mirror / Atom feed
From: Kees Cook <keescook@chromium.org>
To: Alexey Gladkov <gladkov.alexey@gmail.com>
Cc: LKML <linux-kernel@vger.kernel.org>,
	Kernel Hardening <kernel-hardening@lists.openwall.com>,
	Linux API <linux-api@vger.kernel.org>,
	Linux FS Devel <linux-fsdevel@vger.kernel.org>,
	Linux Security Module <linux-security-module@vger.kernel.org>,
	Akinobu Mita <akinobu.mita@gmail.com>,
	Alexander Viro <viro@zeniv.linux.org.uk>,
	Alexey Dobriyan <adobriyan@gmail.com>,
	Alexey Gladkov <legion@kernel.org>,
	Andrew Morton <akpm@linux-foundation.org>,
	Andy Lutomirski <luto@kernel.org>,
	Daniel Micay <danielmicay@gmail.com>,
	Djalal Harouni <tixxdz@gmail.com>,
	"Dmitry V . Levin" <ldv@altlinux.org>,
	"Eric W . Biederman" <ebiederm@xmission.com>,
	Greg Kroah-Hartman <gregkh@linuxfoundation.org>,
	Ingo Molnar <mingo@kernel.org>,
	"J . Bruce Fields" <bfields@fieldses.org>,
	Jeff Layton <jlayton@poochiereds.net>,
	Jonathan Corbet <corbet@lwn.net>,
	Linus Torvalds <torvalds@linux-foundation.org>,
	Oleg Nesterov <oleg@redhat.com>
Subject: Re: [PATCH v9 9/8] proc: use named enums for better readability
Date: Wed, 25 Mar 2020 12:16:17 -0700	[thread overview]
Message-ID: <202003251216.FD5E296@keescook> (raw)
In-Reply-To: <20200325174245.298009-1-gladkov.alexey@gmail.com>

On Wed, Mar 25, 2020 at 06:42:45PM +0100, Alexey Gladkov wrote:
> Signed-off-by: Alexey Gladkov <gladkov.alexey@gmail.com>

I love these kinds of cleanups. :)

Reviewed-by: Kees Cook <keescook@chromium.org>

-Kees

> ---
>  fs/proc/base.c               | 2 +-
>  fs/proc/inode.c              | 2 +-
>  fs/proc/root.c               | 4 ++--
>  include/linux/proc_fs.h      | 6 +++---
>  include/uapi/linux/proc_fs.h | 2 +-
>  5 files changed, 8 insertions(+), 8 deletions(-)
> 
> diff --git a/fs/proc/base.c b/fs/proc/base.c
> index a836979e42fe..608d60fb79fb 100644
> --- a/fs/proc/base.c
> +++ b/fs/proc/base.c
> @@ -699,7 +699,7 @@ int proc_setattr(struct dentry *dentry, struct iattr *attr)
>   */
>  static bool has_pid_permissions(struct proc_fs_info *fs_info,
>  				 struct task_struct *task,
> -				 int hide_pid_min)
> +				 enum proc_hidepid hide_pid_min)
>  {
>  	/*
>  	 * If 'hidpid' mount option is set force a ptrace check,
> diff --git a/fs/proc/inode.c b/fs/proc/inode.c
> index a462fd111719..7870e0be0a1f 100644
> --- a/fs/proc/inode.c
> +++ b/fs/proc/inode.c
> @@ -165,7 +165,7 @@ void proc_invalidate_siblings_dcache(struct hlist_head *inodes, spinlock_t *lock
>  		deactivate_super(old_sb);
>  }
>  
> -static inline const char *hidepid2str(int v)
> +static inline const char *hidepid2str(enum proc_hidepid v)
>  {
>  	switch (v) {
>  		case HIDEPID_OFF: return "off";
> diff --git a/fs/proc/root.c b/fs/proc/root.c
> index 42f3ee05c584..de7cee435621 100644
> --- a/fs/proc/root.c
> +++ b/fs/proc/root.c
> @@ -32,9 +32,9 @@
>  struct proc_fs_context {
>  	struct proc_fs_info	*fs_info;
>  	unsigned int		mask;
> -	int			hidepid;
> +	enum proc_hidepid	hidepid;
>  	int			gid;
> -	int			pidonly;
> +	enum proc_pidonly	pidonly;
>  };
>  
>  enum proc_param {
> diff --git a/include/linux/proc_fs.h b/include/linux/proc_fs.h
> index d259817ec913..b9f7ecd7f61f 100644
> --- a/include/linux/proc_fs.h
> +++ b/include/linux/proc_fs.h
> @@ -29,7 +29,7 @@ struct proc_ops {
>  };
>  
>  /* definitions for proc mount option pidonly */
> -enum {
> +enum proc_pidonly {
>  	PROC_PIDONLY_OFF = 0,
>  	PROC_PIDONLY_ON  = 1,
>  };
> @@ -39,8 +39,8 @@ struct proc_fs_info {
>  	struct dentry *proc_self;        /* For /proc/self */
>  	struct dentry *proc_thread_self; /* For /proc/thread-self */
>  	kgid_t pid_gid;
> -	int hide_pid;
> -	int pidonly;
> +	enum proc_hidepid hide_pid;
> +	enum proc_pidonly pidonly;
>  };
>  
>  static inline struct proc_fs_info *proc_sb_info(struct super_block *sb)
> diff --git a/include/uapi/linux/proc_fs.h b/include/uapi/linux/proc_fs.h
> index dc6d717aa6ec..f5fe0e8dcfe4 100644
> --- a/include/uapi/linux/proc_fs.h
> +++ b/include/uapi/linux/proc_fs.h
> @@ -3,7 +3,7 @@
>  #define _UAPI_PROC_FS_H
>  
>  /* definitions for hide_pid field */
> -enum {
> +enum proc_hidepid {
>  	HIDEPID_OFF            = 0,
>  	HIDEPID_NO_ACCESS      = 1,
>  	HIDEPID_INVISIBLE      = 2,
> -- 
> 2.25.2
> 

-- 
Kees Cook

  reply	other threads:[~2020-03-25 19:16 UTC|newest]

Thread overview: 15+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-03-24 20:44 [PATCH RESEND v9 0/8] proc: modernize proc to support multiple private instances Alexey Gladkov
2020-03-24 20:44 ` [PATCH RESEND v9 1/8] proc: rename struct proc_fs_info to proc_fs_opts Alexey Gladkov
2020-03-24 20:44 ` [PATCH RESEND v9 2/8] proc: allow to mount many instances of proc in one pid namespace Alexey Gladkov
2020-03-24 20:44 ` [PATCH RESEND v9 3/8] proc: move hide_pid, pid_gid from pid_namespace to proc_fs_info Alexey Gladkov
2020-03-24 21:21   ` Linus Torvalds
2020-03-24 21:21     ` Linus Torvalds
2020-03-25 17:42     ` [PATCH v9 9/8] proc: use named enums for better readability Alexey Gladkov
2020-03-25 19:16       ` Kees Cook [this message]
2020-03-25 18:00     ` [PATCH RESEND v9 3/8] proc: move hide_pid, pid_gid from pid_namespace to proc_fs_info Alexey Dobriyan
2020-03-25 19:04       ` Alexey Gladkov
2020-03-24 20:44 ` [PATCH RESEND v9 4/8] proc: instantiate only pids that we can ptrace on 'hidepid=4' mount option Alexey Gladkov
2020-03-24 20:44 ` [PATCH RESEND v9 5/8] proc: add option to mount only a pids subset Alexey Gladkov
2020-03-24 20:44 ` [PATCH RESEND v9 6/8] docs: proc: add documentation for "hidepid=4" and "subset=pidfs" options and new mount behavior Alexey Gladkov
2020-03-24 20:44 ` [PATCH RESEND v9 7/8] proc: move hidepid values to uapi as they are user interface to mount Alexey Gladkov
2020-03-24 20:44 ` [PATCH RESEND v9 8/8] proc: use human-readable values for hidehid Alexey Gladkov

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=202003251216.FD5E296@keescook \
    --to=keescook@chromium.org \
    --cc=adobriyan@gmail.com \
    --cc=akinobu.mita@gmail.com \
    --cc=akpm@linux-foundation.org \
    --cc=bfields@fieldses.org \
    --cc=corbet@lwn.net \
    --cc=danielmicay@gmail.com \
    --cc=ebiederm@xmission.com \
    --cc=gladkov.alexey@gmail.com \
    --cc=gregkh@linuxfoundation.org \
    --cc=jlayton@poochiereds.net \
    --cc=kernel-hardening@lists.openwall.com \
    --cc=ldv@altlinux.org \
    --cc=legion@kernel.org \
    --cc=linux-api@vger.kernel.org \
    --cc=linux-fsdevel@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-security-module@vger.kernel.org \
    --cc=luto@kernel.org \
    --cc=mingo@kernel.org \
    --cc=oleg@redhat.com \
    --cc=tixxdz@gmail.com \
    --cc=torvalds@linux-foundation.org \
    --cc=viro@zeniv.linux.org.uk \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.