All of lore.kernel.org
 help / color / mirror / Atom feed
From: David Sterba <dsterba@suse.cz>
To: Qu Wenruo <wqu@suse.com>
Cc: linux-btrfs@vger.kernel.org
Subject: Re: [PATCH v2 00/39] btrfs: qgroup: Use backref cache based backref walk for commit roots
Date: Thu, 2 Apr 2020 18:18:28 +0200	[thread overview]
Message-ID: <20200402161828.GD5920@twin.jikos.cz> (raw)
In-Reply-To: <20200326083316.48847-1-wqu@suse.com>

I went through the patches, overall like the patch separation made it
easy. Thanks.

There are some things that I fixed or updated.

On Thu, Mar 26, 2020 at 04:32:37PM +0800, Qu Wenruo wrote:
> Qu Wenruo (39):
>   btrfs: backref: Introduce the skeleton of btrfs_backref_iter
>   btrfs: backref: Implement btrfs_backref_iter_next()
>   btrfs: relocation: Use btrfs_backref_iter infrastructure
>   btrfs: relocation: Rename mark_block_processed() and
>     __mark_block_processed()
>   btrfs: relocation: Add backref_cache::pending_edge and
>     backref_cache::useless_node members
>   btrfs: relocation: Add backref_cache::fs_info member
>   btrfs: relocation: Make reloc root search specific for relocation
>     backref cache
>   btrfs: relocation: Refactor direct tree backref processing into its
>     own function
>   btrfs: relocation: Refactor indirect tree backref processing into its
>     own function
>   btrfs: relocation: Use wrapper to replace open-coded edge linking
>   btrfs: relocation: Specify essential members for alloc_backref_node()
>   btrfs: relocation: Remove the open-coded goto loop for breadth-first
>     search
>   btrfs: relocation: Refactor the finishing part of upper linkage into
>     finish_upper_links()
>   btrfs: relocation: Refactor the useless nodes handling into its own
>     function
>   btrfs: relocation: Add btrfs_ prefix for backref_node/edge/cache
>   btrfs: Move btrfs_backref_(node|edge|cache) structures to backref.h
>   btrfs: Rename tree_entry to simple_node and export it
>   btrfs: Rename backref_cache_init() to btrfs_backref_cache_init() and
>     move it to backref.c
>   btrfs: Rename alloc_backref_node() to btrfs_backref_alloc_node() and
>     move it backref.c
>   btrfs: Rename alloc_backref_edge() to btrfs_backref_alloc_edge() and
>     move it backref.c
>   btrfs: Rename link_backref_edge() to btrfs_backref_link_edge() and
>     move it backref.h
>   btrfs: Rename free_backref_(node|edge) to
>     btrfs_backref_free_(node|edge) and move them to backref.h
>   btrfs: Rename drop_backref_node() to btrfs_backref_drop_node() and
>     move its needed facilities to backref.h
>   btrfs: Rename remove_backref_node() to btrfs_backref_cleanup_node()
>     and move it to backref.c
>   btrfs: Rename backref_cache_cleanup() to btrfs_backref_release_cache()
>     and move it to backref.c
>   btrfs: Rename backref_tree_panic() to btrfs_backref_panic(), and move
>     it to backref.c
>   btrfs: Rename should_ignore_root() to btrfs_should_ignore_reloc_root()
>     and export it
>   btrfs: relocation: Open-code read_fs_root() for
>     handle_indirect_tree_backref()
>   btrfs: Rename handle_one_tree_block() to btrfs_backref_add_tree_node()
>     and move it to backref.c
>   btrfs: Rename finish_upper_links() to
>     btrfs_backref_finish_upper_links() and move it to backref.c
>   btrfs: relocation: Move error handling of build_backref_tree() to
>     backref.c
>   btrfs: backref: Only ignore reloc roots for indrect backref resolve if
>     the backref cache is for reloction purpose

This subject line is way too long and also quite hard to grasp what's
the patch actually doing. The other subjects about moving functions are
too long as well, I understand you want to put the new name there too,
but it's IMHO not necessary. When the function is 'renamed and moved',
the details are in the patch. So the final list of subject lines I got
to:

  btrfs: backref: introduce the skeleton of btrfs_backref_iter
  btrfs: backref: implement btrfs_backref_iter_next()
  btrfs: reloc: use btrfs_backref_iter infrastructure
  btrfs: reloc: rename mark_block_processed and __mark_block_processed
  btrfs: reloc: add backref_cache::pending_edge and backref_cache::useless_node
  btrfs: reloc: add backref_cache::fs_info member
  btrfs: reloc: make reloc root search-specific for relocation backref cache
  btrfs: reloc: refactor direct tree backref processing into its own function
  btrfs: reloc: refactor indirect tree backref processing into its own function
  btrfs: reloc: use wrapper to replace open-coded edge linking
  btrfs: reloc: pass essential members for alloc_backref_node()
  btrfs: reloc: remove the open-coded goto loop for breadth-first search
  btrfs: reloc: refactor finishing part of upper linkage into finish_upper_links()
  btrfs: reloc: refactor useless nodes handling into its own function
  btrfs: reloc: add btrfs_ prefix for backref_node/edge/cache
  btrfs: move btrfs_backref_(node|edge|cache) structures to backref.h
  btrfs: rename tree_entry to simple_node and export it
  btrfs: rename and move backref_cache_init()
  btrfs: rename and move alloc_backref_node()
  btrfs: rename and move alloc_backref_edge()
  btrfs: rename and move link_backref_edge()
  btrfs: rename and move free_backref_(node|edge)
  btrfs: rename and move drop_backref_node()
  btrfs: rename and move remove_backref_node()
  btrfs: rename and move backref_cache_cleanup()
  btrfs: rename and move backref_tree_panic()
  btrfs: rename and move should_ignore_root()
  btrfs: reloc: open-code read_fs_root() for handle_indirect_tree_backref()
  btrfs: rename and move handle_one_tree_block()
  btrfs: rename and move finish_upper_links()
  btrfs: reloc: move error handling of build_backref_tree() to backref.c
  btrfs: backref: distinguish reloc and non-reloc use of indirect resolution

For a cleanup series I'd really like to see more focus on making the
code also look better, namely when the comments are moved/updated.

There's a common style that the old comments don't follow, eg. no
capital letter at the beginning, or not using the full line width. There
are also grammar mistakes or spelling typos. It's ok to fix that on the
fly.

The function comments should go to the .c file, not the headers (eg.
btrfs_backref_finish_upper_links, btrfs_backref_add_tree_node,
btrfs_backref_cleanup_node).

When you add something to the end of a header file, please keep an empty
line before the last #endif.

For the static inlines I want to do another round, most of them are
acceptable so I'll look for some clear examples where it's misused. A
quick grep over the code base shows there are many so it would be a
wider cleanup.

  parent reply	other threads:[~2020-04-02 16:19 UTC|newest]

Thread overview: 52+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-03-26  8:32 [PATCH v2 00/39] btrfs: qgroup: Use backref cache based backref walk for commit roots Qu Wenruo
2020-03-26  8:32 ` [PATCH v2 01/39] btrfs: backref: Introduce the skeleton of btrfs_backref_iter Qu Wenruo
2020-04-01 15:37   ` David Sterba
2020-04-01 23:31     ` Qu Wenruo
2020-04-02  1:01       ` David Sterba
2020-04-02  1:27         ` Qu Wenruo
2020-03-26  8:32 ` [PATCH v2 02/39] btrfs: backref: Implement btrfs_backref_iter_next() Qu Wenruo
2020-03-26  8:32 ` [PATCH v2 03/39] btrfs: relocation: Use btrfs_backref_iter infrastructure Qu Wenruo
2020-03-26  8:32 ` [PATCH v2 04/39] btrfs: relocation: Rename mark_block_processed() and __mark_block_processed() Qu Wenruo
2020-03-26  8:32 ` [PATCH v2 05/39] btrfs: relocation: Add backref_cache::pending_edge and backref_cache::useless_node members Qu Wenruo
2020-03-26  8:32 ` [PATCH v2 06/39] btrfs: relocation: Add backref_cache::fs_info member Qu Wenruo
2020-03-26  8:32 ` [PATCH v2 07/39] btrfs: relocation: Make reloc root search specific for relocation backref cache Qu Wenruo
2020-03-26  8:32 ` [PATCH v2 08/39] btrfs: relocation: Refactor direct tree backref processing into its own function Qu Wenruo
2020-03-26  8:32 ` [PATCH v2 09/39] btrfs: relocation: Refactor indirect " Qu Wenruo
2020-03-26  8:32 ` [PATCH v2 10/39] btrfs: relocation: Use wrapper to replace open-coded edge linking Qu Wenruo
2020-03-26  8:32 ` [PATCH v2 11/39] btrfs: relocation: Specify essential members for alloc_backref_node() Qu Wenruo
2020-03-26  8:32 ` [PATCH v2 12/39] btrfs: relocation: Remove the open-coded goto loop for breadth-first search Qu Wenruo
2020-03-26  8:32 ` [PATCH v2 13/39] btrfs: relocation: Refactor the finishing part of upper linkage into finish_upper_links() Qu Wenruo
2020-03-26  8:32 ` [PATCH v2 14/39] btrfs: relocation: Refactor the useless nodes handling into its own function Qu Wenruo
2020-03-26  8:32 ` [PATCH v2 15/39] btrfs: relocation: Add btrfs_ prefix for backref_node/edge/cache Qu Wenruo
2020-03-26  8:32 ` [PATCH v2 16/39] btrfs: Move btrfs_backref_(node|edge|cache) structures to backref.h Qu Wenruo
2020-03-26  8:32 ` [PATCH v2 17/39] btrfs: Rename tree_entry to simple_node and export it Qu Wenruo
2020-04-01 15:48   ` David Sterba
2020-04-01 23:40     ` Qu Wenruo
2020-04-02  0:52       ` Qu Wenruo
2020-04-02  1:09       ` David Sterba
2020-04-02  1:32         ` Qu Wenruo
2020-03-26  8:32 ` [PATCH v2 18/39] btrfs: Rename backref_cache_init() to btrfs_backref_cache_init() and move it to backref.c Qu Wenruo
2020-03-26  8:32 ` [PATCH v2 19/39] btrfs: Rename alloc_backref_node() to btrfs_backref_alloc_node() and move it backref.c Qu Wenruo
2020-03-26  8:32 ` [PATCH v2 20/39] btrfs: Rename alloc_backref_edge() to btrfs_backref_alloc_edge() " Qu Wenruo
2020-03-26  8:32 ` [PATCH v2 21/39] btrfs: Rename link_backref_edge() to btrfs_backref_link_edge() and move it backref.h Qu Wenruo
2020-03-26  8:32 ` [PATCH v2 22/39] btrfs: Rename free_backref_(node|edge) to btrfs_backref_free_(node|edge) and move them to backref.h Qu Wenruo
2020-03-26  8:33 ` [PATCH v2 23/39] btrfs: Rename drop_backref_node() to btrfs_backref_drop_node() and move its needed facilities " Qu Wenruo
2020-03-26  8:33 ` [PATCH v2 24/39] btrfs: Rename remove_backref_node() to btrfs_backref_cleanup_node() and move it to backref.c Qu Wenruo
2020-03-26  8:33 ` [PATCH v2 25/39] btrfs: Rename backref_cache_cleanup() to btrfs_backref_release_cache() " Qu Wenruo
2020-03-26  8:33 ` [PATCH v2 26/39] btrfs: Rename backref_tree_panic() to btrfs_backref_panic(), " Qu Wenruo
2020-03-26  8:33 ` [PATCH v2 27/39] btrfs: Rename should_ignore_root() to btrfs_should_ignore_reloc_root() and export it Qu Wenruo
2020-03-26  8:33 ` [PATCH v2 28/39] btrfs: relocation: Open-code read_fs_root() for handle_indirect_tree_backref() Qu Wenruo
2020-03-26  8:33 ` [PATCH v2 29/39] btrfs: Rename handle_one_tree_block() to btrfs_backref_add_tree_node() and move it to backref.c Qu Wenruo
2020-03-26  8:33 ` [PATCH v2 30/39] btrfs: Rename finish_upper_links() to btrfs_backref_finish_upper_links() " Qu Wenruo
2020-03-26  8:33 ` [PATCH v2 31/39] btrfs: relocation: Move error handling of build_backref_tree() " Qu Wenruo
2020-03-26  8:33 ` [PATCH v2 32/39] btrfs: backref: Only ignore reloc roots for indrect backref resolve if the backref cache is for reloction purpose Qu Wenruo
2020-03-26  8:33 ` [PATCH v2 33/39] btrfs: qgroup: Introduce qgroup backref cache Qu Wenruo
2020-03-26  8:33 ` [PATCH v2 34/39] btrfs: qgroup: Introduce qgroup_backref_cache_build() function Qu Wenruo
2020-03-26  8:33 ` [PATCH v2 35/39] btrfs: qgroup: Introduce a function to iterate through backref_cache to find all parents for specified node Qu Wenruo
2020-03-26  8:33 ` [PATCH v2 36/39] btrfs: qgroup: Introduce helpers to get needed tree block info Qu Wenruo
2020-03-26  8:33 ` [PATCH v2 37/39] btrfs: qgroup: Introduce verification for function to ensure old roots ulist matches btrfs_find_all_roots() result Qu Wenruo
2020-03-26  8:33 ` [PATCH v2 38/39] btrfs: qgroup: Introduce a new function to get old_roots ulist using backref cache Qu Wenruo
2020-03-26  8:33 ` [PATCH v2 39/39] btrfs: qgroup: Use backref cache to speed up old_roots search Qu Wenruo
2020-03-27 15:51 ` [PATCH v2 00/39] btrfs: qgroup: Use backref cache based backref walk for commit roots David Sterba
2020-04-02 16:18 ` David Sterba [this message]
2020-04-03 15:44 ` David Sterba

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20200402161828.GD5920@twin.jikos.cz \
    --to=dsterba@suse.cz \
    --cc=linux-btrfs@vger.kernel.org \
    --cc=wqu@suse.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.