All of lore.kernel.org
 help / color / mirror / Atom feed
From: "Darrick J. Wong" <darrick.wong@oracle.com>
To: Dave Chinner <david@fromorbit.com>
Cc: linux-xfs@vger.kernel.org
Subject: Re: [PATCH 08/11] xfs: replace a few open-coded XFS_DQTYPE_REC_MASK uses
Date: Thu, 16 Jul 2020 18:07:15 -0700	[thread overview]
Message-ID: <20200717010715.GL3151642@magnolia> (raw)
In-Reply-To: <20200717000242.GU2005@dread.disaster.area>

On Fri, Jul 17, 2020 at 10:02:42AM +1000, Dave Chinner wrote:
> On Wed, Jul 15, 2020 at 11:46:10PM -0700, Darrick J. Wong wrote:
> > From: Darrick J. Wong <darrick.wong@oracle.com>
> > 
> > Fix a few places where we open-coded this mask constant.
> > 
> > Signed-off-by: Darrick J. Wong <darrick.wong@oracle.com>
> > ---
> >  fs/xfs/xfs_dquot_item_recover.c |    4 ++--
> >  1 file changed, 2 insertions(+), 2 deletions(-)
> > 
> > 
> > diff --git a/fs/xfs/xfs_dquot_item_recover.c b/fs/xfs/xfs_dquot_item_recover.c
> > index d7eb85c7d394..93178341569a 100644
> > --- a/fs/xfs/xfs_dquot_item_recover.c
> > +++ b/fs/xfs/xfs_dquot_item_recover.c
> > @@ -39,7 +39,7 @@ xlog_recover_dquot_ra_pass2(
> >  	if (item->ri_buf[1].i_len < sizeof(struct xfs_disk_dquot))
> >  		return;
> >  
> > -	type = recddq->d_flags & (XFS_DQTYPE_USER | XFS_DQTYPE_PROJ | XFS_DQTYPE_GROUP);
> > +	type = recddq->d_flags & XFS_DQTYPE_REC_MASK;
> >  	ASSERT(type);
> >  	if (log->l_quotaoffs_flag & type)
> >  		return;
> > @@ -91,7 +91,7 @@ xlog_recover_dquot_commit_pass2(
> >  	/*
> >  	 * This type of quotas was turned off, so ignore this record.
> >  	 */
> > -	type = recddq->d_flags & (XFS_DQTYPE_USER | XFS_DQTYPE_PROJ | XFS_DQTYPE_GROUP);
> > +	type = recddq->d_flags & XFS_DQTYPE_REC_MASK;
> 
> Couldn't these both be converted to xfs_dquot_type(recddq)?

xfs_dquot_type takes a pointer to a incore dquot, not a struct
xfs_disk_dquot, so no.

--D

> Cheers,
> 
> Dave.
> -- 
> Dave Chinner
> david@fromorbit.com

  reply	other threads:[~2020-07-17  1:09 UTC|newest]

Thread overview: 40+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-07-16  6:45 [PATCH v5 00/11] xfs: separate dquot type from flags Darrick J. Wong
2020-07-16  6:45 ` [PATCH 01/11] xfs: drop the type parameter from xfs_dquot_verify Darrick J. Wong
2020-07-16 23:32   ` Dave Chinner
2020-07-21 14:54   ` Christoph Hellwig
2020-07-16  6:45 ` [PATCH 02/11] xfs: rename XFS_DQ_{USER,GROUP,PROJ} to XFS_DQTYPE_* Darrick J. Wong
2020-07-16 23:36   ` Dave Chinner
2020-07-21 14:54   ` Christoph Hellwig
2020-07-16  6:45 ` [PATCH 03/11] xfs: refactor testing if a particular dquot is being enforced Darrick J. Wong
2020-07-16 23:47   ` Dave Chinner
2020-07-21 14:55   ` Christoph Hellwig
2020-07-16  6:45 ` [PATCH 04/11] xfs: remove the XFS_QM_IS[UGP]DQ macros Darrick J. Wong
2020-07-16 23:49   ` Dave Chinner
2020-07-21 14:55   ` Christoph Hellwig
2020-07-16  6:45 ` [PATCH 05/11] xfs: refactor quota type testing Darrick J. Wong
2020-07-16 23:51   ` Dave Chinner
2020-07-21 14:56   ` Christoph Hellwig
2020-07-16  6:45 ` [PATCH 06/11] xfs: always use xfs_dquot_type when extracting type from a dquot Darrick J. Wong
2020-07-16 23:57   ` Dave Chinner
2020-07-21 14:56   ` Christoph Hellwig
2020-07-16  6:46 ` [PATCH 07/11] xfs: remove unnecessary quota type masking Darrick J. Wong
2020-07-17  0:01   ` Dave Chinner
2020-07-21 14:57   ` Christoph Hellwig
2020-07-16  6:46 ` [PATCH 08/11] xfs: replace a few open-coded XFS_DQTYPE_REC_MASK uses Darrick J. Wong
2020-07-17  0:02   ` Dave Chinner
2020-07-17  1:07     ` Darrick J. Wong [this message]
2020-07-17  1:18       ` Dave Chinner
2020-07-21 14:57   ` Christoph Hellwig
2020-07-16  6:46 ` [PATCH 09/11] xfs: create xfs_dqtype_t to represent quota types Darrick J. Wong
2020-07-17  0:08   ` Dave Chinner
2020-07-21 14:58   ` Christoph Hellwig
2020-07-16  6:46 ` [PATCH 10/11] xfs: improve ondisk dquot flags checking Darrick J. Wong
2020-07-17  0:13   ` Dave Chinner
2020-07-17  1:05     ` Darrick J. Wong
2020-07-17  1:11       ` Dave Chinner
2020-07-17  1:12   ` [PATCH v2 " Darrick J. Wong
2020-07-17  1:18     ` Dave Chinner
2020-07-21 14:58     ` Christoph Hellwig
2020-07-16  6:46 ` [PATCH 11/11] xfs: rename the ondisk dquot d_flags to d_type Darrick J. Wong
2020-07-17  0:15   ` Dave Chinner
2020-07-21 14:59   ` Christoph Hellwig

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20200717010715.GL3151642@magnolia \
    --to=darrick.wong@oracle.com \
    --cc=david@fromorbit.com \
    --cc=linux-xfs@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.