All of lore.kernel.org
 help / color / mirror / Atom feed
From: Baolin Wang <baolin.wang@linux.alibaba.com>
To: Christoph Hellwig <hch@lst.de>
Cc: axboe@kernel.dk, ming.lei@redhat.com, baolin.wang7@gmail.com,
	linux-block@vger.kernel.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH v2 2/3] block: Add a new helper to attempt to merge a bio
Date: Thu, 27 Aug 2020 22:30:41 +0800	[thread overview]
Message-ID: <20200827143041.GA122928@VM20190228-100.tbsite.net> (raw)
In-Reply-To: <20200827094415.GA16058@lst.de>

On Thu, Aug 27, 2020 at 11:44:15AM +0200, Christoph Hellwig wrote:
> On Tue, Aug 18, 2020 at 01:45:29PM +0800, Baolin Wang wrote:
> > Meanwhile move the blk_mq_bio_list_merge() into blk-merge.c and
> > rename it as a generic name.
> 
> That should probably a separate patch.

Sure.

> 
> > +		if (blk_attempt_bio_merge(q, rq, bio, nr_segs, false) == BIO_MERGE_OK)
> > +			return true;
> 
> This adds an overly long line.

The checkpatch.pl has increased the default limit to 100 characters, so
I did not get a long line warning. Anyway I will change a new line if
you concern about this.

> > -		if (merged)
> > +		switch (blk_attempt_bio_merge(q, rq, bio, nr_segs, true)) {
> > +		default:
> > +		case BIO_MERGE_NONE:
> > +			continue;
> > +		case BIO_MERGE_OK:
> >  			return true;
> > +		case BIO_MERGE_FAILED:
> > +			return false;
> > +		}
> 
> I don't think we need a default statement here as we handle all
> possible values of the enum.

OK. Will remove it in next version. Thanks.

  reply	other threads:[~2020-08-27 14:31 UTC|newest]

Thread overview: 8+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-08-18  5:45 [PATCH v2 0/3] Some clean-ups for bio merge Baolin Wang
2020-08-18  5:45 ` [PATCH v2 1/3] block: Move bio merge related functions into blk-merge.c Baolin Wang
2020-08-18  5:45 ` [PATCH v2 2/3] block: Add a new helper to attempt to merge a bio Baolin Wang
2020-08-27  9:44   ` Christoph Hellwig
2020-08-27 14:30     ` Baolin Wang [this message]
2020-08-18  5:45 ` [PATCH v2 3/3] block: Remove blk_mq_attempt_merge() function Baolin Wang
2020-08-27  9:44   ` Christoph Hellwig
2020-08-25 13:53 ` [PATCH v2 0/3] Some clean-ups for bio merge Baolin Wang

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20200827143041.GA122928@VM20190228-100.tbsite.net \
    --to=baolin.wang@linux.alibaba.com \
    --cc=axboe@kernel.dk \
    --cc=baolin.wang7@gmail.com \
    --cc=hch@lst.de \
    --cc=linux-block@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=ming.lei@redhat.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.