From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: X-Spam-Checker-Version: SpamAssassin 3.4.0 (2014-02-07) on aws-us-west-2-korg-lkml-1.web.codeaurora.org X-Spam-Level: X-Spam-Status: No, score=-5.3 required=3.0 tests=BAYES_00, HEADER_FROM_DIFFERENT_DOMAINS,MAILING_LIST_MULTI,SPF_HELO_NONE,SPF_PASS, USER_AGENT_SANE_1 autolearn=no autolearn_force=no version=3.4.0 Received: from mail.kernel.org (mail.kernel.org [198.145.29.99]) by smtp.lore.kernel.org (Postfix) with ESMTP id A1E30C43461 for ; Mon, 14 Sep 2020 08:19:34 +0000 (UTC) Received: from vger.kernel.org (vger.kernel.org [23.128.96.18]) by mail.kernel.org (Postfix) with ESMTP id 4B9B821741 for ; Mon, 14 Sep 2020 08:19:34 +0000 (UTC) Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1726240AbgINITc (ORCPT ); Mon, 14 Sep 2020 04:19:32 -0400 Received: from mx2.suse.de ([195.135.220.15]:59616 "EHLO mx2.suse.de" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1726094AbgINITb (ORCPT ); Mon, 14 Sep 2020 04:19:31 -0400 X-Virus-Scanned: by amavisd-new at test-mx.suse.de Received: from relay2.suse.de (unknown [195.135.221.27]) by mx2.suse.de (Postfix) with ESMTP id 5C04CAC46; Mon, 14 Sep 2020 08:19:45 +0000 (UTC) Date: Mon, 14 Sep 2020 10:19:26 +0200 From: Oscar Salvador To: David Hildenbrand Cc: Laurent Dufour , akpm@linux-foundation.org, mhocko@kernel.org, Greg Kroah-Hartman , linux-mm@kvack.org, "Rafael J . Wysocki" , nathanl@linux.ibm.com, cheloha@linux.ibm.com, Tony Luck , Fenghua Yu , linux-ia64@vger.kernel.org, linux-kernel@vger.kernel.org, stable@vger.kernel.org, Michal Hocko Subject: Re: [PATCH 2/3] mm: don't rely on system state to detect hot-plug operations Message-ID: <20200914081921.GA15113@linux> References: <20200911134831.53258-1-ldufour@linux.ibm.com> <20200911134831.53258-3-ldufour@linux.ibm.com> MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: User-Agent: Mutt/1.10.1 (2018-07-13) Sender: linux-kernel-owner@vger.kernel.org Precedence: bulk List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Mon, Sep 14, 2020 at 09:57:46AM +0200, David Hildenbrand wrote: > > /* register memory section under specified node if it spans that node */ > > +struct rmsun_args { > > + int nid; > > + enum memplug_context context; > > +}; Uhmf, that is a not so descriptive name. > Instead of handling this in register_mem_sect_under_node(), I > think it would be better two have two separate > register_mem_sect_under_node() implementations. > > static int register_mem_sect_under_node_hotplug(struct memory_block *mem_blk, > void *arg) > { > const int nid = *(int *)arg; > int ret; > > /* Hotplugged memory has no holes and belongs to a single node. */ > mem_blk->nid = nid; > ret = sysfs_create_link_nowarn(&node_devices[nid]->dev.kobj, > &mem_blk->dev.kobj, > kobject_name(&mem_blk->dev.kobj)); > if (ret) > returnr et; > return sysfs_create_link_nowarn(&mem_blk->dev.kobj, > &node_devices[nid]->dev.kobj, > kobject_name(&node_devices[nid]->dev.kobj)); > > } > > Cleaner, right? :) No unnecessary checks. I tend to agree here, I like more a simplistic version for hotplug. > One could argue if link_mem_section_hotplug() would be better than passing around the context. I am not sure if I would duplicate the code there. We could just pass the pointer of the function we want to call to link_mem_sections? either register_mem_sect_under_node_hotplug or register_mem_sect_under_node_early? Would not that be clean and clear enough? -- Oscar Salvador SUSE L3 From mboxrd@z Thu Jan 1 00:00:00 1970 From: Oscar Salvador Date: Mon, 14 Sep 2020 08:19:26 +0000 Subject: Re: [PATCH 2/3] mm: don't rely on system state to detect hot-plug operations Message-Id: <20200914081921.GA15113@linux> List-Id: References: <20200911134831.53258-1-ldufour@linux.ibm.com> <20200911134831.53258-3-ldufour@linux.ibm.com> In-Reply-To: MIME-Version: 1.0 Content-Type: text/plain; charset="us-ascii" Content-Transfer-Encoding: 7bit To: David Hildenbrand Cc: Laurent Dufour , akpm@linux-foundation.org, mhocko@kernel.org, Greg Kroah-Hartman , linux-mm@kvack.org, "Rafael J . Wysocki" , nathanl@linux.ibm.com, cheloha@linux.ibm.com, Tony Luck , Fenghua Yu , linux-ia64@vger.kernel.org, linux-kernel@vger.kernel.org, stable@vger.kernel.org, Michal Hocko On Mon, Sep 14, 2020 at 09:57:46AM +0200, David Hildenbrand wrote: > > /* register memory section under specified node if it spans that node */ > > +struct rmsun_args { > > + int nid; > > + enum memplug_context context; > > +}; Uhmf, that is a not so descriptive name. > Instead of handling this in register_mem_sect_under_node(), I > think it would be better two have two separate > register_mem_sect_under_node() implementations. > > static int register_mem_sect_under_node_hotplug(struct memory_block *mem_blk, > void *arg) > { > const int nid = *(int *)arg; > int ret; > > /* Hotplugged memory has no holes and belongs to a single node. */ > mem_blk->nid = nid; > ret = sysfs_create_link_nowarn(&node_devices[nid]->dev.kobj, > &mem_blk->dev.kobj, > kobject_name(&mem_blk->dev.kobj)); > if (ret) > returnr et; > return sysfs_create_link_nowarn(&mem_blk->dev.kobj, > &node_devices[nid]->dev.kobj, > kobject_name(&node_devices[nid]->dev.kobj)); > > } > > Cleaner, right? :) No unnecessary checks. I tend to agree here, I like more a simplistic version for hotplug. > One could argue if link_mem_section_hotplug() would be better than passing around the context. I am not sure if I would duplicate the code there. We could just pass the pointer of the function we want to call to link_mem_sections? either register_mem_sect_under_node_hotplug or register_mem_sect_under_node_early? Would not that be clean and clear enough? -- Oscar Salvador SUSE L3