All of lore.kernel.org
 help / color / mirror / Atom feed
From: "Michael S. Tsirkin" <mst@redhat.com>
To: Cornelia Huck <cohuck@redhat.com>
Cc: Thomas Huth <thuth@redhat.com>,
	qemu-s390x@nongnu.org, Eric Farman <farman@linux.ibm.com>,
	qemu-devel@nongnu.org,
	Alex Williamson <alex.williamson@redhat.com>,
	stefanha@redhat.com, Paolo Bonzini <pbonzini@redhat.com>
Subject: Re: [PATCH v3 2/3] Update linux headers to 5.11-rc2
Date: Mon, 11 Jan 2021 08:00:45 -0500	[thread overview]
Message-ID: <20210111075950-mutt-send-email-mst@kernel.org> (raw)
In-Reply-To: <20210111135404.52f18200.cohuck@redhat.com>

On Mon, Jan 11, 2021 at 01:54:04PM +0100, Cornelia Huck wrote:
> On Mon,  4 Jan 2021 21:20:56 +0100
> Eric Farman <farman@linux.ibm.com> wrote:
> 
> > Signed-off-by: Eric Farman <farman@linux.ibm.com>
> > ---
> >  .../infiniband/hw/vmw_pvrdma/pvrdma_ring.h    |  14 +-
> >  .../infiniband/hw/vmw_pvrdma/pvrdma_verbs.h   |   2 +-
> >  include/standard-headers/drm/drm_fourcc.h     | 175 +++++++++++++++++-
> >  include/standard-headers/linux/const.h        |  36 ++++
> >  include/standard-headers/linux/ethtool.h      |   2 +-
> >  include/standard-headers/linux/fuse.h         |  30 ++-
> >  include/standard-headers/linux/kernel.h       |   9 +-
> >  include/standard-headers/linux/pci_regs.h     |  16 ++
> >  include/standard-headers/linux/vhost_types.h  |   9 +
> >  include/standard-headers/linux/virtio_gpu.h   |  82 ++++++++
> >  include/standard-headers/linux/virtio_ids.h   |  44 +++--
> >  linux-headers/asm-arm64/kvm.h                 |   3 -
> >  linux-headers/asm-generic/unistd.h            |   6 +-
> >  linux-headers/asm-mips/unistd_n32.h           |   1 +
> >  linux-headers/asm-mips/unistd_n64.h           |   1 +
> >  linux-headers/asm-mips/unistd_o32.h           |   1 +
> >  linux-headers/asm-powerpc/unistd_32.h         |   1 +
> >  linux-headers/asm-powerpc/unistd_64.h         |   1 +
> >  linux-headers/asm-s390/unistd_32.h            |   1 +
> >  linux-headers/asm-s390/unistd_64.h            |   1 +
> >  linux-headers/asm-x86/kvm.h                   |   1 +
> >  linux-headers/asm-x86/unistd_32.h             |   1 +
> >  linux-headers/asm-x86/unistd_64.h             |   1 +
> >  linux-headers/asm-x86/unistd_x32.h            |   1 +
> >  linux-headers/linux/kvm.h                     |  56 +++++-
> >  linux-headers/linux/userfaultfd.h             |   9 +
> >  linux-headers/linux/vfio.h                    |   1 +
> >  linux-headers/linux/vhost.h                   |   4 +
> >  28 files changed, 461 insertions(+), 48 deletions(-)
> >  create mode 100644 include/standard-headers/linux/const.h
> > 
> > diff --git a/include/standard-headers/drivers/infiniband/hw/vmw_pvrdma/pvrdma_ring.h b/include/standard-headers/drivers/infiniband/hw/vmw_pvrdma/pvrdma_ring.h
> > index 7b4062a1a1..acd4c8346d 100644
> > --- a/include/standard-headers/drivers/infiniband/hw/vmw_pvrdma/pvrdma_ring.h
> > +++ b/include/standard-headers/drivers/infiniband/hw/vmw_pvrdma/pvrdma_ring.h
> > @@ -68,7 +68,7 @@ static inline int pvrdma_idx_valid(uint32_t idx, uint32_t max_elems)
> >  
> >  static inline int32_t pvrdma_idx(int *var, uint32_t max_elems)
> >  {
> > -	const unsigned int idx = qatomic_read(var);
> > +	const unsigned int idx = atomic_read(var);
> 
> Hm, what was the state of these qatomic* instances in this header? Is
> it ok to rename them, or do we need to do some munging in the import
> script?
> 
> (Sorry, it's been a while.)


Yea looks like it was done manually last time:

commit d73415a315471ac0b127ed3fad45c8ec5d711de1
Author: Stefan Hajnoczi <stefanha@redhat.com>
Date:   Wed Sep 23 11:56:46 2020 +0100

    qemu/atomic.h: rename atomic_ to qatomic_



> >  
> >  	if (pvrdma_idx_valid(idx, max_elems))
> >  		return idx & (max_elems - 1);
> > @@ -77,17 +77,17 @@ static inline int32_t pvrdma_idx(int *var, uint32_t max_elems)
> >  
> >  static inline void pvrdma_idx_ring_inc(int *var, uint32_t max_elems)
> >  {
> > -	uint32_t idx = qatomic_read(var) + 1;	/* Increment. */
> > +	uint32_t idx = atomic_read(var) + 1;	/* Increment. */
> >  
> >  	idx &= (max_elems << 1) - 1;		/* Modulo size, flip gen. */
> > -	qatomic_set(var, idx);
> > +	atomic_set(var, idx);
> >  }
> >  
> >  static inline int32_t pvrdma_idx_ring_has_space(const struct pvrdma_ring *r,
> >  					      uint32_t max_elems, uint32_t *out_tail)
> >  {
> > -	const uint32_t tail = qatomic_read(&r->prod_tail);
> > -	const uint32_t head = qatomic_read(&r->cons_head);
> > +	const uint32_t tail = atomic_read(&r->prod_tail);
> > +	const uint32_t head = atomic_read(&r->cons_head);
> >  
> >  	if (pvrdma_idx_valid(tail, max_elems) &&
> >  	    pvrdma_idx_valid(head, max_elems)) {
> > @@ -100,8 +100,8 @@ static inline int32_t pvrdma_idx_ring_has_space(const struct pvrdma_ring *r,
> >  static inline int32_t pvrdma_idx_ring_has_data(const struct pvrdma_ring *r,
> >  					     uint32_t max_elems, uint32_t *out_head)
> >  {
> > -	const uint32_t tail = qatomic_read(&r->prod_tail);
> > -	const uint32_t head = qatomic_read(&r->cons_head);
> > +	const uint32_t tail = atomic_read(&r->prod_tail);
> > +	const uint32_t head = atomic_read(&r->cons_head);
> >  
> >  	if (pvrdma_idx_valid(tail, max_elems) &&
> >  	    pvrdma_idx_valid(head, max_elems)) {



  reply	other threads:[~2021-01-11 13:05 UTC|newest]

Thread overview: 19+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2021-01-04 20:20 [PATCH v3 0/3] vfio-ccw: Implement request notifier Eric Farman
2021-01-04 20:20 ` [PATCH v3 1/3] update-linux-headers: Include const.h Eric Farman
2021-01-06 19:03   ` Peter Xu
2021-01-07 16:51     ` Eric Farman
2021-01-07 17:05       ` Peter Maydell
2021-01-07 17:50         ` Eric Farman
2021-01-07 19:12           ` Peter Xu
2021-01-07  6:52   ` Philippe Mathieu-Daudé
2021-01-04 20:20 ` [PATCH v3 2/3] Update linux headers to 5.11-rc2 Eric Farman
2021-01-11 12:54   ` Cornelia Huck
2021-01-11 13:00     ` Michael S. Tsirkin [this message]
2021-01-11 13:43       ` Cornelia Huck
2021-01-11 15:00         ` Michael S. Tsirkin
2021-01-11 15:11           ` Eric Farman
2021-01-11 15:18             ` Michael S. Tsirkin
2021-01-11 16:05               ` Cornelia Huck
2021-01-13 11:27         ` Cornelia Huck
2021-01-04 20:20 ` [PATCH v3 3/3] vfio-ccw: Connect the device request notifier Eric Farman
2021-01-13 12:58 ` [PATCH v3 0/3] vfio-ccw: Implement " Cornelia Huck

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20210111075950-mutt-send-email-mst@kernel.org \
    --to=mst@redhat.com \
    --cc=alex.williamson@redhat.com \
    --cc=cohuck@redhat.com \
    --cc=farman@linux.ibm.com \
    --cc=pbonzini@redhat.com \
    --cc=qemu-devel@nongnu.org \
    --cc=qemu-s390x@nongnu.org \
    --cc=stefanha@redhat.com \
    --cc=thuth@redhat.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.