On Wed, Feb 10, 2021 at 10:56:55AM +0000, Dave Martin wrote: > On Mon, Feb 01, 2021 at 12:29:00PM +0000, Mark Brown wrote: > > + if (test_thread_flag(TIF_SVE_EXEC)) { > > + vl = sve_vq_from_vl(current->thread.sve_vl) - 1; > One more nit: because of the confusion that can arises from "vl" being a > somewhat overloaded term in the architecture, I was trying to avoid > using the name "vl" for anything that isn't the vector length in bytes. > Can this instead be renamed to vq_minus_1 to match the function > arguments it's passed for? Oh, *that's* what that's all about. I spent quite a bit of time trying to figure out why we were sometimes using vq_minus_1 but never managed to get to the bottom of it - it's an awkward name and there's nothing in the code that explains the logic behind when we use it so it was really confusing. We can do the rename but I'm not sure it's achieving the goal of comprehensibility. > (You could save a couple of lines by moving the declaration here and > combining it with this assignment too.) Not really the coding style in the file though.