All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH v3 0/7] Rationalise __alloc_pages wrappers
@ 2021-02-25 15:06 Matthew Wilcox (Oracle)
  2021-02-25 15:06 ` [PATCH v3 1/7] mm/page_alloc: Rename alloc_mask to alloc_gfp Matthew Wilcox (Oracle)
                   ` (6 more replies)
  0 siblings, 7 replies; 13+ messages in thread
From: Matthew Wilcox (Oracle) @ 2021-02-25 15:06 UTC (permalink / raw)
  To: Andrew Morton; +Cc: Matthew Wilcox (Oracle), linux-mm, Mike Rapoport

I was poking around the __alloc_pages variants trying to understand
why they each exist, and couldn't really find a good justification for
keeping __alloc_pages and __alloc_pages_nodemask as separate functions.
That led to getting rid of alloc_pages_current() and then I noticed the
documentation was bad, and then I noticed the mempolicy documentation
wasn't included ...
anyway, this is all cleanups & doc fixes.

v3:
 - Added acks from Mike (patches 5 & 7) & Michel (patch 5)
 - Improved wording of return value (Mike, patch 5)
 - Added patch 6
v2:
 - Added acks from Vlastimil (patches 2-4) & Michel (patches 3-4)
 - Added patches 1, 5 and 7

Matthew Wilcox (Oracle) (7):
  mm/page_alloc: Rename alloc_mask to alloc_gfp
  mm/page_alloc: Rename gfp_mask to gfp
  mm/page_alloc: Combine __alloc_pages and __alloc_pages_nodemask
  mm/mempolicy: Rename alloc_pages_current to alloc_pages
  mm/mempolicy: Rewrite alloc_pages documentation
  mm/mempolicy: Rewrite alloc_pages_vma documentation
  mm/mempolicy: Fix mpol_misplaced kernel-doc

 Documentation/admin-guide/mm/transhuge.rst |  2 +-
 Documentation/core-api/mm-api.rst          |  1 +
 include/linux/gfp.h                        | 21 ++----
 mm/hugetlb.c                               |  2 +-
 mm/internal.h                              |  4 +-
 mm/mempolicy.c                             | 76 +++++++++-------------
 mm/migrate.c                               |  2 +-
 mm/page_alloc.c                            | 34 +++++-----
 8 files changed, 59 insertions(+), 83 deletions(-)

-- 
2.29.2



^ permalink raw reply	[flat|nested] 13+ messages in thread

end of thread, other threads:[~2021-03-19 14:49 UTC | newest]

Thread overview: 13+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-02-25 15:06 [PATCH v3 0/7] Rationalise __alloc_pages wrappers Matthew Wilcox (Oracle)
2021-02-25 15:06 ` [PATCH v3 1/7] mm/page_alloc: Rename alloc_mask to alloc_gfp Matthew Wilcox (Oracle)
2021-03-19 14:44   ` Vlastimil Babka
2021-02-25 15:06 ` [PATCH v3 2/7] mm/page_alloc: Rename gfp_mask to gfp Matthew Wilcox (Oracle)
2021-02-25 15:06 ` [PATCH v3 3/7] mm/page_alloc: Combine __alloc_pages and __alloc_pages_nodemask Matthew Wilcox (Oracle)
2021-02-25 15:06 ` [PATCH v3 4/7] mm/mempolicy: Rename alloc_pages_current to alloc_pages Matthew Wilcox (Oracle)
2021-02-25 15:06 ` [PATCH v3 5/7] mm/mempolicy: Rewrite alloc_pages documentation Matthew Wilcox (Oracle)
2021-03-19 14:47   ` Vlastimil Babka
2021-02-25 15:06 ` [PATCH v3 6/7] mm/mempolicy: Rewrite alloc_pages_vma documentation Matthew Wilcox (Oracle)
2021-02-25 18:42   ` Mike Rapoport
2021-03-19 14:48   ` Vlastimil Babka
2021-02-25 15:06 ` [PATCH v3 7/7] mm/mempolicy: Fix mpol_misplaced kernel-doc Matthew Wilcox (Oracle)
2021-03-19 14:49   ` Vlastimil Babka

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.