All of lore.kernel.org
 help / color / mirror / Atom feed
From: David Gow <davidgow@google.com>
To: Brendan Higgins <brendanhiggins@google.com>,
	Daniel Latypov <dlatypov@google.com>,
	Shuah Khan <skhan@linuxfoundation.org>,
	John Johansen <john.johansen@canonical.com>,
	James Morris <jmorris@namei.org>,
	"Serge E. Hallyn" <serge@hallyn.com>
Cc: David Gow <davidgow@google.com>,
	kunit-dev@googlegroups.com, linux-kselftest@vger.kernel.org,
	linux-kernel@vger.kernel.org,
	linux-security-module@vger.kernel.org
Subject: [PATCH v2 09/10] apparmor: test: Remove some casts which are no-longer required
Date: Thu, 13 May 2021 12:32:03 -0700	[thread overview]
Message-ID: <20210513193204.816681-9-davidgow@google.com> (raw)
In-Reply-To: <20210513193204.816681-1-davidgow@google.com>

With some of the stricter type checking in KUnit's EXPECT macros
removed, several casts in policy_unpack_test are no longer required.

Remove the unnecessary casts, making the conditions clearer.

Signed-off-by: David Gow <davidgow@google.com>
---
This should be a no-op functionality wise, and while it depends on the
first couple of patches in this series, it's otherwise independent from
the others. I think this makes the test more readable, but if you
particularly dislike it, I'm happy to drop it.

 security/apparmor/policy_unpack_test.c | 18 +++++++++---------
 1 file changed, 9 insertions(+), 9 deletions(-)

diff --git a/security/apparmor/policy_unpack_test.c b/security/apparmor/policy_unpack_test.c
index 533137f45361..03f78a41ef79 100644
--- a/security/apparmor/policy_unpack_test.c
+++ b/security/apparmor/policy_unpack_test.c
@@ -177,7 +177,7 @@ static void policy_unpack_test_unpack_array_out_of_bounds(struct kunit *test)
 
 	array_size = unpack_array(puf->e, name);
 
-	KUNIT_EXPECT_EQ(test, array_size, (u16)0);
+	KUNIT_EXPECT_EQ(test, array_size, 0);
 	KUNIT_EXPECT_PTR_EQ(test, puf->e->pos,
 		puf->e->start + TEST_NAMED_ARRAY_BUF_OFFSET);
 }
@@ -313,7 +313,7 @@ static void policy_unpack_test_unpack_strdup_out_of_bounds(struct kunit *test)
 	size = unpack_strdup(puf->e, &string, TEST_STRING_NAME);
 
 	KUNIT_EXPECT_EQ(test, size, 0);
-	KUNIT_EXPECT_PTR_EQ(test, string, (char *)NULL);
+	KUNIT_EXPECT_PTR_EQ(test, string, NULL);
 	KUNIT_EXPECT_PTR_EQ(test, puf->e->pos, start);
 }
 
@@ -391,10 +391,10 @@ static void policy_unpack_test_unpack_u16_chunk_basic(struct kunit *test)
 
 	size = unpack_u16_chunk(puf->e, &chunk);
 
-	KUNIT_EXPECT_PTR_EQ(test, (void *)chunk,
+	KUNIT_EXPECT_PTR_EQ(test, chunk,
 			    puf->e->start + TEST_U16_OFFSET + 2);
-	KUNIT_EXPECT_EQ(test, size, (size_t)TEST_U16_DATA);
-	KUNIT_EXPECT_PTR_EQ(test, puf->e->pos, (void *)(chunk + TEST_U16_DATA));
+	KUNIT_EXPECT_EQ(test, size, TEST_U16_DATA);
+	KUNIT_EXPECT_PTR_EQ(test, puf->e->pos, (chunk + TEST_U16_DATA));
 }
 
 static void policy_unpack_test_unpack_u16_chunk_out_of_bounds_1(
@@ -408,8 +408,8 @@ static void policy_unpack_test_unpack_u16_chunk_out_of_bounds_1(
 
 	size = unpack_u16_chunk(puf->e, &chunk);
 
-	KUNIT_EXPECT_EQ(test, size, (size_t)0);
-	KUNIT_EXPECT_PTR_EQ(test, chunk, (char *)NULL);
+	KUNIT_EXPECT_EQ(test, size, 0);
+	KUNIT_EXPECT_PTR_EQ(test, chunk, NULL);
 	KUNIT_EXPECT_PTR_EQ(test, puf->e->pos, puf->e->end - 1);
 }
 
@@ -430,8 +430,8 @@ static void policy_unpack_test_unpack_u16_chunk_out_of_bounds_2(
 
 	size = unpack_u16_chunk(puf->e, &chunk);
 
-	KUNIT_EXPECT_EQ(test, size, (size_t)0);
-	KUNIT_EXPECT_PTR_EQ(test, chunk, (char *)NULL);
+	KUNIT_EXPECT_EQ(test, size, 0);
+	KUNIT_EXPECT_PTR_EQ(test, chunk, NULL);
 	KUNIT_EXPECT_PTR_EQ(test, puf->e->pos, puf->e->start + TEST_U16_OFFSET);
 }
 
-- 
2.31.1.751.gd2f1c929bd-goog


  parent reply	other threads:[~2021-05-13 19:36 UTC|newest]

Thread overview: 39+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2021-05-13 19:31 [PATCH v2 01/10] kunit: Do not typecheck binary assertions David Gow
2021-05-13 19:31 ` [PATCH v2 02/10] kunit: Assign strings to 'const char*' in STREQ assertions David Gow
2021-05-13 19:31 ` [PATCH v2 03/10] Documentation: kunit: Clean up some string casts in examples David Gow
2021-05-13 23:07   ` Daniel Latypov
2021-06-15 20:10   ` Brendan Higgins
2021-05-13 19:31 ` [PATCH v2 04/10] device property: Remove some casts in property-entry-test David Gow
2021-05-13 19:42   ` Greg Kroah-Hartman
2021-06-15 20:12   ` Brendan Higgins
2021-05-13 19:31 ` [PATCH v2 05/10] iio: Remove a cast in iio-test-format which is no longer required David Gow
2021-06-15 20:14   ` Brendan Higgins
2021-06-16 14:08     ` Jonathan Cameron
2021-05-13 19:32 ` [PATCH v2 06/10] mmc: sdhci-of-aspeed: Remove some unnecessary casts from KUnit tests David Gow
2021-05-13 19:32   ` David Gow
2021-05-13 19:32   ` David Gow
2021-05-14  1:55   ` Andrew Jeffery
2021-05-14  1:55     ` Andrew Jeffery
2021-05-14  1:55     ` Andrew Jeffery
2021-05-17  9:22   ` Ulf Hansson
2021-05-17  9:22     ` Ulf Hansson
2021-05-17  9:22     ` Ulf Hansson
2021-05-18  4:29     ` David Gow
2021-05-18  4:29       ` David Gow
2021-05-18  4:29       ` David Gow
2021-06-15 20:16   ` Brendan Higgins
2021-06-15 20:16     ` Brendan Higgins
2021-06-15 20:16     ` Brendan Higgins
2021-05-13 19:32 ` [PATCH v2 07/10] thunderbolt: test: Remove sone casts which are no longer required David Gow
2021-05-14  6:06   ` Mika Westerberg
2021-05-14  7:27     ` David Gow
2021-05-14 19:57       ` Shuah Khan
2021-06-15 20:31   ` Brendan Higgins
2021-05-13 19:32 ` [PATCH v2 08/10] kernel/sysctl-test: Remove some casts which are no-longer required David Gow
2021-06-15 20:33   ` Brendan Higgins
2021-05-13 19:32 ` David Gow [this message]
2021-06-15 20:40   ` [PATCH v2 09/10] apparmor: test: " Brendan Higgins
2021-06-15 21:26   ` John Johansen
2021-05-13 19:32 ` [PATCH v2 10/10] lib/cmdline_kunit: Remove a cast " David Gow
2021-05-17  6:52   ` Andy Shevchenko
2021-06-15 20:42   ` Brendan Higgins

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20210513193204.816681-9-davidgow@google.com \
    --to=davidgow@google.com \
    --cc=brendanhiggins@google.com \
    --cc=dlatypov@google.com \
    --cc=jmorris@namei.org \
    --cc=john.johansen@canonical.com \
    --cc=kunit-dev@googlegroups.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-kselftest@vger.kernel.org \
    --cc=linux-security-module@vger.kernel.org \
    --cc=serge@hallyn.com \
    --cc=skhan@linuxfoundation.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.