All of lore.kernel.org
 help / color / mirror / Atom feed
* remove the legacy ide driver v2
@ 2021-06-16 13:46 ` Christoph Hellwig
  0 siblings, 0 replies; 27+ messages in thread
From: Christoph Hellwig @ 2021-06-16 13:46 UTC (permalink / raw)
  To: David S. Miller, Jens Axboe, Geert Uytterhoeven
  Cc: Richard Henderson, Ivan Kokshaysky, Matt Turner, Russell King,
	Michael Ellerman, Linus Torvalds, linux-ide, linux-doc,
	linux-kernel, linux-alpha, linux-arm-kernel, linux-m68k

Hi all,

we've been trying to get rid of the legacy ide driver for a while now,
and finally scheduled a removal for 2021, which is three month old now.

In general distros and most defconfigs have switched to libata long ago,
but there are a few exceptions.  This series first switches over all
remaining defconfigs to use libata and then removes the legacy ide
driver.

libata mostly covers all hardware supported by the legacy ide driver.
There are three mips drivers that are not supported, but the linux-mips
list could not identify any users of those.  There also are two m68k
drivers that do not have libata equivalents, which might or might not
have users, so we'll need some input and possibly help from the m68k
community here.

This series is against Jens' for-5.14/libata branch.

Changes since v1:
 - dropped various already merged patches
 - add a new module option to allow disabling DMA just for the quirky
   cypress devices found on some stone age ARM and Alpha systems

^ permalink raw reply	[flat|nested] 27+ messages in thread