All of lore.kernel.org
 help / color / mirror / Atom feed
From: Jason Gunthorpe <jgg@nvidia.com>
To: Max Gurtovoy <mgurtovoy@nvidia.com>
Cc: Alex Williamson <alex.williamson@redhat.com>,
	cohuck@redhat.com, kvm@vger.kernel.org,
	linux-kernel@vger.kernel.org, aviadye@nvidia.com,
	oren@nvidia.com, shahafs@nvidia.com, parav@nvidia.com,
	artemp@nvidia.com, kwankhede@nvidia.com, ACurrid@nvidia.com,
	cjia@nvidia.com, yishaih@nvidia.com, kevin.tian@intel.com,
	hch@infradead.org, targupta@nvidia.com,
	shameerali.kolothum.thodi@huawei.com, liulongfang@huawei.com,
	yan.y.zhao@intel.com
Subject: Re: [PATCH 09/11] PCI: add matching checks for driver_override binding
Date: Wed, 16 Jun 2021 20:33:17 -0300	[thread overview]
Message-ID: <20210616233317.GR1002214@nvidia.com> (raw)
In-Reply-To: <cd95b92c-a23b-03a7-1dd3-9554b9d22955@nvidia.com>

On Thu, Jun 17, 2021 at 02:28:36AM +0300, Max Gurtovoy wrote:
> 
> On 6/16/2021 3:34 AM, Jason Gunthorpe wrote:
> > On Tue, Jun 15, 2021 at 06:22:45PM -0600, Alex Williamson wrote:
> > > On Tue, 15 Jun 2021 20:32:57 -0300
> > > Jason Gunthorpe <jgg@nvidia.com> wrote:
> > > 
> > > > On Tue, Jun 15, 2021 at 05:22:42PM -0600, Alex Williamson wrote:
> > > > 
> > > > > > > b) alone is a functional, runtime difference.
> > > > > > I would state b) differently:
> > > > > > 
> > > > > > b) Ignore the driver-override-only match entries in the ID table.
> > > > > No, pci_match_device() returns NULL if a match is found that is marked
> > > > > driver-override-only and a driver_override is not specified.  That's
> > > > > the same as no match at all.  We don't then go on to search past that
> > > > > match in the table, we fail to bind the driver.  That's effectively an
> > > > > anti-match when there's no driver_override on the device.
> > > > anti-match isn't the intention. The deployment will have match tables
> > > > where all entires are either flags=0 or are driver-override-only.
> > > I'd expect pci-pf-stub to have one of each, an any-id with
> > > override-only flag and the one device ID currently in the table with
> > > no flag.
> > Oh Hum. Actually I think this shows the anti-match behavior is
> > actually a bug.. :(
> > 
> > For something like pci_pf_stub_whitelist, if we add a
> > driver_override-only using the PCI any id then it effectively disables
> > new_id completely because the match search will alway find the
> > driver_override match first and stop searching. There is no chance to
> > see things new_id adds.
> 
> Actually the dynamic table is the first table the driver search. So new_id
> works exactly the same AFAIU.

Oh, even better, so it isn't really an issue

> But you're right for static mixed table (I assumed that this will never
> happen I guess).

Me too, we could organize the driver-overrides to be last
 
> -       found_id = pci_match_id(drv->id_table, dev);
> -       if (found_id) {
> +       ids = drv->id_table;
> +       while ((found_id = pci_match_id(ids, dev))) {

Yeah, keep searching makes logical sense to me

> diff --git a/drivers/pci/pci-pf-stub.c b/drivers/pci/pci-pf-stub.c
> index 45855a5e9fca..49544ba9a7af 100644
> +++ b/drivers/pci/pci-pf-stub.c
> @@ -19,6 +19,7 @@
>   */
>  static const struct pci_device_id pci_pf_stub_whitelist[] = {
>         { PCI_VDEVICE(AMAZON, 0x0053) },
> +       { PCI_DEVICE_FLAGS(PCI_ANY_ID, PCI_ANY_ID,
> PCI_ID_F_STUB_DRIVER_OVERRIDE) }, /* match all by default (override) */
>         /* required last entry */
>         { 0 }

And we don't really want this change any more right? No reason to put
pci_stub in the module.alias file?

Thanks,
Jason

  reply	other threads:[~2021-06-16 23:33 UTC|newest]

Thread overview: 46+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2021-06-03 16:07 [RFC PATCH v4 00/11] Introduce vfio-pci-core subsystem Max Gurtovoy
2021-06-03 16:07 ` [PATCH 01/11] vfio-pci: rename vfio_pci.c to vfio_pci_core.c Max Gurtovoy
2021-06-03 16:08 ` [PATCH 02/11] vfio-pci: rename vfio_pci_private.h to vfio_pci_core.h Max Gurtovoy
2021-06-03 16:08 ` [PATCH 03/11] vfio-pci: rename vfio_pci_device to vfio_pci_core_device Max Gurtovoy
2021-06-03 16:08 ` [PATCH 04/11] vfio-pci: rename ops functions to fit core namings Max Gurtovoy
2021-06-03 16:08 ` [PATCH 05/11] vfio-pci: include vfio header in vfio_pci_core.h Max Gurtovoy
2021-06-03 16:08 ` [PATCH 06/11] vfio-pci: introduce vfio_pci.c Max Gurtovoy
2021-06-03 16:08 ` [PATCH 07/11] vfio-pci: move igd initialization to vfio_pci.c Max Gurtovoy
2021-06-03 16:08 ` [PATCH 08/11] PCI: add flags field to pci_device_id structure Max Gurtovoy
2021-06-03 16:08 ` [PATCH 09/11] PCI: add matching checks for driver_override binding Max Gurtovoy
2021-06-08 21:26   ` Alex Williamson
2021-06-08 22:45     ` Jason Gunthorpe
2021-06-09  1:27       ` Alex Williamson
2021-06-09  9:26         ` Max Gurtovoy
2021-06-13  8:19         ` Max Gurtovoy
2021-06-14  5:40           ` Christoph Hellwig
2021-06-14  8:18             ` Max Gurtovoy
2021-06-14 15:27               ` Christoph Hellwig
2021-06-14 16:01                 ` Jason Gunthorpe
2021-06-14 16:15                   ` Christoph Hellwig
2021-06-14 16:33                     ` Jason Gunthorpe
2021-06-14 18:42           ` Alex Williamson
2021-06-14 23:12             ` Max Gurtovoy
2021-06-15 15:00               ` Alex Williamson
2021-06-15 15:04                 ` Jason Gunthorpe
2021-06-15 16:20                   ` Alex Williamson
2021-06-15 20:42                     ` Jason Gunthorpe
2021-06-15 21:59                       ` Alex Williamson
2021-06-15 23:00                         ` Jason Gunthorpe
2021-06-15 23:22                           ` Alex Williamson
2021-06-15 23:32                             ` Jason Gunthorpe
2021-06-16  0:22                               ` Alex Williamson
2021-06-16  0:34                                 ` Jason Gunthorpe
2021-06-16 23:28                                   ` Max Gurtovoy
2021-06-16 23:33                                     ` Jason Gunthorpe [this message]
2021-06-16 23:42                                       ` Max Gurtovoy
2021-06-16 23:44                                         ` Jason Gunthorpe
2021-06-16 23:51                                           ` Max Gurtovoy
2021-06-16 23:56                                             ` Jason Gunthorpe
2021-06-20 14:46                                               ` Max Gurtovoy
2021-06-03 16:08 ` [PATCH 10/11] vfio-pci: introduce vfio_pci_core subsystem driver Max Gurtovoy
2021-06-08 21:26   ` Alex Williamson
2021-06-09  9:29     ` Max Gurtovoy
2021-06-03 16:08 ` [PATCH 11/11] mlx5-vfio-pci: add new vfio_pci driver for mlx5 devices Max Gurtovoy
2021-07-30  7:53 ` [RFC PATCH v4 00/11] Introduce vfio-pci-core subsystem Shameerali Kolothum Thodi
2021-07-30 11:55   ` Jason Gunthorpe

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20210616233317.GR1002214@nvidia.com \
    --to=jgg@nvidia.com \
    --cc=ACurrid@nvidia.com \
    --cc=alex.williamson@redhat.com \
    --cc=artemp@nvidia.com \
    --cc=aviadye@nvidia.com \
    --cc=cjia@nvidia.com \
    --cc=cohuck@redhat.com \
    --cc=hch@infradead.org \
    --cc=kevin.tian@intel.com \
    --cc=kvm@vger.kernel.org \
    --cc=kwankhede@nvidia.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=liulongfang@huawei.com \
    --cc=mgurtovoy@nvidia.com \
    --cc=oren@nvidia.com \
    --cc=parav@nvidia.com \
    --cc=shahafs@nvidia.com \
    --cc=shameerali.kolothum.thodi@huawei.com \
    --cc=targupta@nvidia.com \
    --cc=yan.y.zhao@intel.com \
    --cc=yishaih@nvidia.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.