On Mon, Jul 05, 2021 at 09:28:28PM +0530, Vijendar Mukunda wrote: > @@ -982,6 +982,7 @@ struct snd_soc_card { > unsigned int disable_route_checks:1; > unsigned int probed:1; > unsigned int component_chaining:1; > + unsigned int dai_reorder:1; This feels like it should be a per dai_link option rather than a card wide option - the system could have a mix of links that do and don't want this depending on why it's an issue. The name probably also wants to be more specific to what's being reordered, something like stop_dma_first for example since it's only for stops and moves the DMA first.