All of lore.kernel.org
 help / color / mirror / Atom feed
* [Buildroot] [PATCH 1/1] package/python-psycopg2: needs python3
@ 2021-09-29 16:31 Fabrice Fontaine
  2021-10-03 20:32 ` Yann E. MORIN
  0 siblings, 1 reply; 2+ messages in thread
From: Fabrice Fontaine @ 2021-09-29 16:31 UTC (permalink / raw)
  To: buildroot; +Cc: Fabrice Fontaine, Thomas Petazzoni, Asaf Kahlon

python 2 support has been dropped since version 2.9 and
https://github.com/psycopg/psycopg2/commit/d956eaa3b1842a14895685be0d6d5e380fd029fc
resulting in the following build failure since bump to version 2.9.1 in
commit 09417e47d706e5d7d58c0f886b4679064c5175fa:

  File "setup.py", line 117
    f"Unable to find 'pg_config' file in '{self.pg_config_exe}'")
                                                               ^

Fixes:
 - http://autobuild.buildroot.org/results/f8a2cf9eea500e2c617381840b849225f12b56f1

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/python-psycopg2/Config.in | 3 +++
 1 file changed, 3 insertions(+)

diff --git a/package/python-psycopg2/Config.in b/package/python-psycopg2/Config.in
index 5ffe179517..fba781c014 100644
--- a/package/python-psycopg2/Config.in
+++ b/package/python-psycopg2/Config.in
@@ -1,5 +1,6 @@
 config BR2_PACKAGE_PYTHON_PSYCOPG2
 	bool "python-psycopg2"
+	depends on BR2_PACKAGE_PYTHON3
 	depends on BR2_USE_WCHAR # postgresql
 	select BR2_PACKAGE_POSTGRESQL
 	help
@@ -21,5 +22,7 @@ config BR2_PACKAGE_PYTHON_PSYCOPG2
 	  Psycopg 2 is both Unicode and Python 3 friendly.
 
 	  http://initd.org/psycopg/
+
 comment "python-psycopg2 needs a toolchain w/ wchar"
+	depends on BR2_PACKAGE_PYTHON3
 	depends on !BR2_USE_WCHAR
-- 
2.33.0

_______________________________________________
buildroot mailing list
buildroot@buildroot.org
https://lists.buildroot.org/mailman/listinfo/buildroot

^ permalink raw reply	[flat|nested] 2+ messages in thread

* Re: [Buildroot] [PATCH 1/1] package/python-psycopg2: needs python3
  2021-09-29 16:31 [Buildroot] [PATCH 1/1] package/python-psycopg2: needs python3 Fabrice Fontaine
@ 2021-10-03 20:32 ` Yann E. MORIN
  0 siblings, 0 replies; 2+ messages in thread
From: Yann E. MORIN @ 2021-10-03 20:32 UTC (permalink / raw)
  To: Fabrice Fontaine; +Cc: Asaf Kahlon, Thomas Petazzoni, buildroot

Fabrice, All,

On 2021-09-29 18:31 +0200, Fabrice Fontaine spake thusly:
> python 2 support has been dropped since version 2.9 and
> https://github.com/psycopg/psycopg2/commit/d956eaa3b1842a14895685be0d6d5e380fd029fc
> resulting in the following build failure since bump to version 2.9.1 in
> commit 09417e47d706e5d7d58c0f886b4679064c5175fa:
> 
>   File "setup.py", line 117
>     f"Unable to find 'pg_config' file in '{self.pg_config_exe}'")
>                                                                ^
> 
> Fixes:
>  - http://autobuild.buildroot.org/results/f8a2cf9eea500e2c617381840b849225f12b56f1
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

Applied to master, thanks.

Regards,
Yann E. MORIN.

> ---
>  package/python-psycopg2/Config.in | 3 +++
>  1 file changed, 3 insertions(+)
> 
> diff --git a/package/python-psycopg2/Config.in b/package/python-psycopg2/Config.in
> index 5ffe179517..fba781c014 100644
> --- a/package/python-psycopg2/Config.in
> +++ b/package/python-psycopg2/Config.in
> @@ -1,5 +1,6 @@
>  config BR2_PACKAGE_PYTHON_PSYCOPG2
>  	bool "python-psycopg2"
> +	depends on BR2_PACKAGE_PYTHON3
>  	depends on BR2_USE_WCHAR # postgresql
>  	select BR2_PACKAGE_POSTGRESQL
>  	help
> @@ -21,5 +22,7 @@ config BR2_PACKAGE_PYTHON_PSYCOPG2
>  	  Psycopg 2 is both Unicode and Python 3 friendly.
>  
>  	  http://initd.org/psycopg/
> +
>  comment "python-psycopg2 needs a toolchain w/ wchar"
> +	depends on BR2_PACKAGE_PYTHON3
>  	depends on !BR2_USE_WCHAR
> -- 
> 2.33.0
> 
> _______________________________________________
> buildroot mailing list
> buildroot@buildroot.org
> https://lists.buildroot.org/mailman/listinfo/buildroot

-- 
.-----------------.--------------------.------------------.--------------------.
|  Yann E. MORIN  | Real-Time Embedded | /"\ ASCII RIBBON | Erics' conspiracy: |
| +33 662 376 056 | Software  Designer | \ / CAMPAIGN     |  ___               |
| +33 561 099 427 `------------.-------:  X  AGAINST      |  \e/  There is no  |
| http://ymorin.is-a-geek.org/ | _/*\_ | / \ HTML MAIL    |   v   conspiracy.  |
'------------------------------^-------^------------------^--------------------'
_______________________________________________
buildroot mailing list
buildroot@buildroot.org
https://lists.buildroot.org/mailman/listinfo/buildroot

^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, other threads:[~2021-10-03 20:32 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-09-29 16:31 [Buildroot] [PATCH 1/1] package/python-psycopg2: needs python3 Fabrice Fontaine
2021-10-03 20:32 ` Yann E. MORIN

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.