All of lore.kernel.org
 help / color / mirror / Atom feed
From: Enzo Matsumiya <ematsumiya@suse.de>
To: Steve French <smfrench@gmail.com>
Cc: CIFS <linux-cifs@vger.kernel.org>
Subject: Re: Fwd: [RFC PATCH v2 03/10] cifs: rename "TCP_Server_Info" struct to "cifs_server_info"
Date: Wed, 27 Jul 2022 16:24:06 -0300	[thread overview]
Message-ID: <20220727192406.a3oqszjap5cpmmed@cyberdelia> (raw)
In-Reply-To: <20220727153836.sllbblfagnstcza7@cyberdelia>

[ resending this as the other one bounced ]

On 07/27, Steve French wrote:
>Of the first three patches, I think this one makes the most sense, but
>the rename should be "TCP_Server_Info" to something like
>"tcp_server_info" (or TCP_server_info) or something that indicates it
>is for the transport level info, info related to the network
>connection, the socket etc.

Noted.

>(and not using the word "cifs" unless
>related to SMB1)

The "cifs" prefix is for the bigger picture (SMB1 isolation and/or
module renaming) so I can later on do something like:
"sed -i 's/cifs_/<newname>_/g' *.c"

>---------- Forwarded message ---------
>From: Enzo Matsumiya <ematsumiya@suse.de>
>Date: Mon, Jul 25, 2022 at 5:37 PM
>Subject: [RFC PATCH v2 03/10] cifs: rename "TCP_Server_Info" struct to
>"cifs_server_info"
>To: <linux-cifs@vger.kernel.org>
>Cc: <smfrench@gmail.com>, <pc@cjr.nz>, <ronniesahlberg@gmail.com>,
><nspmangalore@gmail.com>
>
>
>Rename the TCP_Server_Info struct to "cifs_server_info",
>making it look more like a cifs.ko struct by using the standard "cifs_"
>prefix.
>
>Also upgrades from Camel_Case to snake_case.
>
>Signed-off-by: Enzo Matsumiya <ematsumiya@suse.de>
>---
>fs/cifs/asn1.c          |   4 +-
>fs/cifs/cifs_debug.c    |  14 ++--
>fs/cifs/cifs_debug.h    |   4 +-
>fs/cifs/cifs_spnego.c   |   2 +-
>fs/cifs/cifs_spnego.h   |   2 +-
>fs/cifs/cifs_swn.h      |   8 +--
>fs/cifs/cifsencrypt.c   |  14 ++--
>fs/cifs/cifsfs.c        |   6 +-
>fs/cifs/cifsglob.h      | 140 ++++++++++++++++++++--------------------
>fs/cifs/cifsproto.h     | 114 ++++++++++++++++----------------
>fs/cifs/cifssmb.c       |  24 +++----
>fs/cifs/connect.c       | 134 +++++++++++++++++++-------------------
>fs/cifs/dfs_cache.c     |  10 +--
>fs/cifs/dir.c           |   6 +-
>fs/cifs/file.c          |  60 ++++++++---------
>fs/cifs/fscache.c       |   2 +-
>fs/cifs/inode.c         |  22 +++----
>fs/cifs/ioctl.c         |   2 +-
>fs/cifs/link.c          |   4 +-
>fs/cifs/misc.c          |  10 +--
>fs/cifs/netmisc.c       |   2 +-
>fs/cifs/ntlmssp.h       |   6 +-
>fs/cifs/readdir.c       |   4 +-
>fs/cifs/sess.c          |  52 +++++++--------
>fs/cifs/smb1ops.c       |  26 ++++----
>fs/cifs/smb2inode.c     |   2 +-
>fs/cifs/smb2misc.c      |  14 ++--
>fs/cifs/smb2ops.c       |  86 ++++++++++++------------
>fs/cifs/smb2pdu.c       | 122 +++++++++++++++++-----------------
>fs/cifs/smb2proto.h     |  58 ++++++++---------
>fs/cifs/smb2transport.c |  44 ++++++-------
>fs/cifs/smbdirect.c     |  10 +--
>fs/cifs/smbdirect.h     |  16 ++---
>fs/cifs/transport.c     |  48 +++++++-------
>34 files changed, 536 insertions(+), 536 deletions(-)

      parent reply	other threads:[~2022-07-27 19:24 UTC|newest]

Thread overview: 20+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2022-07-25 22:36 [RFC PATCH v2 00/10] cifs: rename of several structs and variables Enzo Matsumiya
2022-07-25 22:36 ` [RFC PATCH v2 01/10] cifs: rename xid/mid globals Enzo Matsumiya
2022-07-25 22:36 ` [RFC PATCH v2 02/10] cifs: rename global counters Enzo Matsumiya
2022-07-25 22:37 ` [RFC PATCH v2 05/10] cifs: convert server info vars to snake_case Enzo Matsumiya
2022-07-27 14:32   ` Steve French
2022-07-27 15:17     ` Enzo Matsumiya
2022-07-27 15:29       ` Steve French
2022-07-27 15:35         ` Enzo Matsumiya
2022-07-25 22:37 ` [RFC PATCH v2 06/10] cifs: change status and security types enums to constants Enzo Matsumiya
2022-07-27 14:35   ` Steve French
2022-07-27 15:20     ` Enzo Matsumiya
2022-07-25 22:37 ` [RFC PATCH v2 07/10] cifs: rename cifsFYI to debug_level Enzo Matsumiya
2022-07-27 14:36   ` Steve French
2022-07-27 15:21     ` Enzo Matsumiya
2022-07-25 22:37 ` [RFC PATCH v2 08/10] cifs: rename list_head fields Enzo Matsumiya
2022-07-25 22:37 ` [RFC PATCH v2 10/10] cifs: rename more list_heads, remove redundant prefixes Enzo Matsumiya
2022-07-26  2:23 ` [RFC PATCH v2 00/10] cifs: rename of several structs and variables Tom Talpey
2022-07-26  2:41   ` Enzo Matsumiya
2022-07-29 19:12     ` Tom Talpey
     [not found] ` <20220725223707.14477-4-ematsumiya@suse.de>
     [not found]   ` <CAH2r5msHgxzC6HYhj70cMce+=t6Fz2p1C5X3HCM1WKFEq7rnhQ@mail.gmail.com>
     [not found]     ` <20220727153836.sllbblfagnstcza7@cyberdelia>
2022-07-27 19:24       ` Enzo Matsumiya [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20220727192406.a3oqszjap5cpmmed@cyberdelia \
    --to=ematsumiya@suse.de \
    --cc=linux-cifs@vger.kernel.org \
    --cc=smfrench@gmail.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.