From: guoren@kernel.org To: tj@kernel.org, cl@linux.com, palmer@dabbelt.com, will@kernel.org, catalin.marinas@arm.com, peterz@infradead.org, arnd@arndb.de Cc: linux-arch@vger.kernel.org, linux-kernel@vger.kernel.org, linux-riscv@lists.infradead.org, Guo Ren <guoren@linux.alibaba.com> Subject: [RFC PATCH 0/4] riscv: Add basic percpu operations Date: Mon, 8 Aug 2022 04:05:56 -0400 [thread overview] Message-ID: <20220808080600.3346843-1-guoren@kernel.org> (raw) From: Guo Ren <guoren@linux.alibaba.com> The series try to add basic percpu operations for riscv. HAVE_CMPXCHG_LOCAL would let people confuse with cmpxchg(64)_local, so make the name more accurate (HAVE_CMPXCHG_PERCPU_BYTE). Last, remove RISC-V's cmpxchg(64)_local definition because it's no use. Guo Ren (4): vmstat: percpu: Rename HAVE_CMPXCHG_LOCAL to HAVE_CMPXCHG_PERCPU_BYTE arm64: percpu: Use generic PERCPU_RW_OPS riscv: percpu: Implement this_cpu operations riscv: cmpxchg: Remove unused cmpxchg(64)_local .../locking/cmpxchg-local/arch-support.txt | 6 +- arch/Kconfig | 2 +- arch/arm64/Kconfig | 2 +- arch/arm64/include/asm/percpu.h | 33 ------ arch/riscv/include/asm/cmpxchg.h | 9 -- arch/riscv/include/asm/percpu.h | 104 ++++++++++++++++++ arch/s390/Kconfig | 2 +- arch/x86/Kconfig | 2 +- mm/vmstat.c | 4 +- 9 files changed, 113 insertions(+), 51 deletions(-) create mode 100644 arch/riscv/include/asm/percpu.h -- 2.36.1
WARNING: multiple messages have this Message-ID (diff)
From: guoren@kernel.org To: tj@kernel.org, cl@linux.com, palmer@dabbelt.com, will@kernel.org, catalin.marinas@arm.com, peterz@infradead.org, arnd@arndb.de Cc: linux-arch@vger.kernel.org, linux-kernel@vger.kernel.org, linux-riscv@lists.infradead.org, Guo Ren <guoren@linux.alibaba.com> Subject: [RFC PATCH 0/4] riscv: Add basic percpu operations Date: Mon, 8 Aug 2022 04:05:56 -0400 [thread overview] Message-ID: <20220808080600.3346843-1-guoren@kernel.org> (raw) From: Guo Ren <guoren@linux.alibaba.com> The series try to add basic percpu operations for riscv. HAVE_CMPXCHG_LOCAL would let people confuse with cmpxchg(64)_local, so make the name more accurate (HAVE_CMPXCHG_PERCPU_BYTE). Last, remove RISC-V's cmpxchg(64)_local definition because it's no use. Guo Ren (4): vmstat: percpu: Rename HAVE_CMPXCHG_LOCAL to HAVE_CMPXCHG_PERCPU_BYTE arm64: percpu: Use generic PERCPU_RW_OPS riscv: percpu: Implement this_cpu operations riscv: cmpxchg: Remove unused cmpxchg(64)_local .../locking/cmpxchg-local/arch-support.txt | 6 +- arch/Kconfig | 2 +- arch/arm64/Kconfig | 2 +- arch/arm64/include/asm/percpu.h | 33 ------ arch/riscv/include/asm/cmpxchg.h | 9 -- arch/riscv/include/asm/percpu.h | 104 ++++++++++++++++++ arch/s390/Kconfig | 2 +- arch/x86/Kconfig | 2 +- mm/vmstat.c | 4 +- 9 files changed, 113 insertions(+), 51 deletions(-) create mode 100644 arch/riscv/include/asm/percpu.h -- 2.36.1 _______________________________________________ linux-riscv mailing list linux-riscv@lists.infradead.org http://lists.infradead.org/mailman/listinfo/linux-riscv
next reply other threads:[~2022-08-08 8:06 UTC|newest] Thread overview: 14+ messages / expand[flat|nested] mbox.gz Atom feed top 2022-08-08 8:05 guoren [this message] 2022-08-08 8:05 ` [RFC PATCH 0/4] riscv: Add basic percpu operations guoren 2022-08-08 8:05 ` [RFC PATCH 1/4] vmstat: percpu: Rename HAVE_CMPXCHG_LOCAL to HAVE_CMPXCHG_PERCPU_BYTE guoren 2022-08-08 8:05 ` guoren 2022-08-08 9:31 ` Christoph Lameter 2022-08-08 9:31 ` Christoph Lameter 2022-08-09 2:58 ` Guo Ren 2022-08-09 2:58 ` Guo Ren 2022-08-08 8:05 ` [RFC PATCH 2/4] arm64: percpu: Use generic PERCPU_RW_OPS guoren 2022-08-08 8:05 ` guoren 2022-08-08 8:05 ` [RFC PATCH 3/4] riscv: percpu: Implement this_cpu operations guoren 2022-08-08 8:05 ` guoren 2022-08-08 8:06 ` [RFC PATCH 4/4] riscv: cmpxchg: Remove unused cmpxchg(64)_local guoren 2022-08-08 8:06 ` guoren
Reply instructions: You may reply publicly to this message via plain-text email using any one of the following methods: * Save the following mbox file, import it into your mail client, and reply-to-all from there: mbox Avoid top-posting and favor interleaved quoting: https://en.wikipedia.org/wiki/Posting_style#Interleaved_style * Reply using the --to, --cc, and --in-reply-to switches of git-send-email(1): git send-email \ --in-reply-to=20220808080600.3346843-1-guoren@kernel.org \ --to=guoren@kernel.org \ --cc=arnd@arndb.de \ --cc=catalin.marinas@arm.com \ --cc=cl@linux.com \ --cc=guoren@linux.alibaba.com \ --cc=linux-arch@vger.kernel.org \ --cc=linux-kernel@vger.kernel.org \ --cc=linux-riscv@lists.infradead.org \ --cc=palmer@dabbelt.com \ --cc=peterz@infradead.org \ --cc=tj@kernel.org \ --cc=will@kernel.org \ /path/to/YOUR_REPLY https://kernel.org/pub/software/scm/git/docs/git-send-email.html * If your mail client supports setting the In-Reply-To header via mailto: links, try the mailto: linkBe sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes, see mirroring instructions on how to clone and mirror all data and code used by this external index.