All of lore.kernel.org
 help / color / mirror / Atom feed
From: Kevin Wolf <kwolf@redhat.com>
To: qemu-block@nongnu.org
Cc: kwolf@redhat.com, hreitz@redhat.com, eesposit@redhat.com,
	pbonzini@redhat.com, vsementsov@yandex-team.ru,
	qemu-devel@nongnu.org
Subject: [PATCH 04/14] block: Rename refresh_total_sectors to bdrv_refresh_total_sectors
Date: Tue, 13 Dec 2022 09:53:10 +0100	[thread overview]
Message-ID: <20221213085320.95673-5-kwolf@redhat.com> (raw)
In-Reply-To: <20221213085320.95673-1-kwolf@redhat.com>

From: Emanuele Giuseppe Esposito <eesposit@redhat.com>

The name is not good, not the least because we are going to convert this
to a generated co_wrapper, which adds a _co infix after the first part
of the name.

No functional change intended.

Signed-off-by: Emanuele Giuseppe Esposito <eesposit@redhat.com>
Signed-off-by: Kevin Wolf <kwolf@redhat.com>
---
 include/block/block_int-io.h | 2 +-
 block.c                      | 8 ++++----
 block/io.c                   | 8 +++++---
 3 files changed, 10 insertions(+), 8 deletions(-)

diff --git a/include/block/block_int-io.h b/include/block/block_int-io.h
index 8bc061ebb8..6b285fb520 100644
--- a/include/block/block_int-io.h
+++ b/include/block/block_int-io.h
@@ -120,7 +120,7 @@ int coroutine_fn bdrv_co_copy_range_to(BdrvChild *src, int64_t src_offset,
                                        BdrvRequestFlags read_flags,
                                        BdrvRequestFlags write_flags);
 
-int refresh_total_sectors(BlockDriverState *bs, int64_t hint);
+int bdrv_refresh_total_sectors(BlockDriverState *bs, int64_t hint);
 
 BdrvChild *bdrv_cow_child(BlockDriverState *bs);
 BdrvChild *bdrv_filter_child(BlockDriverState *bs);
diff --git a/block.c b/block.c
index 9c2ac757e4..fdcd06d05d 100644
--- a/block.c
+++ b/block.c
@@ -1034,7 +1034,7 @@ static int find_image_format(BlockBackend *file, const char *filename,
  * Set the current 'total_sectors' value
  * Return 0 on success, -errno on error.
  */
-int refresh_total_sectors(BlockDriverState *bs, int64_t hint)
+int bdrv_refresh_total_sectors(BlockDriverState *bs, int64_t hint)
 {
     BlockDriver *drv = bs->drv;
     IO_CODE();
@@ -1651,7 +1651,7 @@ static int bdrv_open_driver(BlockDriverState *bs, BlockDriver *drv,
     bs->supported_read_flags |= BDRV_REQ_REGISTERED_BUF;
     bs->supported_write_flags |= BDRV_REQ_REGISTERED_BUF;
 
-    ret = refresh_total_sectors(bs, bs->total_sectors);
+    ret = bdrv_refresh_total_sectors(bs, bs->total_sectors);
     if (ret < 0) {
         error_setg_errno(errp, -ret, "Could not refresh total sector count");
         return ret;
@@ -5808,7 +5808,7 @@ int64_t bdrv_nb_sectors(BlockDriverState *bs)
         return -ENOMEDIUM;
 
     if (drv->has_variable_length) {
-        int ret = refresh_total_sectors(bs, bs->total_sectors);
+        int ret = bdrv_refresh_total_sectors(bs, bs->total_sectors);
         if (ret < 0) {
             return ret;
         }
@@ -6590,7 +6590,7 @@ int bdrv_activate(BlockDriverState *bs, Error **errp)
             bdrv_dirty_bitmap_skip_store(bm, false);
         }
 
-        ret = refresh_total_sectors(bs, bs->total_sectors);
+        ret = bdrv_refresh_total_sectors(bs, bs->total_sectors);
         if (ret < 0) {
             bs->open_flags |= BDRV_O_INACTIVE;
             error_setg_errno(errp, -ret, "Could not refresh total sector count");
diff --git a/block/io.c b/block/io.c
index c33672e90a..3940026dc1 100644
--- a/block/io.c
+++ b/block/io.c
@@ -3464,15 +3464,17 @@ int coroutine_fn bdrv_co_truncate(BdrvChild *child, int64_t offset, bool exact,
         goto out;
     }
 
-    ret = refresh_total_sectors(bs, offset >> BDRV_SECTOR_BITS);
+    ret = bdrv_refresh_total_sectors(bs, offset >> BDRV_SECTOR_BITS);
     if (ret < 0) {
         error_setg_errno(errp, -ret, "Could not refresh total sector count");
     } else {
         offset = bs->total_sectors * BDRV_SECTOR_SIZE;
     }
-    /* It's possible that truncation succeeded but refresh_total_sectors
+    /*
+     * It's possible that truncation succeeded but bdrv_refresh_total_sectors
      * failed, but the latter doesn't affect how we should finish the request.
-     * Pass 0 as the last parameter so that dirty bitmaps etc. are handled. */
+     * Pass 0 as the last parameter so that dirty bitmaps etc. are handled.
+     */
     bdrv_co_write_req_finish(child, offset - new_bytes, new_bytes, &req, 0);
 
 out:
-- 
2.38.1



  parent reply	other threads:[~2022-12-13  8:55 UTC|newest]

Thread overview: 28+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2022-12-13  8:53 [PATCH 00/14] block: Move more functions to coroutines Kevin Wolf
2022-12-13  8:53 ` [PATCH 01/14] block-coroutine-wrapper: support void functions Kevin Wolf
2022-12-16 14:21   ` Vladimir Sementsov-Ogievskiy
2022-12-13  8:53 ` [PATCH 02/14] block: Convert bdrv_io_plug() to co_wrapper Kevin Wolf
2022-12-16 14:26   ` Vladimir Sementsov-Ogievskiy
2022-12-19 12:24     ` Emanuele Giuseppe Esposito
2022-12-16 16:12   ` Vladimir Sementsov-Ogievskiy
2022-12-19 12:26     ` Emanuele Giuseppe Esposito
2023-01-13 15:51       ` Kevin Wolf
2022-12-13  8:53 ` [PATCH 03/14] block: Convert bdrv_io_unplug() " Kevin Wolf
2022-12-13  8:53 ` Kevin Wolf [this message]
2022-12-16 16:55   ` [PATCH 04/14] block: Rename refresh_total_sectors to bdrv_refresh_total_sectors Vladimir Sementsov-Ogievskiy
2022-12-13  8:53 ` [PATCH 05/14] block: Convert bdrv_refresh_total_sectors() to co_wrapper_mixed Kevin Wolf
2022-12-16 17:19   ` Vladimir Sementsov-Ogievskiy
2022-12-13  8:53 ` [PATCH 06/14] block-backend: use bdrv_getlength instead of blk_getlength Kevin Wolf
2022-12-16 17:22   ` Vladimir Sementsov-Ogievskiy
2022-12-19 12:28     ` Emanuele Giuseppe Esposito
2022-12-13  8:53 ` [PATCH 07/14] block: use bdrv_co_refresh_total_sectors when possible Kevin Wolf
2022-12-16 17:26   ` Vladimir Sementsov-Ogievskiy
2022-12-13  8:53 ` [PATCH 08/14] block: Convert bdrv_get_allocated_file_size() to co_wrapper Kevin Wolf
2022-12-13  8:53 ` [PATCH 09/14] block: Convert bdrv_get_info() to co_wrapper_mixed Kevin Wolf
2022-12-13  8:53 ` [PATCH 10/14] block: Convert bdrv_is_inserted() to co_wrapper Kevin Wolf
2022-12-13  8:53 ` [PATCH 11/14] block: Convert bdrv_eject() " Kevin Wolf
2022-12-13  8:53 ` [PATCH 12/14] block: convert bdrv_lock_medium in co_wrapper Kevin Wolf
2022-12-13  8:53 ` [PATCH 13/14] block: Convert bdrv_debug_event to co_wrapper_mixed Kevin Wolf
2022-12-13  8:53 ` [PATCH 14/14] block: Rename newly converted BlockDriver IO coroutine functions Kevin Wolf
2022-12-16 17:30   ` Vladimir Sementsov-Ogievskiy
2022-12-15 12:39 ` [PATCH 00/14] block: Move more functions to coroutines Emanuele Giuseppe Esposito

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20221213085320.95673-5-kwolf@redhat.com \
    --to=kwolf@redhat.com \
    --cc=eesposit@redhat.com \
    --cc=hreitz@redhat.com \
    --cc=pbonzini@redhat.com \
    --cc=qemu-block@nongnu.org \
    --cc=qemu-devel@nongnu.org \
    --cc=vsementsov@yandex-team.ru \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.