All of lore.kernel.org
 help / color / mirror / Atom feed
From: Christian Brauner <brauner@kernel.org>
To: Jeff Layton <jlayton@kernel.org>
Cc: tytso@mit.edu, adilger.kernel@dilger.ca, djwong@kernel.org,
	david@fromorbit.com, trondmy@hammerspace.com, neilb@suse.de,
	viro@zeniv.linux.org.uk, zohar@linux.ibm.com, xiubli@redhat.com,
	chuck.lever@oracle.com, lczerner@redhat.com, jack@suse.cz,
	bfields@fieldses.org, fweimer@redhat.com,
	linux-btrfs@vger.kernel.org, linux-fsdevel@vger.kernel.org,
	linux-kernel@vger.kernel.org, ceph-devel@vger.kernel.org,
	linux-ext4@vger.kernel.org, linux-nfs@vger.kernel.org,
	linux-xfs@vger.kernel.org
Subject: Re: [PATCH v8 RESEND 3/8] vfs: plumb i_version handling into struct kstat
Date: Thu, 26 Jan 2023 09:23:55 +0100	[thread overview]
Message-ID: <20230126082355.ejgunkoqr4kocz3b@wittgenstein> (raw)
In-Reply-To: <275450f6a909a640a416860b13a35769d253ab1b.camel@kernel.org>

On Wed, Jan 25, 2023 at 01:30:07PM -0500, Jeff Layton wrote:
> On Wed, 2023-01-25 at 16:50 +0100, Christian Brauner wrote:
> > On Tue, Jan 24, 2023 at 02:30:20PM -0500, Jeff Layton wrote:
> > > The NFS server has a lot of special handling for different types of
> > > change attribute access, depending on the underlying filesystem. In
> > > most cases, it's doing a getattr anyway and then fetching that value
> > > after the fact.
> > > 
> > > Rather that do that, add a new STATX_CHANGE_COOKIE flag that is a
> > > kernel-only symbol (for now). If requested and getattr can implement it,
> > > it can fill out this field. For IS_I_VERSION inodes, add a generic
> > > implementation in vfs_getattr_nosec. Take care to mask
> > > STATX_CHANGE_COOKIE off in requests from userland and in the result
> > > mask.
> > > 
> > > Since not all filesystems can give the same guarantees of monotonicity,
> > > claim a STATX_ATTR_CHANGE_MONOTONIC flag that filesystems can set to
> > > indicate that they offer an i_version value that can never go backward.
> > > 
> > > Eventually if we decide to make the i_version available to userland, we
> > > can just designate a field for it in struct statx, and move the
> > > STATX_CHANGE_COOKIE definition to the uapi header.
> > > 
> > > Reviewed-by: NeilBrown <neilb@suse.de>
> > > Signed-off-by: Jeff Layton <jlayton@kernel.org>
> > > ---
> > >  fs/stat.c            | 17 +++++++++++++++--
> > >  include/linux/stat.h |  9 +++++++++
> > >  2 files changed, 24 insertions(+), 2 deletions(-)
> > > 
> > > diff --git a/fs/stat.c b/fs/stat.c
> > > index d6cc74ca8486..f43afe0081fe 100644
> > > --- a/fs/stat.c
> > > +++ b/fs/stat.c
> > > @@ -18,6 +18,7 @@
> > >  #include <linux/syscalls.h>
> > >  #include <linux/pagemap.h>
> > >  #include <linux/compat.h>
> > > +#include <linux/iversion.h>
> > >  
> > >  #include <linux/uaccess.h>
> > >  #include <asm/unistd.h>
> > > @@ -122,6 +123,11 @@ int vfs_getattr_nosec(const struct path *path, struct kstat *stat,
> > >  	stat->attributes_mask |= (STATX_ATTR_AUTOMOUNT |
> > >  				  STATX_ATTR_DAX);
> > >  
> > > +	if ((request_mask & STATX_CHANGE_COOKIE) && IS_I_VERSION(inode)) {
> > > +		stat->result_mask |= STATX_CHANGE_COOKIE;
> > > +		stat->change_cookie = inode_query_iversion(inode);
> > > +	}
> > > +
> > >  	mnt_userns = mnt_user_ns(path->mnt);
> > >  	if (inode->i_op->getattr)
> > >  		return inode->i_op->getattr(mnt_userns, path, stat,
> > > @@ -602,9 +608,11 @@ cp_statx(const struct kstat *stat, struct statx __user *buffer)
> > >  
> > >  	memset(&tmp, 0, sizeof(tmp));
> > >  
> > > -	tmp.stx_mask = stat->result_mask;
> > > +	/* STATX_CHANGE_COOKIE is kernel-only for now */
> > > +	tmp.stx_mask = stat->result_mask & ~STATX_CHANGE_COOKIE;
> > >  	tmp.stx_blksize = stat->blksize;
> > > -	tmp.stx_attributes = stat->attributes;
> > > +	/* STATX_ATTR_CHANGE_MONOTONIC is kernel-only for now */
> > > +	tmp.stx_attributes = stat->attributes & ~STATX_ATTR_CHANGE_MONOTONIC;
> > >  	tmp.stx_nlink = stat->nlink;
> > >  	tmp.stx_uid = from_kuid_munged(current_user_ns(), stat->uid);
> > >  	tmp.stx_gid = from_kgid_munged(current_user_ns(), stat->gid);
> > > @@ -643,6 +651,11 @@ int do_statx(int dfd, struct filename *filename, unsigned int flags,
> > >  	if ((flags & AT_STATX_SYNC_TYPE) == AT_STATX_SYNC_TYPE)
> > >  		return -EINVAL;
> > >  
> > > +	/* STATX_CHANGE_COOKIE is kernel-only for now. Ignore requests
> > > +	 * from userland.
> > > +	 */
> > > +	mask &= ~STATX_CHANGE_COOKIE;
> > > +
> > >  	error = vfs_statx(dfd, filename, flags, &stat, mask);
> > >  	if (error)
> > >  		return error;
> > > diff --git a/include/linux/stat.h b/include/linux/stat.h
> > > index ff277ced50e9..52150570d37a 100644
> > > --- a/include/linux/stat.h
> > > +++ b/include/linux/stat.h
> > 
> > Sorry being late to the party once again...
> > 
> > > @@ -52,6 +52,15 @@ struct kstat {
> > >  	u64		mnt_id;
> > >  	u32		dio_mem_align;
> > >  	u32		dio_offset_align;
> > > +	u64		change_cookie;
> > >  };
> > >  
> > > +/* These definitions are internal to the kernel for now. Mainly used by nfsd. */
> > > +
> > > +/* mask values */
> > > +#define STATX_CHANGE_COOKIE		0x40000000U	/* Want/got stx_change_attr */
> > > +
> > > +/* file attribute values */
> > > +#define STATX_ATTR_CHANGE_MONOTONIC	0x8000000000000000ULL /* version monotonically increases */
> > 
> > maybe it would be better to copy what we do for SB_* vs SB_I_* flags and
> > at least rename them to:
> > 
> > STATX_I_CHANGE_COOKIE
> > STATX_I_ATTR_CHANGE_MONOTONIC
> > i_change_cookie
> 
> An "i_"/"I_" prefix says "inode" to me. Maybe I've been at this too
> long. ;)
> 
> > 
> > to visually distinguish internal and external flags.
> > 
> > And also if possible it might be useful to move STATX_I_* flags to the
> > higher 32 bits and then one can use upper_32_bits to retrieve kernel
> > internal flags and lower_32_bits for userspace flags in tiny wrappers.
> > 
> > (I did something similar for clone3() a few years ago but there to
> > distinguish between flags available both in clone() and clone3() and
> > such that are only available in clone3().)
> > 
> > But just a thought. I mostly worry about accidently leaking this to
> > userspace so ideally we'd even have separate fields in struct kstat for
> > internal and external attributes but that might bump kstat size, though
> > I don't think struct kstat is actually ever really allocated all that
> > much.
> 
> I'm not sure that the internal/external distinction matters much for
> filesystem providers or consumers of it. The place that it matters is at
> the userland interface level, where statx or something similar is
> called.
> 
> At some point we may want to make STATX_CHANGE_COOKIE queryable via
> statx, at which point we'll have to have a big flag day where we do
> s/STATX_I_CHANGE_COOKIE/STATX_CHANGE_COOKIE/.
> 
> I don't think it's worth it here.

I'm not fond of internal and external STATX_* flags having the exact
same name but fine. :)

  reply	other threads:[~2023-01-26  8:24 UTC|newest]

Thread overview: 20+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2023-01-24 19:30 [PATCH v8 RESEND 0/8] fs: clean up internal i_version handling Jeff Layton
2023-01-24 19:30 ` [PATCH v8 RESEND 1/8] fs: uninline inode_query_iversion Jeff Layton
2023-01-25 13:44   ` Jan Kara
2023-01-26  9:02   ` Christian Brauner
2023-01-24 19:30 ` [PATCH v8 RESEND 2/8] fs: clarify when the i_version counter must be updated Jeff Layton
2023-01-25 16:06   ` Jan Kara
2023-01-26 10:54     ` Jeff Layton
2023-01-26 11:36       ` Jan Kara
2023-01-26 12:02         ` Jeff Layton
2023-01-26  9:01   ` Christian Brauner
2023-01-24 19:30 ` [PATCH v8 RESEND 3/8] vfs: plumb i_version handling into struct kstat Jeff Layton
2023-01-25 15:50   ` Christian Brauner
2023-01-25 18:30     ` Jeff Layton
2023-01-26  8:23       ` Christian Brauner [this message]
2023-01-25 16:20   ` Jan Kara
2023-01-24 19:30 ` [PATCH v8 RESEND 4/8] nfs: report the inode version in getattr if requested Jeff Layton
2023-01-24 19:30 ` [PATCH v8 RESEND 5/8] ceph: " Jeff Layton
2023-01-24 19:30 ` [PATCH v8 RESEND 6/8] nfsd: move nfsd4_change_attribute to nfsfh.c Jeff Layton
2023-01-24 19:30 ` [PATCH v8 RESEND 7/8] nfsd: use the getattr operation to fetch i_version Jeff Layton
2023-01-24 19:30 ` [PATCH v8 RESEND 8/8] nfsd: remove fetch_iversion export operation Jeff Layton

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20230126082355.ejgunkoqr4kocz3b@wittgenstein \
    --to=brauner@kernel.org \
    --cc=adilger.kernel@dilger.ca \
    --cc=bfields@fieldses.org \
    --cc=ceph-devel@vger.kernel.org \
    --cc=chuck.lever@oracle.com \
    --cc=david@fromorbit.com \
    --cc=djwong@kernel.org \
    --cc=fweimer@redhat.com \
    --cc=jack@suse.cz \
    --cc=jlayton@kernel.org \
    --cc=lczerner@redhat.com \
    --cc=linux-btrfs@vger.kernel.org \
    --cc=linux-ext4@vger.kernel.org \
    --cc=linux-fsdevel@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-nfs@vger.kernel.org \
    --cc=linux-xfs@vger.kernel.org \
    --cc=neilb@suse.de \
    --cc=trondmy@hammerspace.com \
    --cc=tytso@mit.edu \
    --cc=viro@zeniv.linux.org.uk \
    --cc=xiubli@redhat.com \
    --cc=zohar@linux.ibm.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.