From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: from mga14.intel.com (mga14.intel.com [192.55.52.115]) by gabe.freedesktop.org (Postfix) with ESMTPS id 1A3C210E414 for ; Thu, 6 Jul 2023 06:06:38 +0000 (UTC) From: =?UTF-8?q?Zbigniew=20Kempczy=C5=84ski?= To: igt-dev@lists.freedesktop.org Date: Thu, 6 Jul 2023 08:05:43 +0200 Message-Id: <20230706060555.282757-5-zbigniew.kempczynski@intel.com> In-Reply-To: <20230706060555.282757-1-zbigniew.kempczynski@intel.com> References: <20230706060555.282757-1-zbigniew.kempczynski@intel.com> MIME-Version: 1.0 Content-Type: text/plain; charset=UTF-8 Content-Transfer-Encoding: 8bit Subject: [igt-dev] [PATCH i-g-t v2 04/16] lib/xe_query: Use vramN when returning string region name List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , Errors-To: igt-dev-bounces@lists.freedesktop.org Sender: "igt-dev" List-ID: For tests which are mixing regions (like xe_ccs) name is confusing. As an example might be example "subtest-name-vram-1-vram-1". It's more readable when it will be renamed to "subtest-name-vram1-vram1". Signed-off-by: Zbigniew KempczyƄski Reviewed-by: Karolina Stolarek --- lib/xe/xe_query.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/lib/xe/xe_query.c b/lib/xe/xe_query.c index 48fb5afba7..830b7e401d 100644 --- a/lib/xe/xe_query.c +++ b/lib/xe/xe_query.c @@ -445,7 +445,7 @@ struct drm_xe_query_mem_region *xe_mem_region(int fd, uint64_t region) * xe_region_name: * @region: region mask * - * Returns region string like "system" or "vram-n" where n=0...62. + * Returns region string like "system" or "vramN" where N=0...62. */ const char *xe_region_name(uint64_t region) { @@ -457,7 +457,7 @@ const char *xe_region_name(uint64_t region) vrams = calloc(64, sizeof(char *)); for (int i = 0; i < 64; i++) { if (i != 0) - asprintf(&vrams[i], "vram-%d", i - 1); + asprintf(&vrams[i], "vram%d", i - 1); else asprintf(&vrams[i], "system"); igt_assert(vrams[i]); -- 2.34.1