From mboxrd@z Thu Jan 1 00:00:00 1970 From: "Ananyev, Konstantin" Subject: Re: [PATCH 2/2] eal/x86: Use lock-prefixed instructions to reduce cost of rte_smp_mb() Date: Mon, 11 Dec 2017 17:30:08 +0000 Message-ID: <2601191342CEEE43887BDE71AB9772585FAC8193@irsmsx105.ger.corp.intel.com> References: <1512126771-27503-1-git-send-email-konstantin.ananyev@intel.com> <1512126771-27503-2-git-send-email-konstantin.ananyev@intel.com> <20171211171121.GB2232@bricha3-MOBL3.ger.corp.intel.com> Mime-Version: 1.0 Content-Type: text/plain; charset="us-ascii" Content-Transfer-Encoding: quoted-printable Cc: "dev@dpdk.org" To: "Richardson, Bruce" Return-path: Received: from mga12.intel.com (mga12.intel.com [192.55.52.136]) by dpdk.org (Postfix) with ESMTP id D647314E8 for ; Mon, 11 Dec 2017 18:30:21 +0100 (CET) In-Reply-To: <20171211171121.GB2232@bricha3-MOBL3.ger.corp.intel.com> Content-Language: en-US List-Id: DPDK patches and discussions List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , Errors-To: dev-bounces@dpdk.org Sender: "dev" Hi Bruce, > -----Original Message----- > From: Richardson, Bruce > Sent: Monday, December 11, 2017 5:11 PM > To: Ananyev, Konstantin > Cc: dev@dpdk.org > Subject: Re: [dpdk-dev] [PATCH 2/2] eal/x86: Use lock-prefixed instructio= ns to reduce cost of rte_smp_mb() >=20 > On Fri, Dec 01, 2017 at 11:12:51AM +0000, Konstantin Ananyev wrote: > > On x86 it is possible to use lock-prefixed instructions to get > > the similar effect as mfence. > > As pointed by Java guys, on most modern HW that gives a better > > performance than using mfence: > > https://shipilev.net/blog/2014/on-the-fence-with-dependencies/ > > That patch adopts that technique for rte_smp_mb() implementation. > > On BDW 2.2 mb_autotest on single lcore reports 2X cycle reduction, > > i.e. from ~110 to ~55 cycles per operation. > > > > Signed-off-by: Konstantin Ananyev > > --- > > .../common/include/arch/x86/rte_atomic.h | 45 ++++++++++++++= +++++++- > > 1 file changed, 43 insertions(+), 2 deletions(-) > > > > > + * As pointed by Java guys, that makes possible to use lock-prefixed > > + * instructions to get the same effect as mfence and on most modern HW > > + * that gives a better perfomarnce than using mfence: > > + * https://shipilev.net/blog/2014/on-the-fence-with-dependencies/ > > + * So below we use that technique for rte_smp_mb() implementation. > > + */ > > + > > +#ifdef RTE_ARCH_I686 > > +#define RTE_SP RTE_STR(esp) > > +#else > > +#define RTE_SP RTE_STR(rsp) > > +#endif > > + > > +#define RTE_MB_DUMMY_MEMP "-128(%%" RTE_SP ")" > > + > > +static __rte_always_inline void > > +rte_smp_mb(void) > > +{ > > + asm volatile("lock addl $0," RTE_MB_DUMMY_MEMP "; " ::: "memory"); > > +} >=20 > Rather than #defining RTE_SP and RTE_MB_DUMMY_MEMP, why not just put the > #ifdef into the rte_smp_mb itself and have two asm volatile lines with > hard-coded register names in them? It would be shorter and I think a lot > easier to read. Fine by me. Any other thoughts from anyone till I submit v2? Konstantin