All of lore.kernel.org
 help / color / mirror / Atom feed
From: <Tudor.Ambarus@microchip.com>
To: <michael@walle.cc>
Cc: <p.yadav@ti.com>, <miquel.raynal@bootlin.com>, <richard@nod.at>,
	<vigneshr@ti.com>, <quic_c_sbhanu@quicinc.com>,
	<linux-mtd@lists.infradead.org>, <linux-kernel@vger.kernel.org>
Subject: Re: [PATCH 1/2] mtd: spi-nor: introduce SNOR_ID3()
Date: Thu, 28 Jul 2022 13:31:01 +0000	[thread overview]
Message-ID: <29f4cff4-edc5-3838-2495-253e794178ae@microchip.com> (raw)
In-Reply-To: <ff6ffb3f8e77b29b44883d30c9b4385e@walle.cc>

On 7/28/22 16:12, Michael Walle wrote:
> EXTERNAL EMAIL: Do not click links or open attachments unless you know the content is safe
> 
>>>> +#define SNOR_ID3(_jedec_id)
>>
>> How about SFDP_ID3 and SFDP_ID6 instead?
> 
> Yes, probably a better name. I was also thinking about splitting
> the id in vendor, device and additional bytes. But I haven't
> thought of the actual implementation that much. Such as:
> 
> #define SFDP_ID(<u8 vid>, <u16 did>, <variable aux bytes>)
> #define SFDP_ID_FULL(<num_continuation_code>, <u8 vid>, <u16 did>,
> <variable aux bytes>)
> 
> Couldn't make up a better name than that _FULL for now. Happy to hear
> suggestions :)
> 

You mean splitting the ID in manufacturer ID, flash ID and extended flash ID?
I'd like to understand the benefits of splitting this, can you give me an
example? In the past I though about introducing some flash info macros for
families of flashes of the same vendor, it will reduce the number of lines
on flash definition, but not really related.

-- 
Cheers,
ta

WARNING: multiple messages have this Message-ID (diff)
From: <Tudor.Ambarus@microchip.com>
To: <michael@walle.cc>
Cc: <p.yadav@ti.com>, <miquel.raynal@bootlin.com>, <richard@nod.at>,
	<vigneshr@ti.com>, <quic_c_sbhanu@quicinc.com>,
	<linux-mtd@lists.infradead.org>, <linux-kernel@vger.kernel.org>
Subject: Re: [PATCH 1/2] mtd: spi-nor: introduce SNOR_ID3()
Date: Thu, 28 Jul 2022 13:31:01 +0000	[thread overview]
Message-ID: <29f4cff4-edc5-3838-2495-253e794178ae@microchip.com> (raw)
In-Reply-To: <ff6ffb3f8e77b29b44883d30c9b4385e@walle.cc>

On 7/28/22 16:12, Michael Walle wrote:
> EXTERNAL EMAIL: Do not click links or open attachments unless you know the content is safe
> 
>>>> +#define SNOR_ID3(_jedec_id)
>>
>> How about SFDP_ID3 and SFDP_ID6 instead?
> 
> Yes, probably a better name. I was also thinking about splitting
> the id in vendor, device and additional bytes. But I haven't
> thought of the actual implementation that much. Such as:
> 
> #define SFDP_ID(<u8 vid>, <u16 did>, <variable aux bytes>)
> #define SFDP_ID_FULL(<num_continuation_code>, <u8 vid>, <u16 did>,
> <variable aux bytes>)
> 
> Couldn't make up a better name than that _FULL for now. Happy to hear
> suggestions :)
> 

You mean splitting the ID in manufacturer ID, flash ID and extended flash ID?
I'd like to understand the benefits of splitting this, can you give me an
example? In the past I though about introducing some flash info macros for
families of flashes of the same vendor, it will reduce the number of lines
on flash definition, but not really related.

-- 
Cheers,
ta
______________________________________________________
Linux MTD discussion mailing list
http://lists.infradead.org/mailman/listinfo/linux-mtd/

  reply	other threads:[~2022-07-28 13:31 UTC|newest]

Thread overview: 44+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2022-05-10 14:02 [PATCH 0/2] introduce SNOR_ID3() Michael Walle
2022-05-10 14:02 ` Michael Walle
2022-05-10 14:02 ` [PATCH 1/2] mtd: spi-nor: " Michael Walle
2022-05-10 14:02   ` Michael Walle
2022-06-05 15:00   ` Tom Fitzhenry
2022-06-05 15:00     ` Tom Fitzhenry
2022-07-12  7:23   ` Pratyush Yadav
2022-07-15 12:19     ` Biju Das
2022-07-15 12:19     ` Biju Das
2022-07-12  7:23     ` Pratyush Yadav
2022-07-19  5:57   ` Tudor.Ambarus
2022-07-19  5:57     ` Tudor.Ambarus
2022-07-19  7:07     ` Michael Walle
2022-07-19  7:07       ` Michael Walle
2022-07-19  7:33       ` Tudor.Ambarus
2022-07-19  7:33         ` Tudor.Ambarus
2022-07-19  7:57         ` Michael Walle
2022-07-19  7:57           ` Michael Walle
2022-07-19  8:30           ` Tudor.Ambarus
2022-07-19  8:30             ` Tudor.Ambarus
2022-07-28  3:24     ` Tudor.Ambarus
2022-07-28  3:24       ` Tudor.Ambarus
2022-07-28 13:12       ` Michael Walle
2022-07-28 13:12         ` Michael Walle
2022-07-28 13:31         ` Tudor.Ambarus [this message]
2022-07-28 13:31           ` Tudor.Ambarus
2022-07-28 13:56           ` Michael Walle
2022-07-28 13:56             ` Michael Walle
2022-05-10 14:02 ` [PATCH 2/2] mtd: spi-nor: winbond: use SNOR_ID3() for w25q512nwm Michael Walle
2022-05-10 14:02   ` Michael Walle
2022-07-12  8:40   ` Tudor.Ambarus
2022-07-12  8:40     ` Tudor.Ambarus
2022-07-18  7:21     ` Michael Walle
2022-07-18  7:21       ` Michael Walle
2022-07-18  7:25     ` Michael Walle
2022-07-18  7:25       ` Michael Walle
2022-07-19  6:00       ` Tudor.Ambarus
2022-07-19  6:00         ` Tudor.Ambarus
2022-07-19  7:02         ` Michael Walle
2022-07-19  7:02           ` Michael Walle
2022-07-19  7:24           ` Tudor.Ambarus
2022-07-19  7:24             ` Tudor.Ambarus
2022-05-10 14:03 ` [PATCH 0/2] mtd: spi-nor: introduce SNOR_ID3() Michael Walle
2022-05-10 14:03   ` Michael Walle

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=29f4cff4-edc5-3838-2495-253e794178ae@microchip.com \
    --to=tudor.ambarus@microchip.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-mtd@lists.infradead.org \
    --cc=michael@walle.cc \
    --cc=miquel.raynal@bootlin.com \
    --cc=p.yadav@ti.com \
    --cc=quic_c_sbhanu@quicinc.com \
    --cc=richard@nod.at \
    --cc=vigneshr@ti.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.