All of lore.kernel.org
 help / color / mirror / Atom feed
From: Baolu Lu <baolu.lu@linux.intel.com>
To: Jean-Philippe Brucker <jean-philippe@linaro.org>
Cc: baolu.lu@linux.intel.com, Joerg Roedel <joro@8bytes.org>,
	Jason Gunthorpe <jgg@nvidia.com>,
	Christoph Hellwig <hch@infradead.org>,
	Kevin Tian <kevin.tian@intel.com>,
	Ashok Raj <ashok.raj@intel.com>, Will Deacon <will@kernel.org>,
	Robin Murphy <robin.murphy@arm.com>,
	Jean-Philippe Brucker <jean-philippe@linaro.com>,
	Dave Jiang <dave.jiang@intel.com>, Vinod Koul <vkoul@kernel.org>,
	Eric Auger <eric.auger@redhat.com>, Liu Yi L <yi.l.liu@intel.com>,
	Jacob jun Pan <jacob.jun.pan@intel.com>,
	iommu@lists.linux-foundation.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH v7 06/10] iommu/sva: Refactoring iommu_sva_bind/unbind_device()
Date: Fri, 20 May 2022 14:38:12 +0800	[thread overview]
Message-ID: <3636ac5e-4f52-26a9-db73-5858a27f61b8@linux.intel.com> (raw)
In-Reply-To: <YoZyvVxJLiYOjBHw@myrica>

On 2022/5/20 00:39, Jean-Philippe Brucker wrote:
>> +struct iommu_sva *iommu_sva_bind_device(struct device *dev, struct mm_struct *mm)
>> +{
>> +	struct iommu_sva_domain *sva_domain;
>> +	struct iommu_domain *domain;
>> +	ioasid_t max_pasid = 0;
>> +	int ret = -EINVAL;
>> +
>> +	/* Allocate mm->pasid if necessary. */
>> +	if (!dev->iommu->iommu_dev->pasids)
>> +		return ERR_PTR(-EOPNOTSUPP);
>> +
>> +	if (dev_is_pci(dev)) {
>> +		max_pasid = pci_max_pasids(to_pci_dev(dev));
>> +		if (max_pasid < 0)
>> +			return ERR_PTR(max_pasid);
>> +	} else {
>> +		ret = device_property_read_u32(dev, "pasid-num-bits",
>> +					       &max_pasid);
>> +		if (ret)
>> +			return ERR_PTR(ret);
>> +		max_pasid = (1UL << max_pasid);
>> +	}
> The IOMMU driver needs this PASID width information earlier, when creating
> the PASID table (in .probe_device(), .attach_dev()). Since we're moving it
> to the IOMMU core to avoid code duplication, it should be done earlier and
> stored in dev->iommu

Yes, really. How about below changes?

 From f1382579e8a15ca49acdf758d38fd36451ea174d Mon Sep 17 00:00:00 2001
From: Lu Baolu <baolu.lu@linux.intel.com>
Date: Mon, 28 Feb 2022 15:01:35 +0800
Subject: [PATCH 1/1] iommu: Add pasids field in struct dev_iommu

Use this field to save the number of PASIDs that a device is able to
consume. It is a generic attribute of a device and lifting it into the
per-device dev_iommu struct could help to avoid the boilerplate code
in various IOMMU drivers.

Signed-off-by: Lu Baolu <baolu.lu@linux.intel.com>
---
  drivers/iommu/iommu.c | 15 +++++++++++++++
  include/linux/iommu.h |  2 ++
  2 files changed, 17 insertions(+)

diff --git a/drivers/iommu/iommu.c b/drivers/iommu/iommu.c
index e49c5a5b8cc1..6b731171d42f 100644
--- a/drivers/iommu/iommu.c
+++ b/drivers/iommu/iommu.c
@@ -20,6 +20,7 @@
  #include <linux/idr.h>
  #include <linux/err.h>
  #include <linux/pci.h>
+#include <linux/pci-ats.h>
  #include <linux/bitops.h>
  #include <linux/property.h>
  #include <linux/fsl/mc.h>
@@ -194,6 +195,8 @@ EXPORT_SYMBOL_GPL(iommu_device_unregister);
  static struct dev_iommu *dev_iommu_get(struct device *dev)
  {
  	struct dev_iommu *param = dev->iommu;
+	u32 max_pasids = 0;
+	int ret;

  	if (param)
  		return param;
@@ -202,6 +205,18 @@ static struct dev_iommu *dev_iommu_get(struct 
device *dev)
  	if (!param)
  		return NULL;

+	if (dev_is_pci(dev)) {
+		ret = pci_max_pasids(to_pci_dev(dev));
+		if (ret > 0)
+			max_pasids = ret;
+	} else {
+		ret = device_property_read_u32(dev, "pasid-num-bits",
+					       &max_pasids);
+		if (!ret)
+			max_pasids = (1UL << max_pasids);
+	}
+	param->pasids = max_pasids;
+
  	mutex_init(&param->lock);
  	dev->iommu = param;
  	return param;
diff --git a/include/linux/iommu.h b/include/linux/iommu.h
index 45f274b2640d..d4296136ba75 100644
--- a/include/linux/iommu.h
+++ b/include/linux/iommu.h
@@ -371,6 +371,7 @@ struct iommu_fault_param {
   * @fwspec:	 IOMMU fwspec data
   * @iommu_dev:	 IOMMU device this device is linked to
   * @priv:	 IOMMU Driver private data
+ * @pasids:	 number of supported PASIDs
   *
   * TODO: migrate other per device data pointers under iommu_dev_data, e.g.
   *	struct iommu_group	*iommu_group;
@@ -382,6 +383,7 @@ struct dev_iommu {
  	struct iommu_fwspec		*fwspec;
  	struct iommu_device		*iommu_dev;
  	void				*priv;
+	u32				pasids;
  };

  int iommu_device_register(struct iommu_device *iommu,
-- 
2.25.1

Best regards,
baolu

WARNING: multiple messages have this Message-ID (diff)
From: Baolu Lu <baolu.lu@linux.intel.com>
To: Jean-Philippe Brucker <jean-philippe@linaro.org>
Cc: Kevin Tian <kevin.tian@intel.com>,
	Dave Jiang <dave.jiang@intel.com>,
	Ashok Raj <ashok.raj@intel.com>,
	Robin Murphy <robin.murphy@arm.com>,
	iommu@lists.linux-foundation.org, linux-kernel@vger.kernel.org,
	Christoph Hellwig <hch@infradead.org>,
	Jean-Philippe Brucker <jean-philippe@linaro.com>,
	Vinod Koul <vkoul@kernel.org>,
	Jacob jun Pan <jacob.jun.pan@intel.com>,
	Jason Gunthorpe <jgg@nvidia.com>, Will Deacon <will@kernel.org>
Subject: Re: [PATCH v7 06/10] iommu/sva: Refactoring iommu_sva_bind/unbind_device()
Date: Fri, 20 May 2022 14:38:12 +0800	[thread overview]
Message-ID: <3636ac5e-4f52-26a9-db73-5858a27f61b8@linux.intel.com> (raw)
In-Reply-To: <YoZyvVxJLiYOjBHw@myrica>

On 2022/5/20 00:39, Jean-Philippe Brucker wrote:
>> +struct iommu_sva *iommu_sva_bind_device(struct device *dev, struct mm_struct *mm)
>> +{
>> +	struct iommu_sva_domain *sva_domain;
>> +	struct iommu_domain *domain;
>> +	ioasid_t max_pasid = 0;
>> +	int ret = -EINVAL;
>> +
>> +	/* Allocate mm->pasid if necessary. */
>> +	if (!dev->iommu->iommu_dev->pasids)
>> +		return ERR_PTR(-EOPNOTSUPP);
>> +
>> +	if (dev_is_pci(dev)) {
>> +		max_pasid = pci_max_pasids(to_pci_dev(dev));
>> +		if (max_pasid < 0)
>> +			return ERR_PTR(max_pasid);
>> +	} else {
>> +		ret = device_property_read_u32(dev, "pasid-num-bits",
>> +					       &max_pasid);
>> +		if (ret)
>> +			return ERR_PTR(ret);
>> +		max_pasid = (1UL << max_pasid);
>> +	}
> The IOMMU driver needs this PASID width information earlier, when creating
> the PASID table (in .probe_device(), .attach_dev()). Since we're moving it
> to the IOMMU core to avoid code duplication, it should be done earlier and
> stored in dev->iommu

Yes, really. How about below changes?

 From f1382579e8a15ca49acdf758d38fd36451ea174d Mon Sep 17 00:00:00 2001
From: Lu Baolu <baolu.lu@linux.intel.com>
Date: Mon, 28 Feb 2022 15:01:35 +0800
Subject: [PATCH 1/1] iommu: Add pasids field in struct dev_iommu

Use this field to save the number of PASIDs that a device is able to
consume. It is a generic attribute of a device and lifting it into the
per-device dev_iommu struct could help to avoid the boilerplate code
in various IOMMU drivers.

Signed-off-by: Lu Baolu <baolu.lu@linux.intel.com>
---
  drivers/iommu/iommu.c | 15 +++++++++++++++
  include/linux/iommu.h |  2 ++
  2 files changed, 17 insertions(+)

diff --git a/drivers/iommu/iommu.c b/drivers/iommu/iommu.c
index e49c5a5b8cc1..6b731171d42f 100644
--- a/drivers/iommu/iommu.c
+++ b/drivers/iommu/iommu.c
@@ -20,6 +20,7 @@
  #include <linux/idr.h>
  #include <linux/err.h>
  #include <linux/pci.h>
+#include <linux/pci-ats.h>
  #include <linux/bitops.h>
  #include <linux/property.h>
  #include <linux/fsl/mc.h>
@@ -194,6 +195,8 @@ EXPORT_SYMBOL_GPL(iommu_device_unregister);
  static struct dev_iommu *dev_iommu_get(struct device *dev)
  {
  	struct dev_iommu *param = dev->iommu;
+	u32 max_pasids = 0;
+	int ret;

  	if (param)
  		return param;
@@ -202,6 +205,18 @@ static struct dev_iommu *dev_iommu_get(struct 
device *dev)
  	if (!param)
  		return NULL;

+	if (dev_is_pci(dev)) {
+		ret = pci_max_pasids(to_pci_dev(dev));
+		if (ret > 0)
+			max_pasids = ret;
+	} else {
+		ret = device_property_read_u32(dev, "pasid-num-bits",
+					       &max_pasids);
+		if (!ret)
+			max_pasids = (1UL << max_pasids);
+	}
+	param->pasids = max_pasids;
+
  	mutex_init(&param->lock);
  	dev->iommu = param;
  	return param;
diff --git a/include/linux/iommu.h b/include/linux/iommu.h
index 45f274b2640d..d4296136ba75 100644
--- a/include/linux/iommu.h
+++ b/include/linux/iommu.h
@@ -371,6 +371,7 @@ struct iommu_fault_param {
   * @fwspec:	 IOMMU fwspec data
   * @iommu_dev:	 IOMMU device this device is linked to
   * @priv:	 IOMMU Driver private data
+ * @pasids:	 number of supported PASIDs
   *
   * TODO: migrate other per device data pointers under iommu_dev_data, e.g.
   *	struct iommu_group	*iommu_group;
@@ -382,6 +383,7 @@ struct dev_iommu {
  	struct iommu_fwspec		*fwspec;
  	struct iommu_device		*iommu_dev;
  	void				*priv;
+	u32				pasids;
  };

  int iommu_device_register(struct iommu_device *iommu,
-- 
2.25.1

Best regards,
baolu
_______________________________________________
iommu mailing list
iommu@lists.linux-foundation.org
https://lists.linuxfoundation.org/mailman/listinfo/iommu

  reply	other threads:[~2022-05-20  6:38 UTC|newest]

Thread overview: 100+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2022-05-19  7:20 [PATCH v7 00/10] iommu: SVA and IOPF refactoring Lu Baolu
2022-05-19  7:20 ` Lu Baolu
2022-05-19  7:20 ` [PATCH v7 01/10] iommu: Add pasids field in struct iommu_device Lu Baolu
2022-05-19  7:20   ` Lu Baolu
2022-05-19 10:37   ` Jean-Philippe Brucker
2022-05-19 10:37     ` Jean-Philippe Brucker
2022-05-19 11:55     ` Baolu Lu
2022-05-19 11:55       ` Baolu Lu
2022-05-24  9:24   ` Tian, Kevin
2022-05-24  9:24     ` Tian, Kevin
2022-05-25  2:03     ` Baolu Lu
2022-05-25  2:03       ` Baolu Lu
2022-05-25  2:13       ` Baolu Lu
2022-05-25  2:13         ` Baolu Lu
2022-05-19  7:20 ` [PATCH v7 02/10] iommu: Remove SVM_FLAG_SUPERVISOR_MODE support Lu Baolu
2022-05-19  7:20   ` Lu Baolu
2022-05-19 16:22   ` Jean-Philippe Brucker
2022-05-19 16:22     ` Jean-Philippe Brucker
2022-05-24  9:27   ` Tian, Kevin
2022-05-24  9:27     ` Tian, Kevin
2022-05-19  7:20 ` [PATCH v7 03/10] iommu/sva: Add iommu_sva_domain support Lu Baolu
2022-05-19  7:20   ` Lu Baolu
2022-05-19 16:33   ` Jean-Philippe Brucker
2022-05-19 16:33     ` Jean-Philippe Brucker
2022-05-20  4:55     ` Baolu Lu
2022-05-20  4:55       ` Baolu Lu
2022-05-23  7:12   ` Baolu Lu
2022-05-23  7:12     ` Baolu Lu
2022-05-24  9:44     ` Tian, Kevin
2022-05-24  9:44       ` Tian, Kevin
2022-05-25  2:18       ` Baolu Lu
2022-05-25  2:18         ` Baolu Lu
2022-05-24  9:39   ` Tian, Kevin
2022-05-24  9:39     ` Tian, Kevin
2022-05-24 13:38     ` Jason Gunthorpe
2022-05-24 13:38       ` Jason Gunthorpe via iommu
2022-05-25  0:44       ` Tian, Kevin
2022-05-25  0:44         ` Tian, Kevin
2022-05-25  2:38         ` Baolu Lu
2022-05-25  2:38           ` Baolu Lu
2022-05-25  4:50     ` Baolu Lu
2022-05-25  4:50       ` Baolu Lu
2022-05-24 13:44   ` Jason Gunthorpe
2022-05-24 13:44     ` Jason Gunthorpe via iommu
2022-05-25  5:19     ` Baolu Lu
2022-05-25  5:19       ` Baolu Lu
2022-05-25 15:25       ` Jason Gunthorpe
2022-05-25 15:25         ` Jason Gunthorpe via iommu
2022-05-26  1:03         ` Baolu Lu
2022-05-26  1:03           ` Baolu Lu
2022-05-25  5:33     ` Baolu Lu
2022-05-25  5:33       ` Baolu Lu
2022-05-24 14:36   ` Robin Murphy
2022-05-24 14:36     ` Robin Murphy
2022-05-25  6:20     ` Baolu Lu
2022-05-25  6:20       ` Baolu Lu
2022-05-25 10:07       ` Robin Murphy
2022-05-25 10:07         ` Robin Murphy
2022-05-25 11:06         ` Jean-Philippe Brucker
2022-05-25 11:06           ` Jean-Philippe Brucker
2022-05-25 13:11           ` Baolu Lu
2022-05-25 13:11             ` Baolu Lu
2022-05-19  7:20 ` [PATCH v7 04/10] iommu/vt-d: Add SVA domain support Lu Baolu
2022-05-19  7:20   ` Lu Baolu
2022-05-19  7:20 ` [PATCH v7 05/10] arm-smmu-v3/sva: " Lu Baolu
2022-05-19  7:20   ` Lu Baolu
2022-05-19 16:37   ` Jean-Philippe Brucker
2022-05-19 16:37     ` Jean-Philippe Brucker
2022-05-19  7:20 ` [PATCH v7 06/10] iommu/sva: Refactoring iommu_sva_bind/unbind_device() Lu Baolu
2022-05-19  7:20   ` Lu Baolu
2022-05-19 16:39   ` Jean-Philippe Brucker
2022-05-19 16:39     ` Jean-Philippe Brucker
2022-05-20  6:38     ` Baolu Lu [this message]
2022-05-20  6:38       ` Baolu Lu
2022-05-20 11:28       ` Jean-Philippe Brucker
2022-05-20 11:28         ` Jean-Philippe Brucker
2022-05-23  3:07         ` Baolu Lu
2022-05-23  3:07           ` Baolu Lu
2022-05-24 10:22   ` Tian, Kevin
2022-05-24 10:22     ` Tian, Kevin
2022-05-24 10:57     ` Jean-Philippe Brucker
2022-05-24 10:57       ` Jean-Philippe Brucker
2022-05-25  2:04       ` Tian, Kevin
2022-05-25  2:04         ` Tian, Kevin
2022-05-25  7:29         ` Jean-Philippe Brucker
2022-05-25  7:29           ` Jean-Philippe Brucker
2022-06-02  6:46           ` Tian, Kevin
2022-06-02  6:46             ` Tian, Kevin
2022-05-19  7:20 ` [PATCH v7 07/10] iommu: Remove SVA related callbacks from iommu ops Lu Baolu
2022-05-19  7:20   ` Lu Baolu
2022-05-24 10:23   ` Tian, Kevin
2022-05-24 10:23     ` Tian, Kevin
2022-05-19  7:20 ` [PATCH v7 08/10] iommu: Prepare IOMMU domain for IOPF Lu Baolu
2022-05-19  7:20   ` Lu Baolu
2022-05-19 16:40   ` Jean-Philippe Brucker
2022-05-19 16:40     ` Jean-Philippe Brucker
2022-05-19  7:20 ` [PATCH v7 09/10] iommu: Per-domain I/O page fault handling Lu Baolu
2022-05-19  7:20   ` Lu Baolu
2022-05-19  7:20 ` [PATCH v7 10/10] iommu: Rename iommu-sva-lib.{c,h} Lu Baolu
2022-05-19  7:20   ` Lu Baolu

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=3636ac5e-4f52-26a9-db73-5858a27f61b8@linux.intel.com \
    --to=baolu.lu@linux.intel.com \
    --cc=ashok.raj@intel.com \
    --cc=dave.jiang@intel.com \
    --cc=eric.auger@redhat.com \
    --cc=hch@infradead.org \
    --cc=iommu@lists.linux-foundation.org \
    --cc=jacob.jun.pan@intel.com \
    --cc=jean-philippe@linaro.com \
    --cc=jean-philippe@linaro.org \
    --cc=jgg@nvidia.com \
    --cc=joro@8bytes.org \
    --cc=kevin.tian@intel.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=robin.murphy@arm.com \
    --cc=vkoul@kernel.org \
    --cc=will@kernel.org \
    --cc=yi.l.liu@intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.