All of lore.kernel.org
 help / color / mirror / Atom feed
From: Guenter Roeck <linux@roeck-us.net>
To: IKEGAMI Tokunori <ikegami@allied-telesis.co.jp>,
	Jean Delvare <jdelvare@suse.com>
Cc: PACKHAM Chris <chris.packham@alliedtelesis.co.nz>,
	"linux-hwmon@vger.kernel.org" <linux-hwmon@vger.kernel.org>
Subject: Re: [PATCH 3/5] hwmon: adt7475: Change to use adt7475_read macro
Date: Wed, 11 Jul 2018 20:41:58 -0700	[thread overview]
Message-ID: <3860355d-ed87-902c-dc54-908c85f98ce4@roeck-us.net> (raw)
In-Reply-To: <OSAPR01MB317031FF04DEDDC33E01C2E0DC590@OSAPR01MB3170.jpnprd01.prod.outlook.com>

On 07/11/2018 07:52 PM, IKEGAMI Tokunori wrote:
> Hi Guenter-san,
> 
> Thank you so much for your comments.
> Okay now I am thinking to change the adt7475_read macro to a function to repeat for the error case.
> If you have any comment about this please let me know.

Yes - we should only do this if it is known to be a chip problem.
Patching the chip driver for a board (or i2c controller) problem
is not appropriate.

Guenter

> Anyway I will do send v2 version patches later.
> 
> Regards,
> Ikegami
> 
>> -----Original Message-----
>> From: Guenter Roeck [mailto:groeck7@gmail.com] On Behalf Of Guenter
>> Roeck
>> Sent: Thursday, July 12, 2018 10:50 AM
>> To: IKEGAMI Tokunori; Jean Delvare
>> Cc: PACKHAM Chris; linux-hwmon@vger.kernel.org
>> Subject: Re: [PATCH 3/5] hwmon: adt7475: Change to use adt7475_read macro
>>
>> On 07/11/2018 06:04 PM, Tokunori Ikegami wrote:
>>> It shoudl be same as with other functions to use adt7475_read.
>>> So change to use it instead of i2c_smbus_read_byte_data.
>>>
>>
>> I don't see a point in this change. Replacing a function name doesn't
>> make
>> the code easier to read. If anything, you could consider dropping
>> adt7475_read
>> and calling i2c_smbus_read_byte_data() directly.
>>
>> Guenter
>>
>>> Signed-off-by: Tokunori Ikegami <ikegami@allied-telesis.co.jp>
>>> Cc: Chris Packham <chris.packham@alliedtelesis.co.nz>
>>> Cc: linux-hwmon@vger.kernel.org
>>> ---
>>>    drivers/hwmon/adt7475.c | 2 +-
>>>    1 file changed, 1 insertion(+), 1 deletion(-)
>>>
>>> diff --git a/drivers/hwmon/adt7475.c b/drivers/hwmon/adt7475.c
>>> index a40eb62ee6b1..bad250729e99 100644
>>> --- a/drivers/hwmon/adt7475.c
>>> +++ b/drivers/hwmon/adt7475.c
>>> @@ -1012,7 +1012,7 @@ static ssize_t
>> pwm_use_point2_pwm_at_crit_store(struct device *dev,
>>>    		return -EINVAL;
>>>
>>>    	mutex_lock(&data->lock);
>>> -	data->config4 = i2c_smbus_read_byte_data(client,
>> REG_CONFIG4);
>>> +	data->config4 = adt7475_read(REG_CONFIG4);
>>>    	if (val)
>>>    		data->config4 |= CONFIG4_MAXDUTY;
>>>    	else
>>>
> 


  reply	other threads:[~2018-07-12  3:49 UTC|newest]

Thread overview: 19+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2018-07-12  1:04 [PATCH 0/5] hwmon: adt7475: Add error handling for update function Tokunori Ikegami
2018-07-12  1:04 ` [PATCH 1/5] hwmon: adt7475: Split device update function to measure and limits Tokunori Ikegami
2018-07-12  2:00   ` Guenter Roeck
2018-07-12  3:01     ` IKEGAMI Tokunori
2018-07-12  1:04 ` [PATCH 2/5] hwmon: adt7475: Change read and write functions to return error Tokunori Ikegami
2018-07-12  1:04 ` [PATCH 3/5] hwmon: adt7475: Change to use adt7475_read macro Tokunori Ikegami
2018-07-12  1:50   ` Guenter Roeck
2018-07-12  2:52     ` IKEGAMI Tokunori
2018-07-12  3:41       ` Guenter Roeck [this message]
2018-07-12  4:01         ` IKEGAMI Tokunori
2018-07-12  4:23           ` Guenter Roeck
2018-07-12  6:22             ` IKEGAMI Tokunori
2018-07-12 13:47             ` IKEGAMI Tokunori
2018-07-12 14:05               ` Guenter Roeck
2018-07-12 14:33                 ` IKEGAMI Tokunori
2018-07-12  1:04 ` [PATCH 4/5] hwmon: adt7475: Change to use adt7475_write macro Tokunori Ikegami
2018-07-12  1:52   ` Guenter Roeck
2018-07-12  2:56     ` IKEGAMI Tokunori
2018-07-12  1:04 ` [PATCH 5/5] hwmon: adt7475: Change update functions to add error handling Tokunori Ikegami

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=3860355d-ed87-902c-dc54-908c85f98ce4@roeck-us.net \
    --to=linux@roeck-us.net \
    --cc=chris.packham@alliedtelesis.co.nz \
    --cc=ikegami@allied-telesis.co.jp \
    --cc=jdelvare@suse.com \
    --cc=linux-hwmon@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.