All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH] docs/tools/virtiofsd.rst: Do not hard-code the QEMU binary name
@ 2021-06-07 17:42 Thomas Huth
  2021-06-07 18:54 ` Dr. David Alan Gilbert
                   ` (2 more replies)
  0 siblings, 3 replies; 4+ messages in thread
From: Thomas Huth @ 2021-06-07 17:42 UTC (permalink / raw)
  To: qemu-devel, Stefan Hajnoczi, Dr. David Alan Gilbert; +Cc: qemu-trivial

In downstream, we want to use a different name for the QEMU binary,
and some people might also use the docs for non-x86 binaries, that's
why we already created the |qemu_system| placeholder in the past.
Use it now in the virtiofsd doc, too.

Signed-off-by: Thomas Huth <thuth@redhat.com>
---
 docs/tools/virtiofsd.rst | 14 +++++++-------
 1 file changed, 7 insertions(+), 7 deletions(-)

diff --git a/docs/tools/virtiofsd.rst b/docs/tools/virtiofsd.rst
index 00554c75bd..265a39b0cf 100644
--- a/docs/tools/virtiofsd.rst
+++ b/docs/tools/virtiofsd.rst
@@ -298,13 +298,13 @@ Examples
 Export ``/var/lib/fs/vm001/`` on vhost-user UNIX domain socket
 ``/var/run/vm001-vhost-fs.sock``:
 
-::
+.. parsed-literal::
 
   host# virtiofsd --socket-path=/var/run/vm001-vhost-fs.sock -o source=/var/lib/fs/vm001
-  host# qemu-system-x86_64 \
-      -chardev socket,id=char0,path=/var/run/vm001-vhost-fs.sock \
-      -device vhost-user-fs-pci,chardev=char0,tag=myfs \
-      -object memory-backend-memfd,id=mem,size=4G,share=on \
-      -numa node,memdev=mem \
-      ...
+  host# |qemu_system| \\
+        -chardev socket,id=char0,path=/var/run/vm001-vhost-fs.sock \\
+        -device vhost-user-fs-pci,chardev=char0,tag=myfs \\
+        -object memory-backend-memfd,id=mem,size=4G,share=on \\
+        -numa node,memdev=mem \\
+        ...
   guest# mount -t virtiofs myfs /mnt
-- 
2.27.0



^ permalink raw reply related	[flat|nested] 4+ messages in thread

* Re: [PATCH] docs/tools/virtiofsd.rst: Do not hard-code the QEMU binary name
  2021-06-07 17:42 [PATCH] docs/tools/virtiofsd.rst: Do not hard-code the QEMU binary name Thomas Huth
@ 2021-06-07 18:54 ` Dr. David Alan Gilbert
  2021-06-08  6:33 ` Philippe Mathieu-Daudé
  2021-06-08  8:08 ` Stefan Hajnoczi
  2 siblings, 0 replies; 4+ messages in thread
From: Dr. David Alan Gilbert @ 2021-06-07 18:54 UTC (permalink / raw)
  To: Thomas Huth; +Cc: qemu-trivial, qemu-devel, Stefan Hajnoczi

* Thomas Huth (thuth@redhat.com) wrote:
> In downstream, we want to use a different name for the QEMU binary,
> and some people might also use the docs for non-x86 binaries, that's
> why we already created the |qemu_system| placeholder in the past.
> Use it now in the virtiofsd doc, too.
> 
> Signed-off-by: Thomas Huth <thuth@redhat.com>

Reviewed-by: Dr. David Alan Gilbert <dgilbert@redhat.com>

> ---
>  docs/tools/virtiofsd.rst | 14 +++++++-------
>  1 file changed, 7 insertions(+), 7 deletions(-)
> 
> diff --git a/docs/tools/virtiofsd.rst b/docs/tools/virtiofsd.rst
> index 00554c75bd..265a39b0cf 100644
> --- a/docs/tools/virtiofsd.rst
> +++ b/docs/tools/virtiofsd.rst
> @@ -298,13 +298,13 @@ Examples
>  Export ``/var/lib/fs/vm001/`` on vhost-user UNIX domain socket
>  ``/var/run/vm001-vhost-fs.sock``:
>  
> -::
> +.. parsed-literal::
>  
>    host# virtiofsd --socket-path=/var/run/vm001-vhost-fs.sock -o source=/var/lib/fs/vm001
> -  host# qemu-system-x86_64 \
> -      -chardev socket,id=char0,path=/var/run/vm001-vhost-fs.sock \
> -      -device vhost-user-fs-pci,chardev=char0,tag=myfs \
> -      -object memory-backend-memfd,id=mem,size=4G,share=on \
> -      -numa node,memdev=mem \
> -      ...
> +  host# |qemu_system| \\
> +        -chardev socket,id=char0,path=/var/run/vm001-vhost-fs.sock \\
> +        -device vhost-user-fs-pci,chardev=char0,tag=myfs \\
> +        -object memory-backend-memfd,id=mem,size=4G,share=on \\
> +        -numa node,memdev=mem \\
> +        ...
>    guest# mount -t virtiofs myfs /mnt
> -- 
> 2.27.0
> 
-- 
Dr. David Alan Gilbert / dgilbert@redhat.com / Manchester, UK



^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: [PATCH] docs/tools/virtiofsd.rst: Do not hard-code the QEMU binary name
  2021-06-07 17:42 [PATCH] docs/tools/virtiofsd.rst: Do not hard-code the QEMU binary name Thomas Huth
  2021-06-07 18:54 ` Dr. David Alan Gilbert
@ 2021-06-08  6:33 ` Philippe Mathieu-Daudé
  2021-06-08  8:08 ` Stefan Hajnoczi
  2 siblings, 0 replies; 4+ messages in thread
From: Philippe Mathieu-Daudé @ 2021-06-08  6:33 UTC (permalink / raw)
  To: Thomas Huth, qemu-devel, Stefan Hajnoczi, Dr. David Alan Gilbert
  Cc: qemu-trivial

On 6/7/21 7:42 PM, Thomas Huth wrote:
> In downstream, we want to use a different name for the QEMU binary,
> and some people might also use the docs for non-x86 binaries, that's
> why we already created the |qemu_system| placeholder in the past.
> Use it now in the virtiofsd doc, too.
> 
> Signed-off-by: Thomas Huth <thuth@redhat.com>
> ---
>  docs/tools/virtiofsd.rst | 14 +++++++-------
>  1 file changed, 7 insertions(+), 7 deletions(-)

Reviewed-by: Philippe Mathieu-Daudé <philmd@redhat.com>



^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: [PATCH] docs/tools/virtiofsd.rst: Do not hard-code the QEMU binary name
  2021-06-07 17:42 [PATCH] docs/tools/virtiofsd.rst: Do not hard-code the QEMU binary name Thomas Huth
  2021-06-07 18:54 ` Dr. David Alan Gilbert
  2021-06-08  6:33 ` Philippe Mathieu-Daudé
@ 2021-06-08  8:08 ` Stefan Hajnoczi
  2 siblings, 0 replies; 4+ messages in thread
From: Stefan Hajnoczi @ 2021-06-08  8:08 UTC (permalink / raw)
  To: Thomas Huth; +Cc: qemu-trivial, qemu-devel, Dr. David Alan Gilbert

[-- Attachment #1: Type: text/plain, Size: 530 bytes --]

On Mon, Jun 07, 2021 at 07:42:50PM +0200, Thomas Huth wrote:
> In downstream, we want to use a different name for the QEMU binary,
> and some people might also use the docs for non-x86 binaries, that's
> why we already created the |qemu_system| placeholder in the past.
> Use it now in the virtiofsd doc, too.
> 
> Signed-off-by: Thomas Huth <thuth@redhat.com>
> ---
>  docs/tools/virtiofsd.rst | 14 +++++++-------
>  1 file changed, 7 insertions(+), 7 deletions(-)

Reviewed-by: Stefan Hajnoczi <stefanha@redhat.com>

[-- Attachment #2: signature.asc --]
[-- Type: application/pgp-signature, Size: 488 bytes --]

^ permalink raw reply	[flat|nested] 4+ messages in thread

end of thread, other threads:[~2021-06-08  8:09 UTC | newest]

Thread overview: 4+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-06-07 17:42 [PATCH] docs/tools/virtiofsd.rst: Do not hard-code the QEMU binary name Thomas Huth
2021-06-07 18:54 ` Dr. David Alan Gilbert
2021-06-08  6:33 ` Philippe Mathieu-Daudé
2021-06-08  8:08 ` Stefan Hajnoczi

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.