On 08.08.2016 20:07, Colin Lord wrote: > One more minor revision from v6, no big changes. > > v7: > - Add ifdef around qemu_iscsi_opts in vl.c (first patch) > > v6: > - Fix bug so that users can specify a modularized driver on the cli > without qemu exiting > - Remove extra lines from Makefile > - Add patch to modularize NFS > > v5: > - No format drivers are modularized, therefore the probe functions are > all being left completely untouched. > - Remove dmg from block-obj-m since it is not a target of the > modularization effort. > - Modify module_block.py to only include the library name and protocol > name fields in the generated struct. The other fields are no longer > necessary for the drivers that are being modularized. > > v4: > - Fix indentation of the generated header file module_block.h > - Drivers and probe functions are now all located in the block/ > directory, rather than being split between block/ and block/probe/. In > addition the header files for each probe/driver pair are in the block/ > directory, not the include/block/driver/ directory (which no longer > exists). > - Since the probe files are in block/ now, they follow the naming > pattern of format-probe.c > - Renamed crypto probe file to be crypto-probe.c, luks is no longer in > the filename > - Fixed formatting of parallels_probe() function header > - Enforced consistent naming convention for the probe functions. They > now follow the pattern bdrv_format_probe(). > > Colin Lord (2): > blockdev: prepare iSCSI block driver for dynamic loading > blockdev: Modularize nfs block driver > > Marc Mari (2): > blockdev: Add dynamic generation of module_block.h > blockdev: Add dynamic module loading for block drivers > > Makefile | 10 ++-- > block.c | 62 ++++++++++++++++++++--- > block/Makefile.objs | 4 +- > block/iscsi.c | 36 -------------- > configure | 4 +- > include/qemu/module.h | 3 ++ > scripts/modules/module_block.py | 108 ++++++++++++++++++++++++++++++++++++++++ > util/module.c | 38 ++++---------- > vl.c | 40 +++++++++++++++ > 9 files changed, 228 insertions(+), 77 deletions(-) > create mode 100644 scripts/modules/module_block.py I'd be happy to apply the series as-is, but I'll still give you some time to decide whether you want to extend patch 3's commit message by what Fam has proposed. Max