From mboxrd@z Thu Jan 1 00:00:00 1970 From: Remy Bohmer Date: Wed, 8 Jul 2009 22:19:36 +0200 Subject: [U-Boot] [PATCH-ARM] Add support for Embest SBC2440-II Board 1/7 In-Reply-To: <4A42C62B.8000004@fearnside-systems.co.uk> References: <4A42C62B.8000004@fearnside-systems.co.uk> Message-ID: <3efb10970907081319w40bccbat81b7682b98209031@mail.gmail.com> List-Id: MIME-Version: 1.0 Content-Type: text/plain; charset="us-ascii" Content-Transfer-Encoding: 7bit To: u-boot@lists.denx.de Hello Kevin, 2009/6/25 kevin.morfitt at fearnside-systems.co.uk : > > Patches 1 to 4 replace "[PATCH-ARM 1/2] Add support for > the Embest SBC2440-II Board 1/2" submitted on 19/06/2009. > > This patch re-formats the code in cpu/arm920t and cpu/arm920t/23c24x0 in > preparation for changes to add support for the Embest SBC2440-II Board. > > The changes are as follows: > > - re-indent the code using Lindent > - make sure register layouts are defined using a C struct, from a > ?comment by Wolfgang on 03/06/2009 > - replace the upper-case typedef'ed C struct names with lower case > ?non-typedef'ed ones, from a comment by Scott on 22/06/2009 > - make sure registers are accessed using the proper accessor > ?functions, from a comment by Wolfgang on 03/06/2009 > - run checkpatch.pl and fix any error reports > > Note that usb_ohci.c still has two lines that exceed 80 characters. > This is because the statements on those lines lose readability when > wrapped - the Linux coding style guidleines allows for this. > > This complete series of patches assumes the following patches have > already been applied: > > - [PATCH-ARM] Bug-fix in drivers mtd nand Makefile, sent 18/06/2009 > - [PATCH-ARM] CONFIG_SYS_HZ fix for ARM920T S3C24X0 Boards, sent > ?21/06/2009 > > Signed-off-by: Kevin Morfitt > --- > ?cpu/arm920t/s3c24x0/usb_ohci.c | 1268 +++++++++++++++++++++------------------- Why are these files put in the cpu section, and not in the drivers/usb section where it belongs. Could it be merged into the existing ohci code, especially if it contains improvements compared to the existing code? I do not think it is okay to copy similar code to different places in u-boot. Kind regards, Remy