All of lore.kernel.org
 help / color / mirror / Atom feed
From: redstrate <josh@redstrate.com>
To: "José Expósito" <jose.exposito89@gmail.com>
Cc: linux-input@vger.kernel.org, kernel test robot <lkp@intel.com>,
	Dan Carpenter <error27@gmail.com>, Jiri Kosina <jikos@kernel.org>,
	Benjamin Tissoires <benjamin.tissoires@redhat.com>,
	linux-kernel@vger.kernel.org
Subject: Re: [PATCH v2] HID: uclogic: Add support for XP-PEN Artist 22R Pro
Date: Thu, 05 Jan 2023 17:08:29 -0500	[thread overview]
Message-ID: <4810275.31r3eYUQgx@adrastea> (raw)
In-Reply-To: <Y7cLJpgnP50JzHps@fedora>

> I see this event codes in a test device mock in libinput, but I wonder
> if we could/should use BTN_9 instead of skiping a few IDs here.
> 
> Honestly, I don't now what should be the right approach in this case,
> let's see if someone else comments on this topic.

I forgot about BTN_9, that should be an easy change. I already merged changes 
upstream in systemd/udev to mark devices with these buttons correctly - so, 
sunken cost and all that :-)

> I think that you could use uclogic_params_parse_ugee_v2_desc() and
> change the number of buttons in the template afterwards. It'd avoid
> some code duplication.

Yeah I think that's what I'll do, I was thinking of reusing it and just 
overriding parameters if needed.

> There are some XP-Pen PRO devices handled by the other init function.
> Maybe we could rename this function to something more specific to your
> device.

Ah okay, it's pretty specific to this device anyway - so I'll rename the 
function so it's clear what it's purpose is. I wasn't sure if future XP-PEN 
Pro work was going to reuse this function, but I guess we'll rename it if that 
happens!

> You can use "uclogic_ugee_v2_probe_endpoint" here.

Good catch! Will change.

> User-space lacks support for dials, but, with this descriptor, would it
> be possible to differenciate between the 2 dials to, for example,
> assign them different actions? Or would them be exposed as the same
> dial?
> 
> I have no idea how would user-space see this, but it'd interesting to
> see how libinput handles it.

Currently userspace sees this as REL_WHEEL and REL_HWHEEL, but like
mentioned libinput currently rejects mouse wheel events from tablet pads.
The fact that they previously worked before these patches is because udev
misclassified the pad device as a mouse. I'm working upstream to expose dials 
on tablet pads in libinput (I just got the green light so I'll be working on 
that shortly!)

> You can cherry-pick my patch refactoring this variables and send it as
> part of your series. I think that it might help maintainers with the
> merge and it'd also fix the problem reported by the test robot.

Ooh good point, I didn't even consider doing that. Next version will have it 
split up into two then.





  reply	other threads:[~2023-01-05 22:10 UTC|newest]

Thread overview: 16+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2022-12-26  3:11 [PATCH] HID: uclogic: Add support for XP-PEN Artist 22R Pro Joshua Goins
2022-12-26  8:29 ` kernel test robot
2022-12-26 10:31 ` kernel test robot
2022-12-26 11:22 ` kernel test robot
2022-12-29 19:06 ` José Expósito
2022-12-30 20:02   ` redstrate
2023-01-01 15:33     ` José Expósito
2023-01-01 15:40       ` redstrate
2023-01-02 19:49 ` [PATCH v2] " Joshua Goins
2023-01-02 22:46   ` kernel test robot
2023-01-03  1:58   ` kernel test robot
2023-01-03  8:27   ` Dan Carpenter
2023-01-05 17:38   ` José Expósito
2023-01-05 22:08     ` redstrate [this message]
2022-12-26 10:11 [PATCH] " kernel test robot
2022-12-29  9:29 ` Dan Carpenter

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=4810275.31r3eYUQgx@adrastea \
    --to=josh@redstrate.com \
    --cc=benjamin.tissoires@redhat.com \
    --cc=error27@gmail.com \
    --cc=jikos@kernel.org \
    --cc=jose.exposito89@gmail.com \
    --cc=linux-input@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=lkp@intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.