All of lore.kernel.org
 help / color / mirror / Atom feed
From: Sergei Shtylyov <sshtylyov@mvista.com>
To: Jeff Garzik <jeff@garzik.org>
Cc: Sergei Shtylyov <sshtylyov@mvista.com>,
	Anton Vorontsov <avorontsov@ru.mvista.com>,
	linux-ide@vger.kernel.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH 09/12] ahci: Introduce ahci_set_em_messages()
Date: Wed, 03 Mar 2010 13:40:49 +0300	[thread overview]
Message-ID: <4B8E3CB1.10902@ru.mvista.com> (raw)
In-Reply-To: <4B8D9CED.7040603@garzik.org>

Hello.

Jeff Garzik wrote:

>>> Factor out some ahci_em_messages handling code from ahci_init_one().
>>> We would like to reuse it for non-PCI devices.
>>>
>>> Signed-off-by: Anton Vorontsov <avorontsov@ru.mvista.com>
>>> ---
>>> drivers/ata/ahci.c | 41 ++++++++++++++++++++++++-----------------
>>> 1 files changed, 24 insertions(+), 17 deletions(-)
>>>
>>> diff --git a/drivers/ata/ahci.c b/drivers/ata/ahci.c
>>> index 18443e9..6694b17 100644
>>> --- a/drivers/ata/ahci.c
>>> +++ b/drivers/ata/ahci.c
>>> @@ -3040,6 +3040,29 @@ static inline void
>>> ahci_gtf_filter_workaround(struct ata_host *host)
>>> {}
>>> #endif
>>>
>>> +static void ahci_set_em_messages(struct ahci_host_priv *hpriv,
>>> + struct ata_port_info *pi)
>>> +{
>>> + u8 messages;
>>> + void __iomem *mmio = hpriv->mmio;
>>> + u32 em_loc = readl(mmio + HOST_EM_LOC);
>>> + u32 em_ctl = readl(mmio + HOST_EM_CTL);
>>> +
>>> + if (!ahci_em_messages || !(hpriv->cap & HOST_CAP_EMS))
>>> + return;
>>> +
>>> + messages = (em_ctl & EM_CTRL_MSG_TYPE) >> 16;
>>> +
>>> + /* we only support LED message type right now */
>>> + if ((messages & 0x01) && (ahci_em_messages == 1)) {
>>> + /* store em_loc */
>>> + hpriv->em_loc = ((em_loc >> 16) * 4);
>>
>> Could drop unneeded parens, while at it...
>
> While not strictly necessary, parens often help with readability.  I 
> think the above code looks fine as-is.  If the reader has to waste a 
> few seconds recalling C's operator precedence, that detracts from the 
> easy reading of the code.  Not everyone is like me and has worked on a 
> C compiler, you know ;-)

   Come on, parens around the right arg of = are pretty 
counter-intuitive and so don't add to the readability. :-)

>     Jeff

MBR, Sergei


  reply	other threads:[~2010-03-03 10:41 UTC|newest]

Thread overview: 23+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2010-03-02 18:28 [PATCH RFC 0/12] ahci: Add support for non-PCI devices Anton Vorontsov
2010-03-02 18:29 ` [PATCH 01/12] ahci: Fix some sparse warnings Anton Vorontsov
2010-03-02 18:29 ` [PATCH 02/12] ahci: Get rid of host->iomap usage Anton Vorontsov
2010-03-02 18:29 ` [PATCH 03/12] ahci: Factor out PCI specifics from ahci_save_initial_config() Anton Vorontsov
2010-03-02 18:29 ` [PATCH 04/12] ahci: Get rid of pci_dev argument in ahci_save_initial_config() Anton Vorontsov
2010-03-02 18:29 ` [PATCH 05/12] ahci: Factor out PCI specifics from ahci_reset_controller() Anton Vorontsov
2010-03-02 18:29 ` [PATCH 06/12] ahci: Get rid of pci_dev argument in ahci_port_init() Anton Vorontsov
2010-03-02 18:29 ` [PATCH 07/12] ahci: Factor out PCI specifics from ahci_init_controller() Anton Vorontsov
2010-03-02 18:29 ` [PATCH 08/12] ahci: Factor out PCI specifics from ahci_print_info() Anton Vorontsov
2010-03-02 18:29 ` [PATCH 09/12] ahci: Introduce ahci_set_em_messages() Anton Vorontsov
2010-03-02 21:18   ` Sergei Shtylyov
2010-03-02 23:19     ` Jeff Garzik
2010-03-03 10:40       ` Sergei Shtylyov [this message]
2010-03-03 11:41         ` Jeff Garzik
2010-03-03 14:38           ` Greg Freemyer
2010-03-02 18:29 ` [PATCH 10/12] ahci: Move PCI code into ahci_pci.c Anton Vorontsov
2010-03-02 18:29 ` [PATCH 11/12] ahci: Export generic AHCI symbols Anton Vorontsov
2010-03-02 18:29 ` [PATCH 12/12] ahci: Add platform driver Anton Vorontsov
2010-03-02 19:41   ` Sergei Shtylyov
2010-03-03 13:14     ` Anton Vorontsov
2010-03-02 21:34 ` [PATCH RFC 0/12] ahci: Add support for non-PCI devices Jeff Garzik
2010-03-03 13:15   ` Anton Vorontsov
2010-03-03 13:40     ` Jeff Garzik

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=4B8E3CB1.10902@ru.mvista.com \
    --to=sshtylyov@mvista.com \
    --cc=avorontsov@ru.mvista.com \
    --cc=jeff@garzik.org \
    --cc=linux-ide@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.