From mboxrd@z Thu Jan 1 00:00:00 1970 From: Daniel Gorsulowski Date: Fri, 21 Jan 2011 15:00:23 +0100 Subject: [U-Boot] [PATCH 2/2] at91: fixed 'esd gmbh' meesc and otc570 boards In-Reply-To: <4D396F28.7030108@emk-elektronik.de> References: <1295601136-31768-2-git-send-email-Daniel.Gorsulowski@esd.eu> <4D396F28.7030108@emk-elektronik.de> Message-ID: <4D399177.4040903@esd.eu> List-Id: MIME-Version: 1.0 Content-Type: text/plain; charset="us-ascii" Content-Transfer-Encoding: 7bit To: u-boot@lists.denx.de Reinhard Meyer wrote: > Dear Daniel Gorsulowski, >> Signed-off-by: Daniel Gorsulowski >> ... >> - gd->bd->bi_dram[0].start = PHYS_SDRAM; >> - gd->bd->bi_dram[0].size = get_ram_size((long *) PHYS_SDRAM, (1<< 27)); >> + gd->bd->bi_dram[0].start = CONFIG_SYS_SDRAM_BASE; >> + gd->bd->bi_dram[0].size = get_ram_size((long *) CONFIG_SYS_SDRAM_BASE, >> + (1<< 27)); > Maybe there is a suitable SIZE_128MIB (didn't check) - would look more readable ;) AFAIK, Wolfgang wants to get rid of the sizes.h file. So I'll replace that with something like (128*1024*1024) >> diff --git a/board/esd/otc570/otc570.c b/board/esd/otc570/otc570.c >> index 410d8b4..c66f99e 100644 >> --- a/board/esd/otc570/otc570.c >> +++ b/board/esd/otc570/otc570.c >> @@ -1,5 +1,5 @@ >> /* >> - * (C) Copyright 2010 >> + * (C) Copyright 2010-2011 >> * Daniel Gorsulowski >> * esd electronic system design gmbh >> * >> @@ -27,6 +27,7 @@ >> */ >> >> #include >> +#include >> #include > including hardware.h does include above, don't include it directly. Ok, I'll remove this include ... >> diff --git a/boards.cfg b/boards.cfg >> index 9b15026..77f3fc4 100644 >> --- a/boards.cfg >> +++ b/boards.cfg >> @@ -83,8 +83,10 @@ at91sam9xeek_dataflash_cs0 arm arm926ejs at91sam9260ek atmel >> at91sam9xeek_dataflash_cs1 arm arm926ejs at91sam9260ek atmel at91 at91sam9260ek:AT91SAM9XE,SYS_USE_DATAFLASH_CS1 >> top9000eval_xe arm arm926ejs top9000 emk at91 top9000:EVAL9000 >> top9000su_xe arm arm926ejs top9000 emk at91 top9000:SU9000 >> -meesc arm arm926ejs - esd at91 >> -otc570 arm arm926ejs - esd at91 >> +meesc arm arm926ejs meesc esd at91 meesc:AT91SAM9263,SYS_USE_NANDFLASH >> +meesc_dataflash arm arm926ejs meesc esd at91 meesc:AT91SAM9263,SYS_USE_DATAFLASH >> +otc570 arm arm926ejs otc570 esd at91 otc570:AT91SAM9263,SYS_USE_NANDFLASH >> +otc570_dataflash arm arm926ejs otc570 esd at91 otc570:AT91SAM9263,SYS_USE_DATAFLASH > Apparently its always a sam9263, so please don't define it here. The defines in boards.cfg should only be used > for differences between variants. I'll move that to board config files >> diff --git a/include/configs/meesc.h b/include/configs/meesc.h >> index a27b36b..dbb97ed 100644 >> --- a/include/configs/meesc.h >> +++ b/include/configs/meesc.h >> @@ -3,7 +3,7 @@ >> * Stelian Pop >> * Lead Tech Design >> * >> - * (C) Copyright 2009-2010 >> + * (C) Copyright 2009-2011 >> * Daniel Gorsulowski >> * esd electronic system design gmbh >> * >> @@ -31,49 +31,67 @@ >> #ifndef __CONFIG_H >> #define __CONFIG_H >> >> -/* Common stuff */ >> -#define CONFIG_MEESC 1 /* Board is esd MEESC */ >> -#define CONFIG_ARM926EJS 1 /* This is an ARM926EJS Core */ >> -#define CONFIG_AT91SAM9263 1 /* It's an AT91SAM9263 SoC */ >> -#define CONFIG_SYS_AT91_MAIN_CLOCK 16000000/* 16.0 MHz crystal */ >> +/* >> + * SoC must be defined first, before hardware.h is included. >> + * In this case SoC is defined in boards.cfg. > Please define SoC here. See beyond... ... > > I'll run it through checkpatch.pl later. > > Best Regards, > Reinhard Best regards, Daniel