Hi Jukka, > +/* For gprs */ > +void __ofono_gprs_provision_get_settings(const char *mcc, const char *mnc, > + const char *spn, > + struct ofono_gprs_provision_data **settings, > + int *count); The __ofono prefix implies that this is private ofono API. Things declared in include/foo.h are public oFono API. Since this does not seem to be a good candidate for public consumption, can you move this down to src/ofono.h? > +void provision_settings_free(struct ofono_gprs_provision_data *settings, > + int count); I suggest renaming this to __ofono_gprs_provision_free_settings() and moving this to src/ofono.h. Regards, -Denis