All of lore.kernel.org
 help / color / mirror / Atom feed
From: Asias He <asias.hejun@gmail.com>
To: Sasha Levin <levinsasha928@gmail.com>
Cc: Pekka Enberg <penberg@kernel.org>,
	mingo@elte.hu, gorcunov@gmail.com, kvm@vger.kernel.org
Subject: Re: [RFC 01/12] kvm tools: Split kvm_cmd_run into init, work and uninit
Date: Tue, 20 Dec 2011 16:55:31 +0800	[thread overview]
Message-ID: <4EF04D83.3020008@gmail.com> (raw)
In-Reply-To: <1324375766.22797.0.camel@lappy>

On 12/20/2011 06:09 PM, Sasha Levin wrote:
> On Mon, 2011-12-19 at 23:26 +0200, Pekka Enberg wrote:
>> On Mon, 2011-12-19 at 15:58 +0200, Sasha Levin wrote:
>>> +int kvm_cmd_run(int argc, const char **argv, const char *prefix)
>>> +{
>>> +	int r, ret;
>>> +
>>> +	r = kvm_cmd_run_init(argc, argv);
>>> +	ret = kvm_cmd_run_work();
>>> +	r = kvm_cmd_run_uninit(ret);
>>> +
>>> +	return ret;
>>>  }
>>
>> What's going on here? Why do you bother saving 'r' if you don't use it
>> for anything?
> 
> It was part of my plans to get kvm_cmd_run_{init, uninit} as a simple

Can we have a shorter name for 'uninit', e.g. 'fini', thus we will have
{init, fini}.

> for(;;) through a init/uninit function pointer array, right now it's
> simply meaningless there.
> 


-- 
Asias He

  reply	other threads:[~2011-12-20  8:57 UTC|newest]

Thread overview: 17+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2011-12-19 13:58 [RFC 00/12] Overhaul of error handling and module init/uninit Sasha Levin
2011-12-19 13:58 ` [RFC 01/12] kvm tools: Split kvm_cmd_run into init, work and uninit Sasha Levin
2011-12-19 21:26   ` Pekka Enberg
2011-12-20 10:09     ` Sasha Levin
2011-12-20  8:55       ` Asias He [this message]
2011-12-19 13:58 ` [RFC 02/12] kvm tools: Fixes for symbol resolving module Sasha Levin
2011-12-19 13:58 ` [RFC 03/12] kvm tools: Fixes for IRQ module Sasha Levin
2011-12-19 13:58 ` [RFC 04/12] kvm tools: Fixes for UI modules Sasha Levin
2011-12-19 13:58 ` [RFC 05/12] kvm tools: Fixes for ioport module Sasha Levin
2011-12-19 13:58 ` [RFC 06/12] kvm tools: Fixes for ioeventfd module Sasha Levin
2011-12-19 13:58 ` [RFC 07/12] kvm tools: Fixes for serial module Sasha Levin
2011-12-19 13:58 ` [RFC 08/12] kvm tools: Fixes for mptable module Sasha Levin
2011-12-19 13:58 ` [RFC 09/12] kvm tools: Fixes for ioeventfd module Sasha Levin
2011-12-19 13:58 ` [RFC 10/12] kvm tools: Fixes for disk image module Sasha Levin
2011-12-19 13:58 ` [RFC 11/12] kvm tools: Fixes for rtc module Sasha Levin
2011-12-19 13:58 ` [RFC 12/12] kvm tools: Fixes for ioeventfd module Sasha Levin
2011-12-19 21:29 ` [RFC 00/12] Overhaul of error handling and module init/uninit Pekka Enberg

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=4EF04D83.3020008@gmail.com \
    --to=asias.hejun@gmail.com \
    --cc=gorcunov@gmail.com \
    --cc=kvm@vger.kernel.org \
    --cc=levinsasha928@gmail.com \
    --cc=mingo@elte.hu \
    --cc=penberg@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.