All of lore.kernel.org
 help / color / mirror / Atom feed
From: walter harms <wharms@bfs.de>
To: kernel-janitors@vger.kernel.org
Subject: Re: [patch] [media] ngene: remove an unneeded condition
Date: Sat, 28 Apr 2012 16:23:58 +0000	[thread overview]
Message-ID: <4F9C199E.4070901@bfs.de> (raw)
In-Reply-To: <20120420131502.GB26339@elgon.mountain>



Am 28.04.2012 17:16, schrieb Dan Carpenter:
> On Sat, Apr 28, 2012 at 04:57:35PM +0200, walter harms wrote:
>>
>>
>> Am 20.04.2012 15:15, schrieb Dan Carpenter:
>>> "stat" is always zero here.  The condition used to be needed, but we
>>> shifted stuff around in 0f0b270f90 "[media] ngene: CXD2099AR Common
>>> Interface driver".
>>>
>>> This doesn't change how the code works, it's just a bit tidier.
>>>
>>> Signed-off-by: Dan Carpenter <dan.carpenter@oracle.com>
>>>
>>> diff --git a/drivers/media/dvb/ngene/ngene-core.c b/drivers/media/dvb/ngene/ngene-core.c
>>> index f129a93..3985738 100644
>>> --- a/drivers/media/dvb/ngene/ngene-core.c
>>> +++ b/drivers/media/dvb/ngene/ngene-core.c
>>> @@ -1409,10 +1409,8 @@ static int ngene_start(struct ngene *dev)
>>>  	if (stat < 0)
>>>  		goto fail;
>>>  
>>> -	if (!stat)
>>> -		return stat;
>>> +	return 0;
>>>  
>>> -	/* otherwise error: fall through */
>>>  fail:
>>>  	ngwritel(0, NGENE_INT_ENABLE);
>>>  	free_irq(dev->pci_dev->irq, dev);
>>
>> it seems more logical to use the positive exit in this case like:
>>
>>   if (stat >=0)
>> 	return 0;
>>
>> instead of jumping over return 0:
>>
> 
> I would say it's more readable to handle the error condition as
> a special case instead of handling the normal success case as
> special.  It's better to be consistent instead of changing back and
> forth:
> 
> 	if (error condition)
> 		return ret;
> 	if (error condition)
> 		return ret;
> 	if (success conditi)
> 		return ret;
> 	if (error condition)
> 		return ret;
> 
> 

i agree but in this special case it looks strange. Would that more
readable ?

if (stat < 0)
{
<errorhandling here>	
 return stat;	
}
	
return 0:

re,
 wh

  parent reply	other threads:[~2012-04-28 16:23 UTC|newest]

Thread overview: 8+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2012-04-20 13:15 [patch] [media] ngene: remove an unneeded condition Dan Carpenter
2012-04-20 13:15 ` Dan Carpenter
2012-04-28 14:57 ` walter harms
2012-04-28 14:57   ` walter harms
2012-04-28 15:16   ` Dan Carpenter
2012-04-28 15:16     ` Dan Carpenter
2012-04-28 16:23 ` walter harms [this message]
2012-04-29 13:46 ` Dan Carpenter

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=4F9C199E.4070901@bfs.de \
    --to=wharms@bfs.de \
    --cc=kernel-janitors@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.