All of lore.kernel.org
 help / color / mirror / Atom feed
From: Jan Kiszka <jan.kiszka@web.de>
To: Peter Maydell <peter.maydell@linaro.org>
Cc: Avi Kivity <avi@redhat.com>,
	Marcelo Tosatti <mtosatti@redhat.com>,
	qemu-devel@nongnu.org, patches@linaro.org,
	Alexander Graf <agraf@suse.de>
Subject: Re: [Qemu-devel] [PATCH v2 0/7] split out uses of kvm_irqchip_in_kernel()
Date: Thu, 02 Aug 2012 11:00:08 +0200	[thread overview]
Message-ID: <501A4198.7020506@web.de> (raw)
In-Reply-To: <CAFEAcA9JZTqe6CN2nCUQRwvPcHR7266-GDBQTwCKRWEmd8BKPQ@mail.gmail.com>

[-- Attachment #1: Type: text/plain, Size: 2470 bytes --]

On 2012-08-01 16:39, Peter Maydell wrote:
> ping?

Sorry, head is full with other stuff. Will try to have a final look today.

Jan

> 
> thanks
> -- PMM
> 
> On 26 July 2012 15:35, Peter Maydell <peter.maydell@linaro.org> wrote:
>> This patch series removes all uses of kvm_irqchip_in_kernel()
>> from architecture-independent code, by creating a set of more
>> specific functions instead to test for the particular aspects
>> of behaviour that the calling code is actually interested in.
>>
>> The uses in x86-specific code could in theory be further broken
>> down into kvm_ioapic(), kvm_pit(), etc, but I leave that for
>> one of the x86 maintainers if they think it's worthwhile.
>>
>> Changes v1->v2:
>>  * more blank lines round kvm.h doc comments / macros
>>  * 1: fn name changed to: kvm_async_interrupts_enabled()
>>       (and corresponding bool is now kvm_async_interrupts_allowed,
>>       so we are consistent about the enabled/allowed convention)
>>  * 2: fn name changed to: kvm_set_irq()
>>  * 3: fix return type of kvm_allows_irq0_override() to bool
>>  * 5 (and new patch 6): split out separate kvm_gsi_routing_enabled()
>>       check for use in kvm_irqchip_add_msi_route()
>>
>> Peter Maydell (7):
>>   kvm: Decouple 'async interrupt delivery' from 'kernel irqchip'
>>   kvm: Rename kvm_irqchip_set_irq() to kvm_set_irq()
>>   kvm: Move kvm_allows_irq0_override() to target-i386, fix return type
>>   kvm: Decouple 'irqfds usable' from 'kernel irqchip'
>>   kvm: Decouple 'MSI routing via irqfds' from 'kernel irqchip'
>>   kvm: Decouple 'GSI routing' from 'kernel irqchip'
>>   kvm: Add documentation comment for kvm_irqchip_in_kernel()
>>
>>  cpus.c                    |    3 +-
>>  hw/kvm/i8259.c            |    2 +-
>>  hw/kvm/ioapic.c           |    2 +-
>>  hw/pc.c                   |    1 +
>>  hw/virtio-pci.c           |    4 +-
>>  kvm-all.c                 |   25 ++++++++++--------
>>  kvm-stub.c                |    9 +++---
>>  kvm.h                     |   60 ++++++++++++++++++++++++++++++++++++++++++--
>>  target-i386/Makefile.objs |    1 +
>>  target-i386/kvm-stub.c    |   18 +++++++++++++
>>  target-i386/kvm.c         |   13 +++++++++
>>  target-i386/kvm_i386.h    |   16 ++++++++++++
>>  12 files changed, 130 insertions(+), 24 deletions(-)
>>  create mode 100644 target-i386/kvm-stub.c
>>  create mode 100644 target-i386/kvm_i386.h
>>
>> --
>> 1.7.5.4
>>
>>




[-- Attachment #2: OpenPGP digital signature --]
[-- Type: application/pgp-signature, Size: 262 bytes --]

  reply	other threads:[~2012-08-02  9:00 UTC|newest]

Thread overview: 15+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2012-07-26 14:35 [Qemu-devel] [PATCH v2 0/7] split out uses of kvm_irqchip_in_kernel() Peter Maydell
2012-07-26 14:35 ` [Qemu-devel] [PATCH v2 1/7] kvm: Decouple 'async interrupt delivery' from 'kernel irqchip' Peter Maydell
2012-07-26 14:35 ` [Qemu-devel] [PATCH v2 2/7] kvm: Rename kvm_irqchip_set_irq() to kvm_set_irq() Peter Maydell
2012-07-26 14:35 ` [Qemu-devel] [PATCH v2 3/7] kvm: Move kvm_allows_irq0_override() to target-i386, fix return type Peter Maydell
2012-07-26 14:35 ` [Qemu-devel] [PATCH v2 4/7] kvm: Decouple 'irqfds usable' from 'kernel irqchip' Peter Maydell
2012-07-26 14:35 ` [Qemu-devel] [PATCH v2 5/7] kvm: Decouple 'MSI routing via irqfds' " Peter Maydell
2012-07-26 14:35 ` [Qemu-devel] [PATCH v2 6/7] kvm: Decouple 'GSI routing' " Peter Maydell
2012-07-26 14:35 ` [Qemu-devel] [PATCH v2 7/7] kvm: Add documentation comment for kvm_irqchip_in_kernel() Peter Maydell
2012-08-01 14:39 ` [Qemu-devel] [PATCH v2 0/7] split out uses of kvm_irqchip_in_kernel() Peter Maydell
2012-08-02  9:00   ` Jan Kiszka [this message]
2012-08-02  9:14 ` Jan Kiszka
2012-08-07 15:11   ` Peter Maydell
2012-08-07 15:11     ` [Qemu-devel] " Peter Maydell
2012-08-09 13:17     ` Avi Kivity
2012-08-09 13:17       ` [Qemu-devel] " Avi Kivity

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=501A4198.7020506@web.de \
    --to=jan.kiszka@web.de \
    --cc=agraf@suse.de \
    --cc=avi@redhat.com \
    --cc=mtosatti@redhat.com \
    --cc=patches@linaro.org \
    --cc=peter.maydell@linaro.org \
    --cc=qemu-devel@nongnu.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.