All of lore.kernel.org
 help / color / mirror / Atom feed
From: Wenchao Xia <xiawenc@linux.vnet.ibm.com>
To: Eric Blake <eblake@redhat.com>
Cc: kwolf@redhat.com, phrdina@redhat.com, famz@redhat.com,
	armbru@redhat.com, qemu-devel@nongnu.org, lcapitulino@redhat.com,
	stefanha@redhat.com, pbonzini@redhat.com, dietmar@proxmox.com
Subject: Re: [Qemu-devel] [PATCH V2 08/12] qmp: add interface blockdev-snapshot-internal-sync
Date: Mon, 17 Jun 2013 11:09:06 +0800	[thread overview]
Message-ID: <51BE7DD2.5020800@linux.vnet.ibm.com> (raw)
In-Reply-To: <51BC393A.8030106@redhat.com>

于 2013-6-15 17:51, Eric Blake 写道:
> On 06/14/2013 12:39 PM, Wenchao Xia wrote:
>> This interface can generate snapshot name automatically if it is not
>> specified, since it is a single opertion.
>
> s/opertion/operation/
>
>>
>> Snapshot ID can't be specified in this interface.
>>
>> Signed-off-by: Wenchao Xia <xiawenc@linux.vnet.ibm.com>
>> ---
>>   blockdev.c       |   25 +++++++++++++++++++++++++
>>   qapi-schema.json |   23 +++++++++++++++++++++++
>>   qmp-commands.hx  |   31 +++++++++++++++++++++++++++++++
>>   3 files changed, 79 insertions(+), 0 deletions(-)
>>
>
>> +++ b/qapi-schema.json
>> @@ -1689,6 +1689,29 @@
>>               '*mode': 'NewImageMode'} }
>>
>>   ##
>> +# @blockdev-snapshot-internal-sync
>> +#
>> +# Synchronously take an internal snapshot of a block device, when the format
>> +# of the image used supports it.
>> +#
>> +# @device: the name of the device to generate the snapshot from
>> +#
>> +# @name: #optional the new snapshot name. If not specified, a name will be
>> +# generated according to time by qemu
>
> So why is name optional here but mandatory within a transaction?  If
> qemu is able to generate names, then it should be able to generate names
> in both cases.  Otherwise, make the name mandatory in both places.
   A bit different: transaction take multiple requests, if some thing
is generated it should return the info, but it didn't, so forbid it.
But for this action, it is single, make caller possible to get accurate
info by a info query. I'll make name mandatory in both case, it seems
better.


>
> Should this patch be folded in to 7/12?  Compare with Stefan's series on
   I think the two patch can distinguish each other: one is doing the job
in "batch" mode, one is doing in "single" mode, and make each patch
smaller. After review, I am OK to squash them.

> adding block-snapshot as a transaction (for that matter, the two series
> have a [trivial] merge conflict since both add a transaction), and make
> sure you are using the same approach between the two series at
> introducing things.
   I am OK to rebase if Stefan's patch upstream first.

>
>> +#
>> +# Returns: nothing on success
>> +#          If @device is not a valid block device, DeviceNotFound
>> +#          If any snapshot matching @name exists, or the name is a numeric
>> +#          which may mess up with snapshot ID, generic error will be returned
>> +#          If the format of the image used does not support it,
>> +#          BlockFormatFeatureNotSupported
>> +#
>> +# Since 1.6
>> +##
>> +{ 'command': 'blockdev-snapshot-internal-sync',
>> +  'data': { 'device': 'str', '*name': 'str'} }
>
> Ah, so this answers my question in 7/12 about a witness that libvirt can
> use for knowing when transaction supports the new action, without
> needing introspection.
>
>
>> +
>> +SQMP
>> +blockdev-snapshot-internal-sync
>> +-------------------------------
>> +
>> +Synchronously take an internal snapshot of a block device when the format of
>> +image used supports it.  If name is not specified, it will be automatically
>> +generated by qemu according to host time.  If the name is a numeric string
>> +which may mess up with ID, such as "19", the operation will fail.
>
> Wait a second.  If we DON'T pass a name, then the generated name is all
   Nop, it starts with "vm", like "vm-20130608141726". But I'll make
parameter name mandatory in next version.

> numeric.  But if we DO pass an all-numeric name, it gets rejected.
> That's awkward to explain.  Maybe you want to instead have a cutoff,
> where a number < 64k (is that the right threshold? I just picked a
> number out of the air) is rejected, but a number >= 64k is treated as
> valid because it might represent a timestamp.  Or allow all possible
> numbers, and only reject the creation of a name that collides with an
> existing id.  It may be too hard to predict if a name will collide with
> a future id of a later snapshot operation.
>
>
>> +Example:
>> +
>> +-> { "execute": "blockdev-snapshot-internal-sync",
>> +                "arguments": { "device": "ide-hd0",
>> +                               "name": "snapshot0" }
>> +   }
>> +<- { "return": {} }
>
> Evil.  If I don't pass a name, then I NEED to know what name got
> generated on my behalf.  So that argues you need to return something,
> rather than nothing.  I can see why you can't return a string via
> 'transaction', but maybe this is an argument that 'name' should be
> mandatory in this QMP command (and any generation of a timestamp id must
> be higher up in the stack, at the HMP level, so that HMP can still treat
> name as optional).  But then you are back to solving the problem of
> allowing an all-numeric generated timestamp as a valid name.
>


-- 
Best Regards

Wenchao Xia

  reply	other threads:[~2013-06-17  3:09 UTC|newest]

Thread overview: 31+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2013-06-14 11:39 [Qemu-devel] [PATCH V2 00/12] add internal snapshot support at block device level Wenchao Xia
2013-06-14 11:39 ` [Qemu-devel] [PATCH V2 01/12] blockdev: drop redundant proto_drv check Wenchao Xia
2013-06-14 11:39 ` [Qemu-devel] [PATCH V2 02/12] blockdev: rename BlkTransactionStates to singular Wenchao Xia
2013-06-14 11:39 ` [Qemu-devel] [PATCH V2 03/12] blockdev: allow BdrvActionOps->commit() to be NULL Wenchao Xia
2013-06-14 11:39 ` [Qemu-devel] [PATCH V2 04/12] snapshot: new function bdrv_snapshot_find_by_id_and_name() Wenchao Xia
2013-06-14 11:39 ` [Qemu-devel] [PATCH V2 05/12] snapshot: add paired functions for internal snapshot id and name Wenchao Xia
2013-06-14 11:39 ` [Qemu-devel] [PATCH V2 06/12] snapshot: distinguish id and name in snapshot delete Wenchao Xia
2013-06-14 11:39 ` [Qemu-devel] [PATCH V2 07/12] qmp: add internal snapshot support in qmp_transaction Wenchao Xia
2013-06-15  9:40   ` Eric Blake
2013-06-17  2:43     ` Wenchao Xia
2013-06-18 14:09   ` Stefan Hajnoczi
2013-06-14 11:39 ` [Qemu-devel] [PATCH V2 08/12] qmp: add interface blockdev-snapshot-internal-sync Wenchao Xia
2013-06-15  9:51   ` Eric Blake
2013-06-17  3:09     ` Wenchao Xia [this message]
2013-06-14 11:39 ` [Qemu-devel] [PATCH V2 09/12] qmp: add interface blockdev-snapshot-delete-internal-sync Wenchao Xia
2013-06-15  9:55   ` Eric Blake
2013-06-17  3:25     ` Wenchao Xia
2013-06-18 14:20       ` Stefan Hajnoczi
2013-06-19  6:18         ` Wenchao Xia
2013-06-19  7:46           ` Stefan Hajnoczi
2013-06-19  8:53             ` Wenchao Xia
2013-06-19 14:24               ` Stefan Hajnoczi
2013-06-20  2:37                 ` Wenchao Xia
2013-06-14 11:39 ` [Qemu-devel] [PATCH V2 10/12] hmp: add interface hmp_snapshot_blkdev_internal Wenchao Xia
2013-06-14 11:39 ` [Qemu-devel] [PATCH V2 11/12] hmp: add interface hmp_snapshot_delete_blkdev_internal Wenchao Xia
2013-06-14 11:39 ` [Qemu-devel] [PATCH V2 12/12] qemu-iotests: add 055 internal snapshot for block device test case Wenchao Xia
2013-06-18 14:32   ` Stefan Hajnoczi
2013-06-19  6:21     ` Wenchao Xia
2013-06-19  7:46       ` Stefan Hajnoczi
2013-06-19  9:01         ` Wenchao Xia
2013-06-19 14:26           ` Stefan Hajnoczi

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=51BE7DD2.5020800@linux.vnet.ibm.com \
    --to=xiawenc@linux.vnet.ibm.com \
    --cc=armbru@redhat.com \
    --cc=dietmar@proxmox.com \
    --cc=eblake@redhat.com \
    --cc=famz@redhat.com \
    --cc=kwolf@redhat.com \
    --cc=lcapitulino@redhat.com \
    --cc=pbonzini@redhat.com \
    --cc=phrdina@redhat.com \
    --cc=qemu-devel@nongnu.org \
    --cc=stefanha@redhat.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.