From mboxrd@z Thu Jan 1 00:00:00 1970 From: David Vrabel Subject: Re: [PATCH 04/10] kexec: add infrastructure for handling kexec images Date: Thu, 27 Jun 2013 18:17:12 +0100 Message-ID: <51CC7398.3040202@citrix.com> References: <1372095741-27012-1-git-send-email-david.vrabel@citrix.com> <1372095741-27012-5-git-send-email-david.vrabel@citrix.com> <51C968E002000078000E0386@nat28.tlf.novell.com> Mime-Version: 1.0 Content-Type: text/plain; charset="us-ascii" Content-Transfer-Encoding: 7bit Return-path: In-Reply-To: <51C968E002000078000E0386@nat28.tlf.novell.com> List-Unsubscribe: , List-Post: List-Help: List-Subscribe: , Sender: xen-devel-bounces@lists.xen.org Errors-To: xen-devel-bounces@lists.xen.org To: Jan Beulich Cc: Daniel Kiper , Keir Fraser , xen-devel@lists.xen.org List-Id: xen-devel@lists.xenproject.org On 25/06/13 08:54, Jan Beulich wrote: >>>> On 24.06.13 at 19:42, David Vrabel wrote: >> >> + goto out; >> + >> + image->control_page = ~0; /* By default this does not apply */ > > Use a recognizable #define instead? This assignment serves no purpose so I'll leaved it zeroed. >> + mstart = image->segments[i].dest_maddr; >> + mend = mstart + image->segments[i].dest_size; >> + if ( (mstart & ~PAGE_MASK) || (mend & ~PAGE_MASK) ) > > Expressions like this can be abbreviated to > > if ( (mstart | mend) & ~PAGE_MASK ) I think the original more clearly reflects the intent. David