From mboxrd@z Thu Jan 1 00:00:00 1970 From: John Stultz Subject: Re: [PATCH 2/5] time: pass flags instead of multiple bools to timekeeping_update() Date: Thu, 27 Jun 2013 10:39:04 -0700 Message-ID: <51CC78B8.3050709__48808.3859942437$1372354852$gmane$org@linaro.org> References: <1372329348-20841-1-git-send-email-david.vrabel@citrix.com> <1372329348-20841-3-git-send-email-david.vrabel@citrix.com> Mime-Version: 1.0 Content-Type: text/plain; charset="us-ascii"; Format="flowed" Content-Transfer-Encoding: 7bit Return-path: In-Reply-To: <1372329348-20841-3-git-send-email-david.vrabel@citrix.com> List-Unsubscribe: , List-Post: List-Help: List-Subscribe: , Sender: xen-devel-bounces@lists.xen.org Errors-To: xen-devel-bounces@lists.xen.org To: David Vrabel Cc: Thomas Gleixner , Konrad Rzeszutek Wilk , linux-kernel@vger.kernel.org, xen-devel@lists.xen.org List-Id: xen-devel@lists.xenproject.org On 06/27/2013 03:35 AM, David Vrabel wrote: > From: David Vrabel > > Instead of passing multiple bools to timekeeping_updated(), define > flags and use a single 'action' parameter. It is then more obvious > what each timekeeping_update() call does. > > Signed-off-by: David Vrabel > --- > kernel/time/timekeeping.c | 21 ++++++++++++--------- > 1 files changed, 12 insertions(+), 9 deletions(-) > > diff --git a/kernel/time/timekeeping.c b/kernel/time/timekeeping.c > index baeeb5c..7aed2b0 100644 > --- a/kernel/time/timekeeping.c > +++ b/kernel/time/timekeeping.c > @@ -26,6 +26,9 @@ > #include "tick-internal.h" > #include "ntp_internal.h" > > +#define TK_CLEAR_NTP (1 << 0) > +#define TK_MIRROR (1 << 1) > + > static struct timekeeper timekeeper; > static DEFINE_RAW_SPINLOCK(timekeeper_lock); > static seqcount_t timekeeper_seq; > @@ -241,16 +244,16 @@ int pvclock_gtod_unregister_notifier(struct notifier_block *nb) > EXPORT_SYMBOL_GPL(pvclock_gtod_unregister_notifier); > > /* must hold timekeeper_lock */ > -static void timekeeping_update(struct timekeeper *tk, bool clearntp, bool mirror) > +static void timekeeping_update(struct timekeeper *tk, unsigned action) Nit: Mind making this "unsigned int" just for consistency sake with the rest of the code? thanks -john