All of lore.kernel.org
 help / color / mirror / Atom feed
From: Jeffrey Hugo <jhugo@codeaurora.org>
To: Mark Brown <broonie@kernel.org>, Jeffrey Hugo <jeffrey.l.hugo@gmail.com>
Cc: lgirdwood@gmail.com, agross@kernel.org, david.brown@linaro.org,
	bjorn.andersson@linaro.org, jcrouse@codeaurora.org,
	robh+dt@kernel.org, mark.rutland@arm.com,
	linux-arm-msm@vger.kernel.org, linux-kernel@vger.kernel.org,
	devicetree@vger.kernel.org,
	Jorge Ramirez-Ortiz <jorge.ramirez-ortiz@linaro.org>
Subject: Re: [PATCH 2/3] regulator: qcom_spmi: Add support for PM8005
Date: Tue, 21 May 2019 17:16:06 -0600	[thread overview]
Message-ID: <51caaee4-dfc9-5b5a-07c7-b1406c178ca3@codeaurora.org> (raw)
In-Reply-To: <20190521185054.GD16633@sirena.org.uk>

On 5/21/2019 12:50 PM, Mark Brown wrote:
> On Tue, May 21, 2019 at 09:53:15AM -0700, Jeffrey Hugo wrote:
> 
>> -	spmi_vreg_read(vreg, SPMI_COMMON_REG_VOLTAGE_RANGE, &range_sel, 1);
>> +	/* second common devices don't have VOLTAGE_RANGE register */
>> +	if (vreg->logical_type == SPMI_REGULATOR_LOGICAL_TYPE_FTSMPS2) {
>> +		spmi_vreg_read(vreg, SPMI_COMMON2_REG_VOLTAGE_LSB, &lsb, 1);
>> +		spmi_vreg_read(vreg, SPMI_COMMON2_REG_VOLTAGE_MSB, &msb, 1);
>> +
>> +		uV = (((int)msb << 8) | (int)lsb) * 1000;
> 
> This overlaps with some changes that Jorge (CCed) was sending for the
> PMS405.  As I was saying to him rather than shoving special cases for
> different regulator types into the ops (especially ones that don't have
> any of the range stuff) it'd be better to just define separate ops for
> the regulators that look quite different to the existing ones.

Sorry, I hadn't paid attention to that discussion.  Reviewing it now.
> 
>> +static int spmi_regulator_common_list_voltage(struct regulator_dev *rdev,
>> +					      unsigned selector);
>> +
>> +static int spmi_regulator_common2_set_voltage(struct regulator_dev *rdev,
>> +					      unsigned selector)
> 
> Eeew, can we not have better names?

I'm open to suggestions.  Apparently there are two register common 
register schemes - the old one and the new one.  PMIC designs after some 
random point in time are all the new register scheme per the 
documentation I see.

As far as I an aware, the FT426 design is the first design to be added 
to this driver to make use of the new scheme, but I expect more to be 
supported in future, thus I'm reluctant to make these ft426 specific in 
the name.

> 
>> +static unsigned int spmi_regulator_common2_get_mode(struct regulator_dev *rdev)
>> +{
>> +	struct spmi_regulator *vreg = rdev_get_drvdata(rdev);
>> +	u8 reg;
>> +
>> +	spmi_vreg_read(vreg, SPMI_COMMON2_REG_MODE, &reg, 1);
>> +
>> +	if (reg == SPMI_COMMON2_MODE_HPM_MASK)
>> +		return REGULATOR_MODE_NORMAL;
>> +
>> +	if (reg == SPMI_COMMON2_MODE_AUTO_MASK)
>> +		return REGULATOR_MODE_FAST;
>> +
>> +	return REGULATOR_MODE_IDLE;
>> +}
> 
> This looks like you want to write a switch statement.

It follows the existing style in the driver, but sure I can make this a 
switch.

> 
>> +spmi_regulator_common2_set_mode(struct regulator_dev *rdev, unsigned int mode)
>> +{
>> +	struct spmi_regulator *vreg = rdev_get_drvdata(rdev);
>> +	u8 mask = SPMI_COMMON2_MODE_MASK;
>> +	u8 val = SPMI_COMMON2_MODE_LPM_MASK;
>> +
>> +	if (mode == REGULATOR_MODE_NORMAL)
>> +		val = SPMI_COMMON2_MODE_HPM_MASK;
>> +	else if (mode == REGULATOR_MODE_FAST)
>> +		val = SPMI_COMMON2_MODE_AUTO_MASK;
> 
> This needs to be a switch statement, then it can have a default case to
> catch errors too.
> 


-- 
Jeffrey Hugo
Qualcomm Datacenter Technologies as an affiliate of Qualcomm 
Technologies, Inc.
Qualcomm Technologies, Inc. is a member of the
Code Aurora Forum, a Linux Foundation Collaborative Project.

  reply	other threads:[~2019-05-21 23:16 UTC|newest]

Thread overview: 14+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2019-05-21 16:49 [PATCH 0/3] PM8005 regulator support for msm8998 GPU Jeffrey Hugo
2019-05-21 16:49 ` Jeffrey Hugo
2019-05-21 16:52 ` [PATCH 1/3] dt-bindings: qcom_spmi: Document PM8005 regulators Jeffrey Hugo
2019-05-21 17:26   ` Bjorn Andersson
2019-05-21 16:53 ` [PATCH 2/3] regulator: qcom_spmi: Add support for PM8005 Jeffrey Hugo
2019-05-21 18:50   ` Mark Brown
2019-05-21 23:16     ` Jeffrey Hugo [this message]
2019-05-22 11:01       ` Mark Brown
2019-05-22 14:16         ` Jeffrey Hugo
2019-05-22 14:28           ` Mark Brown
2019-05-22 14:58             ` Jeffrey Hugo
2019-05-21 19:09   ` Bjorn Andersson
2019-05-21 16:53 ` [PATCH 3/3] arm64: dts: msm8998-mtp: Add pm8005_s1 regulator Jeffrey Hugo
2019-05-21 18:16   ` Bjorn Andersson

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=51caaee4-dfc9-5b5a-07c7-b1406c178ca3@codeaurora.org \
    --to=jhugo@codeaurora.org \
    --cc=agross@kernel.org \
    --cc=bjorn.andersson@linaro.org \
    --cc=broonie@kernel.org \
    --cc=david.brown@linaro.org \
    --cc=devicetree@vger.kernel.org \
    --cc=jcrouse@codeaurora.org \
    --cc=jeffrey.l.hugo@gmail.com \
    --cc=jorge.ramirez-ortiz@linaro.org \
    --cc=lgirdwood@gmail.com \
    --cc=linux-arm-msm@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mark.rutland@arm.com \
    --cc=robh+dt@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.