All of lore.kernel.org
 help / color / mirror / Atom feed
From: Tomasz Figa <t.figa@samsung.com>
To: Inki Dae <inki.dae@samsung.com>, Tomasz Figa <tomasz.figa@gmail.com>
Cc: "Stéphane Marchesin" <marcheu@chromium.org>,
	"DRI mailing list" <dri-devel@lists.freedesktop.org>
Subject: Re: [PATCH v4 14/34] drm/exynos: hdmi: remove the i2c drivers and use devtree
Date: Tue, 11 Feb 2014 15:13:43 +0100	[thread overview]
Message-ID: <52FA3017.7060100@samsung.com> (raw)
In-Reply-To: <CAAQKjZNH8xaVWTqaZR0Rb1Qm=wonJ=C4BGAck8NVKNufo=bUsw@mail.gmail.com>



On 10.02.2014 08:30, Inki Dae wrote:
> 2014-02-08 11:52 GMT+09:00 Tomasz Figa <tomasz.figa@gmail.com>:
>> Hi,
>>
>>
>> On 30.01.2014 22:19, Sean Paul wrote:
>>>
>>> From: Daniel Kurtz <djkurtz@chromium.org>
>>>
>>> The i2c client was previously being passed into the hdmi driver via a
>>> dedicated i2c driver, and then a global variable. This patch removes all
>>> of that and just uses the device tree to get the i2c_client. This patch
>>> also properly references the client so we don't lose it before we're
>>> done with it.
>>>
>>> Signed-off-by: Daniel Kurtz <djkurtz@chromium.org>
>>> [seanpaul changed to phandle lookup instead of using of node name]
>>> Signed-off-by: Sean Paul <seanpaul@chromium.org>
>>> ---
>>>
>>> Changes in v2:
>>>    - Change include to linux/i2c.h instead of linux/of_i2c.h
>>> Changes in v3: None
>>> Changes in v4:
>>>    - Changed to find phy via phandle instead of by name
>>>
>>>    .../devicetree/bindings/video/exynos_hdmi.txt      |  5 ++
>>>    drivers/gpu/drm/exynos/Makefile                    |  1 -
>>>    drivers/gpu/drm/exynos/exynos_ddc.c                | 63
>>> ---------------------
>>>    drivers/gpu/drm/exynos/exynos_hdmi.c               | 59
>>> +++++++++-----------
>>>    drivers/gpu/drm/exynos/exynos_hdmi.h               | 23 --------
>>>    drivers/gpu/drm/exynos/exynos_hdmiphy.c            | 65
>>> ----------------------
>>>    6 files changed, 32 insertions(+), 184 deletions(-)
>>>    delete mode 100644 drivers/gpu/drm/exynos/exynos_ddc.c
>>>    delete mode 100644 drivers/gpu/drm/exynos/exynos_hdmi.h
>>>    delete mode 100644 drivers/gpu/drm/exynos/exynos_hdmiphy.c
>>>
>>> diff --git a/Documentation/devicetree/bindings/video/exynos_hdmi.txt
>>> b/Documentation/devicetree/bindings/video/exynos_hdmi.txt
>>> index 50decf8..f9187a2 100644
>>> --- a/Documentation/devicetree/bindings/video/exynos_hdmi.txt
>>> +++ b/Documentation/devicetree/bindings/video/exynos_hdmi.txt
>>> @@ -25,6 +25,9 @@ Required properties:
>>>                  sclk_pixel.
>>>    - clock-names: aliases as per driver requirements for above clock IDs:
>>>          "hdmi", "sclk_hdmi", "sclk_pixel", "sclk_hdmiphy" and "mout_hdmi".
>>> +- ddc: phandle to the hdmi ddc node
>>> +- phy: phandle to the hdmi phy node
>>> +
>>
>>
>> Adding new required properties to an already defined binding is breaking
>> backwards compatibility, which is supposed to be preserved, since DT is an
>> ABI.
>
> Right, that's a problem. If we use this patch, and  we add additional
> codes for these property to hdmi driver, then the existing dtb will be
> broken by dt binding fail. However, as long as I know, there is
> another case that phy property is used like this way; MIPI-CSI device
> node. And also it seems reasonable to add ddc property in similar
> reason if we could handle that the existing dt node is deplicated.
>
> So what we could select I think are,
> 1. to deplicate the existing dt node, and using this patch.
> 2. or, to separate phy and ddc parts as each module so that each
> module can bind device tree. However, this way would make hdmi part of
> exynos drm to be complicated because we should resolve probe ordering
> issue.
>
> It seems that we need to discuss and make a consensus about this issue.
>
> Tomasz and Sean, please, share your opinion. I tend to proper 1.

I tend to prefer option 1 too. I don't have anything against this patch 
itself.

All I'm just worried about is applying different standards to patches 
changing DT bindings depending on subsystem (and authors?).

Either we declare that we are okay with making Exynos-specific bindings 
unstable or we keep stability for all of them. I wouldn't be upset if we 
went with the former, as the whole stability making it impossible to get 
rid of some fugly broken bindings is getting more and more annoying.

Best regards,
Tomasz

  reply	other threads:[~2014-02-11 14:13 UTC|newest]

Thread overview: 62+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2014-01-30 21:18 [PATCH v4 00/34] drm/exynos: Refactor parts of the exynos driver Sean Paul
2014-01-30 21:19 ` [PATCH v4 01/34] drm/exynos: Rename hdmi_infoframe to avoid collision Sean Paul
2014-01-30 21:19 ` [PATCH v4 02/34] drm/exynos: Remove useless slab.h include Sean Paul
2014-01-30 21:19 ` [PATCH v4 03/34] drm/exynos: Merge overlay_ops into manager_ops Sean Paul
2014-01-30 21:19 ` [PATCH v4 04/34] drm/exynos: Add an initialize function to manager and display Sean Paul
2014-01-30 21:19 ` [PATCH v4 05/34] drm/exynos: Use manager_op initialize in fimd Sean Paul
2014-01-30 21:19 ` [PATCH v4 06/34] drm/exynos: hdmi: Implement initialize op for hdmi Sean Paul
2014-01-30 21:19 ` [PATCH v4 07/34] drm/exynos: Pass exynos_drm_manager in manager ops instead of dev Sean Paul
2014-01-30 21:19 ` [PATCH v4 08/34] drm/exynos: Remove apply manager callback Sean Paul
2014-01-30 21:19 ` [PATCH v4 09/34] drm/exynos: Remove dpms link between encoder/connector Sean Paul
2014-01-30 21:19 ` [PATCH v4 10/34] drm/exynos: Rename display_op power_on to dpms Sean Paul
2014-01-30 21:19 ` [PATCH v4 11/34] drm/exynos: Don't keep dpms state in encoder Sean Paul
2014-01-30 21:19 ` [PATCH v4 12/34] drm/exynos: Use unsigned long for possible_crtcs Sean Paul
2014-01-30 21:19 ` [PATCH v4 13/34] drm/exynos: Split manager/display/subdrv Sean Paul
2014-01-30 21:19 ` [PATCH v4 14/34] drm/exynos: hdmi: remove the i2c drivers and use devtree Sean Paul
2014-02-08  2:52   ` Tomasz Figa
2014-02-10  7:30     ` Inki Dae
2014-02-11 14:13       ` Tomasz Figa [this message]
2014-02-11 23:02     ` Olof Johansson
2014-02-12  0:44       ` Tomasz Figa
2014-02-14 14:13   ` Tomasz Stanislawski
2014-02-19 11:14     ` Inki Dae
2014-04-04 14:04       ` Tomasz Stanislawski
2014-02-19 11:43   ` Inki Dae
2014-01-30 21:19 ` [PATCH v4 15/34] ARM: dts: exynos: Add i2c phandles to hdmi node Sean Paul
2014-01-30 21:19 ` [PATCH v4 16/34] drm/exynos: Remove exynos_drm_hdmi shim Sean Paul
2014-01-30 21:19 ` [PATCH v4 17/34] drm/exynos: Use drm_mode_copy to copy modes Sean Paul
2014-01-30 21:19 ` [PATCH v4 18/34] drm/exynos: Disable unused crtc planes from crtc Sean Paul
2014-01-30 21:19 ` [PATCH v4 19/34] drm/exynos: Add mode_set manager operation Sean Paul
2014-01-30 21:19 ` [PATCH v4 20/34] drm/exynos: Implement mode_fixup " Sean Paul
2014-01-30 21:19 ` [PATCH v4 21/34] drm/exynos: Use mode_set to configure fimd Sean Paul
2014-02-10 10:36   ` Andrzej Hajda
2014-01-30 21:19 ` [PATCH v4 22/34] drm/exynos: Remove unused/useless fimd_context members Sean Paul
2014-01-30 21:19 ` [PATCH v4 23/34] drm/exynos: Move dp driver from video/ to drm/ Sean Paul
2014-01-30 21:19 ` [PATCH v4 24/34] drm/exynos: Move display implementation into dp Sean Paul
2014-01-30 21:19 ` [PATCH v4 25/34] ARM: dts: Move display-timings node from fimd to dp Sean Paul
2014-01-30 21:19 ` [PATCH v4 26/34] drm/exynos: Implement dpms display callback in DP Sean Paul
2014-01-30 21:19 ` [PATCH v4 27/34] drm/exynos: Clean up FIMD power on/off routines Sean Paul
2014-01-30 21:19 ` [PATCH v4 28/34] drm/exynos: Consolidate suspend/resume in drm_drv Sean Paul
2014-01-30 21:19 ` [PATCH v4 29/34] drm/exynos: Add create_connector callback Sean Paul
2014-01-30 21:19 ` [PATCH v4 30/34] drm/exynos: Implement drm_connector in hdmi directly Sean Paul
2014-01-30 21:19 ` [PATCH v4 31/34] drm/exynos: Implement drm_connector directly in dp driver Sean Paul
2014-01-30 21:19 ` [PATCH v4 32/34] drm/exynos: Implement drm_connector directly in vidi driver Sean Paul
2014-01-30 21:38   ` [PATCH v5 " Sean Paul
2014-01-30 21:19 ` [PATCH v4 33/34] drm/exynos: Move lvds bridge discovery into DP driver Sean Paul
2014-01-30 21:19 ` [PATCH v4 34/34] drm/exynos: Remove the exynos_drm_connector shim Sean Paul
2014-02-06 19:54 ` [PATCH v4 00/34] drm/exynos: Refactor parts of the exynos driver Olof Johansson
2014-02-07  4:13   ` Inki Dae
2014-02-08  2:48   ` Tomasz Figa
2014-02-27  4:43     ` Inki Dae
2014-02-27 13:49       ` Tomasz Figa
2014-02-27 17:09         ` Inki Dae
2014-02-28  2:28           ` Inki Dae
2014-03-04 11:03             ` Andrzej Hajda
2014-03-04 13:57               ` Inki Dae
2014-03-06 15:39                 ` Andrzej Hajda
2014-02-07 10:29 ` Tomasz Figa
2014-03-13  7:33 ` Inki Dae
2014-03-13 14:05   ` Tomasz Figa
2014-03-13 15:48     ` Inki Dae
2014-03-13 18:10       ` Tomasz Figa
2014-03-14 11:02         ` Inki Dae

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=52FA3017.7060100@samsung.com \
    --to=t.figa@samsung.com \
    --cc=dri-devel@lists.freedesktop.org \
    --cc=inki.dae@samsung.com \
    --cc=marcheu@chromium.org \
    --cc=tomasz.figa@gmail.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.