All of lore.kernel.org
 help / color / mirror / Atom feed
From: "Jan Beulich" <JBeulich@suse.com>
To: Mukesh Rathor <mukesh.rathor@oracle.com>
Cc: kevin.tian@intel.com, George.Dunlap@eu.citrix.com, tim@xen.org,
	eddie.dong@intel.com, keir.xen@gmail.com, jun.nakajima@intel.com,
	xen-devel@lists.xenproject.org
Subject: Re: [V2 PATCH 3/3] P2M error code propogation
Date: Thu, 10 Apr 2014 08:23:40 +0100	[thread overview]
Message-ID: <5346631C02000078000077A9@nat28.tlf.novell.com> (raw)
In-Reply-To: <1397089142-12561-4-git-send-email-mukesh.rathor@oracle.com>

>>> On 10.04.14 at 02:19, <mukesh.rathor@oracle.com> wrote:
>              ret = iomem_deny_access(d, mfn, mfn + nr_mfns - 1);
> -            if ( !ret && add )
> -                ret = -EIO;
> +            if ( !ret && tmp_rc )
> +                ret = tmp_rc;

This could be just "if ( !ret )"; no need to re-submit just because of this
though.

>  static int
>  p2m_pt_set_entry(struct p2m_domain *p2m, unsigned long gfn, mfn_t mfn,
>                   unsigned int page_order, p2m_type_t p2mt, p2m_access_t p2ma)
>  {
> -    // XXX -- this might be able to be faster iff current->domain == d
> +    /* XXX -- this might be able to be faster iff current->domain == d */
>      mfn_t table_mfn = pagetable_get_mfn(p2m_get_pagetable(p2m));
> -    void *table =map_domain_page(mfn_x(table_mfn));
> +    void *table = map_domain_page(mfn_x(table_mfn));

While I'm generally fine with you doing cleanup like this as you go, I
think this should have been done in the mechanical (renaming) patch
rather than in this one, which while not intended to change
functionality needs pretty close looking at to verify it really doesn't,
and hence would benefit from having just the changes that are
needed (that said, adjusting style when you have to touch a line
anyway is still fine).

As the comments are only of stylistic nature, nevertheless
Reviewed-by: Jan Beulich <jbeulich@suse.com>

Jan

  reply	other threads:[~2014-04-10  7:23 UTC|newest]

Thread overview: 8+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2014-04-10  0:18 [V2 PATCH 0/3]: Fixup error codes in some p2m paths Mukesh Rathor
2014-04-10  0:19 ` [V2 PATCH 1/3] Rename public functions in p2m-pt.c Mukesh Rathor
2014-04-10  0:19 ` [V2 PATCH 2/3] Rename "set_p2m_entry" to "p2m_set_entry" Mukesh Rathor
2014-04-10  0:19 ` [V2 PATCH 3/3] P2M error code propogation Mukesh Rathor
2014-04-10  7:23   ` Jan Beulich [this message]
2014-04-10  6:57 ` [V2 PATCH 0/3]: Fixup error codes in some p2m paths Jan Beulich
2014-04-10 22:04   ` Mukesh Rathor
2014-04-13 20:43 ` Tim Deegan

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=5346631C02000078000077A9@nat28.tlf.novell.com \
    --to=jbeulich@suse.com \
    --cc=George.Dunlap@eu.citrix.com \
    --cc=eddie.dong@intel.com \
    --cc=jun.nakajima@intel.com \
    --cc=keir.xen@gmail.com \
    --cc=kevin.tian@intel.com \
    --cc=mukesh.rathor@oracle.com \
    --cc=tim@xen.org \
    --cc=xen-devel@lists.xenproject.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.