From mboxrd@z Thu Jan 1 00:00:00 1970 From: Keir Fraser Subject: Re: [PATCH v3 0/7] xen: Hardware domain support Date: Thu, 10 Apr 2014 16:58:30 +0100 Message-ID: <5346BFA6.2050106@gmail.com> References: <1395921128-7086-1-git-send-email-dgdegra@tycho.nsa.gov> Mime-Version: 1.0 Content-Type: multipart/mixed; boundary="===============4870582066024896768==" Return-path: In-Reply-To: <1395921128-7086-1-git-send-email-dgdegra@tycho.nsa.gov> List-Unsubscribe: , List-Post: List-Help: List-Subscribe: , Sender: xen-devel-bounces@lists.xen.org Errors-To: xen-devel-bounces@lists.xen.org To: Daniel De Graaf Cc: xen-devel@lists.xen.org List-Id: xen-devel@lists.xenproject.org This is a multi-part message in MIME format. --===============4870582066024896768== Content-Type: multipart/alternative; boundary="------------000507030607050308020904" This is a multi-part message in MIME format. --------------000507030607050308020904 Content-Type: text/plain; charset=ISO-8859-1; format=flowed Content-Transfer-Encoding: 7bit > Daniel De Graaf > 27 March 2014 11:52 > This adds support to the hypervisor for the creation of a hardware > domain distinct from domain 0, allowing further disaggregation of the > duties of domain 0. The commit message for patch 1 contains a more > complete description of the distinction between the hardware domain and > control domain(s). Making the hardware domain distinct from domain 0 > allows it to be further de-privileged using an XSM policy: the hardware > domain does not need to be permitted access to create or modify other > domains in order to act as a device backend for them. > > Changes since v2: > - Rename and move CONFIG_LATE_HWDOM declaration to asm-x86/config.h > - Move alloc_dom0_vcpu0 prototype change from patch 5 to 4 > - Also rename nmi_{dom0 => hwdom}_report > - Add help/documentation for xl destroy -f > > Changes since v1: > - More complete conversion to is_hardware_domain (convert "== dom0") > - Rename "dom0" global variable and associated functions > - Avoid locating the hardware_domid variable in x86-only code > - Require using "xl destroy -f 0" to destroy domain 0 to retain the > existing guard against accidental attempts to destroy domain 0 that > will still cause disruption of the platform. > - Add an XSM permission check so that the security label of the > hardware domain can be limited by the policy. > - Rebase against updated xen/staging > > [PATCH 1/7] xen: use domid check in is_hardware_domain > [PATCH 2/7] xen/iommu: Move dom0 setup to __hwdom_init > [PATCH 3/7] xen: prevent 0 from being used as a dynamic domid > [PATCH 4/7] xen: rename dom0 to hardware_domain > [PATCH 5/7] xen: rename various functions referencing dom0 > [PATCH 6/7] xen: Allow hardare domain != dom0 > [PATCH 7/7] tools/libxl: Allow dom0 to be destroyed Acked-by: Keir Fraser > > _______________________________________________ > Xen-devel mailing list > Xen-devel@lists.xen.org > http://lists.xen.org/xen-devel --------------000507030607050308020904 Content-Type: multipart/related; boundary="------------090602010500050105070104" --------------090602010500050105070104 Content-Type: text/html; charset=ISO-8859-1 Content-Transfer-Encoding: 7bit

27 March 2014 11:52
This adds support to the hypervisor for the creation of a hardware
domain distinct from domain 0, allowing further disaggregation of the
duties of domain 0. The commit message for patch 1 contains a more
complete description of the distinction between the hardware domain and
control domain(s). Making the hardware domain distinct from domain 0
allows it to be further de-privileged using an XSM policy: the hardware
domain does not need to be permitted access to create or modify other
domains in order to act as a device backend for them.

Changes since v2:
- Rename and move CONFIG_LATE_HWDOM declaration to asm-x86/config.h
- Move alloc_dom0_vcpu0 prototype change from patch 5 to 4
- Also rename nmi_{dom0 => hwdom}_report
- Add help/documentation for xl destroy -f

Changes since v1:
- More complete conversion to is_hardware_domain (convert "== dom0")
- Rename "dom0" global variable and associated functions
- Avoid locating the hardware_domid variable in x86-only code
- Require using "xl destroy -f 0" to destroy domain 0 to retain the
existing guard against accidental attempts to destroy domain 0 that
will still cause disruption of the platform.
- Add an XSM permission check so that the security label of the
hardware domain can be limited by the policy.
- Rebase against updated xen/staging

[PATCH 1/7] xen: use domid check in is_hardware_domain
[PATCH 2/7] xen/iommu: Move dom0 setup to __hwdom_init
[PATCH 3/7] xen: prevent 0 from being used as a dynamic domid
[PATCH 4/7] xen: rename dom0 to hardware_domain
[PATCH 5/7] xen: rename various functions referencing dom0
[PATCH 6/7] xen: Allow hardare domain != dom0
[PATCH 7/7] tools/libxl: Allow dom0 to be destroyed

Acked-by: Keir Fraser <keir@xen.org>

_______________________________________________
Xen-devel mailing list
Xen-devel@lists.xen.org
http://lists.xen.org/xen-devel
--------------090602010500050105070104 Content-Type: image/jpeg; x-apple-mail-type=stationery; name="compose-unknown-contact.jpg" Content-Transfer-Encoding: base64 Content-ID: Content-Disposition: inline; filename="compose-unknown-contact.jpg" /9j/4AAQSkZJRgABAQEARwBHAAD/2wBDAAEBAQEBAQEBAQEBAQEBAQEBAQEBAQEBAQEBAQEC AQEBAQEBAgICAgICAgICAgICAgICAgICAgICAgICAgICAgL/2wBDAQEBAQEBAQICAgICAgIC AgICAgICAgICAgICAgICAgICAgICAgICAgICAgICAgICAgICAgICAgICAgICAgICAgL/wAAR CAAZABkDAREAAhEBAxEB/8QAGAAAAwEBAAAAAAAAAAAAAAAABgcICQr/xAA0EAABAwMCAgUK BwAAAAAAAAACAQMEBQYRABITIQcUMUF2CBUXIjI2N0JRtVRWkZOV0dL/xAAYAQEAAwEAAAAA AAAAAAAAAAADAAEEAv/EACQRAAICAAQGAwAAAAAAAAAAAAABAhEDMrHREyExM0FxgfDx/9oA DAMBAAIRAxEAPwDuEt+gW/ULet6oVC3rfqNQqFv0OfPn1GhUqfOmzZtKZlS5UqZMaNwzNwiJ VIl7eXLCaZIGwBl3TY8epPx2+jy2ZNPjvkwc9uhW8j7nCPhvOsQliYIeS7cvCpp8o50qwrC4 v3lsNSDbdmTEhvs2tahxpfV3WnmbbozJEw/gwdadbYExVRXKEKoSdvJcaOSqxE7/AAiX0gXx +a69/JSf9alIlste0VzaNpeFrcT9KKymotyiaZ0KRCnzacoE7Kjzn4gi2KqUh3jqDHDHv4mR UfruTWlMzlVUKIVNp9GguEJnAh0+IZjyAiisgyRDnu5azS8miKqjOTVkKqS/psG37fo1Fbab eg25b8eZPeFJBBJSjMG5HjMeyihnaauZwe4OGiju13GAcpOwBeN+U8/IkGbsiS8b7ryogmbz hbyc9REROfZhERO5ETShjPtvpGqTUyLErytS4siSwx5x2tRH4hPOI0DkjZtaJtFxuVEbIUUi yeNujlBUJGbJN6nM/Cyf2Hf60YgjvKA+NPSP4gT7axpcPtr51YWJnYn9dnAQWl722p4ot37y zqnlfp6FrqbwawG8/9k= --------------090602010500050105070104-- --------------000507030607050308020904-- --===============4870582066024896768== Content-Type: text/plain; charset="us-ascii" MIME-Version: 1.0 Content-Transfer-Encoding: 7bit Content-Disposition: inline _______________________________________________ Xen-devel mailing list Xen-devel@lists.xen.org http://lists.xen.org/xen-devel --===============4870582066024896768==--