From mboxrd@z Thu Jan 1 00:00:00 1970 From: Hanjun Guo Subject: Re: [PATCH 01/19] ARM64 / ACPI: Get RSDP and ACPI boot-time tables Date: Tue, 29 Jul 2014 21:08:40 +0800 Message-ID: <53D79CD8.9050709@linaro.org> References: <1406206825-15590-1-git-send-email-hanjun.guo@linaro.org> <1406206825-15590-2-git-send-email-hanjun.guo@linaro.org> <53D69678.20002@arm.com> Mime-Version: 1.0 Content-Type: text/plain; charset=windows-1252 Content-Transfer-Encoding: 7bit Return-path: Received: from mail-pd0-f169.google.com ([209.85.192.169]:44611 "EHLO mail-pd0-f169.google.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1750867AbaG2NJ4 (ORCPT ); Tue, 29 Jul 2014 09:09:56 -0400 Received: by mail-pd0-f169.google.com with SMTP id y10so11649189pdj.14 for ; Tue, 29 Jul 2014 06:09:56 -0700 (PDT) In-Reply-To: <53D69678.20002@arm.com> Sender: linux-acpi-owner@vger.kernel.org List-Id: linux-acpi@vger.kernel.org To: Sudeep Holla , Catalin Marinas , "Rafael J. Wysocki" , Mark Rutland Cc: "graeme.gregory@linaro.org" , Arnd Bergmann , "grant.likely@linaro.org" , Will Deacon , Jason Cooper , Marc Zyngier , Bjorn Helgaas , Daniel Lezcano , Mark Brown , Robert Richter , Lv Zheng , Robert Moore , Lorenzo Pieralisi , Liviu Dudau , Randy Dunlap , Charles Garcia-Tobin , "linux-acpi@vger.kernel.org" , "linux-arm-kernel@lists.infradead.org" , "linux-kernel@vger.kernel.org" , Al Stone On 2014-7-29 2:29, Sudeep Holla wrote: [...] >> + >> +/* >> + * We never plan to use RSDT on arm/arm64 as its deprecated in spec but this >> + * variable is still required by the ACPI core >> + */ >> +u32 acpi_rsdt_forced; > > This looks like yet another stray variable not used anywhere including > core ACPI It will be used by ACPICA to get the RSDP in acpi_tb_parse_root_table() in tbutils.c. > >> + >> +int acpi_noirq; /* skip ACPI IRQ initialization */ >> +int acpi_strict; >> +int acpi_disabled; >> +EXPORT_SYMBOL(acpi_disabled); >> + >> +int acpi_pci_disabled; /* skip ACPI PCI scan and IRQ initialization */ >> +EXPORT_SYMBOL(acpi_pci_disabled); >> + >> +/* >> + * __acpi_map_table() will be called before page_init(), so early_ioremap() >> + * or early_memremap() should be called here to for ACPI table mapping. >> + */ >> +char *__init __acpi_map_table(unsigned long phys, unsigned long size) >> +{ >> + if (!phys || !size) >> + return NULL; >> + >> + return early_memremap(phys, size); >> +} >> + >> +void __init __acpi_unmap_table(char *map, unsigned long size) >> +{ >> + if (!map || !size) >> + return; >> + >> + early_iounmap(map, size); > > Why not early_memunmap for consistency ? ok. > Also now there's generic implementation of early mappings does it make > sense to move this also to acpi core ? Good point, how about clean it up after this patch set is merged? Thanks Hanjun From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1753398AbaG2NJ6 (ORCPT ); Tue, 29 Jul 2014 09:09:58 -0400 Received: from mail-pd0-f171.google.com ([209.85.192.171]:38859 "EHLO mail-pd0-f171.google.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1750933AbaG2NJ4 (ORCPT ); Tue, 29 Jul 2014 09:09:56 -0400 Message-ID: <53D79CD8.9050709@linaro.org> Date: Tue, 29 Jul 2014 21:08:40 +0800 From: Hanjun Guo User-Agent: Mozilla/5.0 (Windows NT 5.1; rv:24.0) Gecko/20100101 Thunderbird/24.6.0 MIME-Version: 1.0 To: Sudeep Holla , Catalin Marinas , "Rafael J. Wysocki" , Mark Rutland CC: "graeme.gregory@linaro.org" , Arnd Bergmann , "grant.likely@linaro.org" , Will Deacon , Jason Cooper , Marc Zyngier , Bjorn Helgaas , Daniel Lezcano , Mark Brown , Robert Richter , Lv Zheng , Robert Moore , Lorenzo Pieralisi , Liviu Dudau , Randy Dunlap , Charles Garcia-Tobin , "linux-acpi@vger.kernel.org" , "linux-arm-kernel@lists.infradead.org" , "linux-kernel@vger.kernel.org" , Al Stone , Tomasz Nowicki Subject: Re: [PATCH 01/19] ARM64 / ACPI: Get RSDP and ACPI boot-time tables References: <1406206825-15590-1-git-send-email-hanjun.guo@linaro.org> <1406206825-15590-2-git-send-email-hanjun.guo@linaro.org> <53D69678.20002@arm.com> In-Reply-To: <53D69678.20002@arm.com> Content-Type: text/plain; charset=windows-1252 Content-Transfer-Encoding: 7bit Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On 2014-7-29 2:29, Sudeep Holla wrote: [...] >> + >> +/* >> + * We never plan to use RSDT on arm/arm64 as its deprecated in spec but this >> + * variable is still required by the ACPI core >> + */ >> +u32 acpi_rsdt_forced; > > This looks like yet another stray variable not used anywhere including > core ACPI It will be used by ACPICA to get the RSDP in acpi_tb_parse_root_table() in tbutils.c. > >> + >> +int acpi_noirq; /* skip ACPI IRQ initialization */ >> +int acpi_strict; >> +int acpi_disabled; >> +EXPORT_SYMBOL(acpi_disabled); >> + >> +int acpi_pci_disabled; /* skip ACPI PCI scan and IRQ initialization */ >> +EXPORT_SYMBOL(acpi_pci_disabled); >> + >> +/* >> + * __acpi_map_table() will be called before page_init(), so early_ioremap() >> + * or early_memremap() should be called here to for ACPI table mapping. >> + */ >> +char *__init __acpi_map_table(unsigned long phys, unsigned long size) >> +{ >> + if (!phys || !size) >> + return NULL; >> + >> + return early_memremap(phys, size); >> +} >> + >> +void __init __acpi_unmap_table(char *map, unsigned long size) >> +{ >> + if (!map || !size) >> + return; >> + >> + early_iounmap(map, size); > > Why not early_memunmap for consistency ? ok. > Also now there's generic implementation of early mappings does it make > sense to move this also to acpi core ? Good point, how about clean it up after this patch set is merged? Thanks Hanjun From mboxrd@z Thu Jan 1 00:00:00 1970 From: hanjun.guo@linaro.org (Hanjun Guo) Date: Tue, 29 Jul 2014 21:08:40 +0800 Subject: [PATCH 01/19] ARM64 / ACPI: Get RSDP and ACPI boot-time tables In-Reply-To: <53D69678.20002@arm.com> References: <1406206825-15590-1-git-send-email-hanjun.guo@linaro.org> <1406206825-15590-2-git-send-email-hanjun.guo@linaro.org> <53D69678.20002@arm.com> Message-ID: <53D79CD8.9050709@linaro.org> To: linux-arm-kernel@lists.infradead.org List-Id: linux-arm-kernel.lists.infradead.org On 2014-7-29 2:29, Sudeep Holla wrote: [...] >> + >> +/* >> + * We never plan to use RSDT on arm/arm64 as its deprecated in spec but this >> + * variable is still required by the ACPI core >> + */ >> +u32 acpi_rsdt_forced; > > This looks like yet another stray variable not used anywhere including > core ACPI It will be used by ACPICA to get the RSDP in acpi_tb_parse_root_table() in tbutils.c. > >> + >> +int acpi_noirq; /* skip ACPI IRQ initialization */ >> +int acpi_strict; >> +int acpi_disabled; >> +EXPORT_SYMBOL(acpi_disabled); >> + >> +int acpi_pci_disabled; /* skip ACPI PCI scan and IRQ initialization */ >> +EXPORT_SYMBOL(acpi_pci_disabled); >> + >> +/* >> + * __acpi_map_table() will be called before page_init(), so early_ioremap() >> + * or early_memremap() should be called here to for ACPI table mapping. >> + */ >> +char *__init __acpi_map_table(unsigned long phys, unsigned long size) >> +{ >> + if (!phys || !size) >> + return NULL; >> + >> + return early_memremap(phys, size); >> +} >> + >> +void __init __acpi_unmap_table(char *map, unsigned long size) >> +{ >> + if (!map || !size) >> + return; >> + >> + early_iounmap(map, size); > > Why not early_memunmap for consistency ? ok. > Also now there's generic implementation of early mappings does it make > sense to move this also to acpi core ? Good point, how about clean it up after this patch set is merged? Thanks Hanjun