From mboxrd@z Thu Jan 1 00:00:00 1970 Received: from eggs.gnu.org ([2001:4830:134:3::10]:55551) by lists.gnu.org with esmtp (Exim 4.71) (envelope-from ) id 1XMDA9-0006Qt-3A for qemu-devel@nongnu.org; Tue, 26 Aug 2014 05:35:44 -0400 Received: from Debian-exim by eggs.gnu.org with spam-scanned (Exim 4.71) (envelope-from ) id 1XMDA1-0005fS-Gf for qemu-devel@nongnu.org; Tue, 26 Aug 2014 05:35:36 -0400 Received: from mail-pd0-f179.google.com ([209.85.192.179]:46995) by eggs.gnu.org with esmtp (Exim 4.71) (envelope-from ) id 1XMDA1-0005fH-9s for qemu-devel@nongnu.org; Tue, 26 Aug 2014 05:35:29 -0400 Received: by mail-pd0-f179.google.com with SMTP id v10so22249057pde.38 for ; Tue, 26 Aug 2014 02:35:28 -0700 (PDT) Message-ID: <53FC54DA.8090508@ozlabs.ru> Date: Tue, 26 Aug 2014 19:35:22 +1000 From: Alexey Kardashevskiy MIME-Version: 1.0 References: <1408407718-10835-1-git-send-email-mdroth@linux.vnet.ibm.com> <1408407718-10835-13-git-send-email-mdroth@linux.vnet.ibm.com> In-Reply-To: <1408407718-10835-13-git-send-email-mdroth@linux.vnet.ibm.com> Content-Type: text/plain; charset=koi8-r Content-Transfer-Encoding: 7bit Subject: Re: [Qemu-devel] [PATCH 12/12] spapr_pci: emit hotplug add/remove events during hotplug List-Id: List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , To: Michael Roth , qemu-devel@nongnu.org Cc: ncmike@ncultra.org, nfont@linux.vnet.ibm.com, qemu-ppc@nongnu.org, agraf@suse.de, tyreld@linux.vnet.ibm.com On 08/19/2014 10:21 AM, Michael Roth wrote: > From: Tyrel Datwyler > > This uses extension of existing EPOW interrupt/event mechanism > to notify userspace tools like librtas/drmgr to handle > in-guest configuration/cleanup operations in response to > device_add/device_del. > > Userspace tools that don't implement this extension will need > to be run manually in response/advance of device_add/device_del, > respectively. > > Signed-off-by: Tyrel Datwyler > Signed-off-by: Michael Roth > --- > hw/ppc/spapr_pci.c | 20 ++++++++++++++++++++ > 1 file changed, 20 insertions(+) > > diff --git a/hw/ppc/spapr_pci.c b/hw/ppc/spapr_pci.c > index 23864ab..17d37c0 100644 > --- a/hw/ppc/spapr_pci.c > +++ b/hw/ppc/spapr_pci.c > @@ -944,6 +944,18 @@ static int spapr_device_hotplug_add(DeviceState *qdev, PCIDevice *dev) > drc_entry_slot->state &= ~(uint32_t)INDICATOR_ENTITY_SENSE_MASK; > drc_entry_slot->state |= encoded; /* and the slot */ > > + /* reliable unplug requires we wait for a transition from > + * UNISOLATED->ISOLATED prior to device removal/deletion. > + * However, slots populated by devices at boot-time will not > + * have ever been set by guest tools to an UNISOLATED/populated > + * state, so set this manually in the case of coldplug devices > + */ > + if (!DEVICE(dev)->hotplugged) { > + drc_entry_slot->state |= ENCODE_DRC_STATE(1, > + INDICATOR_ISOLATION_MASK, > + INDICATOR_ISOLATION_SHIFT); > + } > + > /* add OF node for pci device and required OF DT properties */ > fdt_orig = g_malloc0(FDT_MAX_SIZE); > offset = fdt_create(fdt_orig, FDT_MAX_SIZE); > @@ -1026,13 +1038,21 @@ static void spapr_device_hotplug_remove(DeviceState *qdev, PCIDevice *dev) > static void spapr_phb_hot_plug(HotplugHandler *plug_handler, > DeviceState *plugged_dev, Error **errp) > { > + int slot = PCI_SLOT(PCI_DEVICE(plugged_dev)->devfn); > + > spapr_device_hotplug_add(DEVICE(plug_handler), PCI_DEVICE(plugged_dev)); > + if (plugged_dev->hotplugged) { > + spapr_pci_hotplug_add_event(DEVICE(plug_handler), slot); > + } Minor comment here :) @slot is a temporary variable and it used once. Ok, may be it increases readability, then it makes sense to have local variables for PCI_DEVICE(plugged_dev) and DEVICE(plug_handler) too as they both are calculated twice. But I do not insist :) > } > > static void spapr_phb_hot_unplug(HotplugHandler *plug_handler, > DeviceState *plugged_dev, Error **errp) > { > + int slot = PCI_SLOT(PCI_DEVICE(plugged_dev)->devfn); > + > spapr_device_hotplug_remove(DEVICE(plug_handler), PCI_DEVICE(plugged_dev)); > + spapr_pci_hotplug_remove_event(DEVICE(plug_handler), slot); > } Same here. > > static void spapr_phb_realize(DeviceState *dev, Error **errp) > -- Alexey