From mboxrd@z Thu Jan 1 00:00:00 1970 From: Nikita Kiryanov Date: Mon, 15 Dec 2014 14:02:04 +0200 Subject: [U-Boot] [PATCH V3 00/12] cleanup and refactor lcd.c In-Reply-To: <1418051686-630-1-git-send-email-nikita@compulab.co.il> References: <1418051686-630-1-git-send-email-nikita@compulab.co.il> Message-ID: <548ECDBC.30002@compulab.co.il> List-Id: MIME-Version: 1.0 Content-Type: text/plain; charset="us-ascii" Content-Transfer-Encoding: 7bit To: u-boot@lists.denx.de Gentle ping. On 12/08/2014 05:14 PM, Nikita Kiryanov wrote: > This series is a first step towards an end goal of merging all CONFIG_LCD > related functionality into CONFIG_VIDEO code. My plan is to start by refactoring > lcd.c into something cleaner (less ifdefs) and more modular (split code into > multiple files), then possibly refactor CONFIG_VIDEO code if needed, and then > finally: move CONFIG_LCD related functionality over to CONFIG_VIDEO code, > replacing as much CONFIG_LCD related code with CONFIG_VIDEO related code as > possible. > > This specific step eliminates some unused code and refactors lcd console stuff > into its own file. > > The patches ("lcd: rename console_(row|col)" to > "lcd: make lcd_drawchars() independant of lcd_base") are preparatory patches > meant to illustrate exactly what changed and where in the transition from lcd.c > to lcd_console.c, and are not necesserily code improvements when viewed out of > context. > > Changes in V3: > - Function documentation > - Cache values of lcd_get(bg|fg)color() instead of calling the functions > multiple times. > > The whole series was rebased over current mainline, and compile tested for arm > and powerpc. > > Cc: Anatolij Gustschin > Cc: Wolfgang Denk > Cc: Simon Glass > Cc: Stephen Warren > > Entire series: > Tested-by: Stephen Warren > Tested-by: Simon Glass > > Nikita Kiryanov (12): > lcd: remove CONFIG_SYS_INVERT_COLORS > lcd: cleanup lcd_drawchars > mpc8xx_lcd: get rid of CONFIG_EDT32F10 > lcd: remove LCD_MONOCHROME > lcd: rename console_(row|col) > lcd: replace CONSOLE_(ROWS|COLS) with variables > lcd: expand console api > lcd: get rid of COLOR_MASK > lcd: introduce getters for bg/fg color > lcd: make lcd_drawchars() independant of lcd_base > lcd: refactor lcd console stuff into its own file > lcd_console: remove unused defines > > common/Makefile | 2 +- > common/lcd.c | 313 +++++---------------------------------------- > common/lcd_console.c | 211 ++++++++++++++++++++++++++++++ > drivers/video/mpc8xx_lcd.c | 49 +------ > drivers/video/pxa_lcd.c | 15 --- > include/configs/R360MPI.h | 1 - > include/lcd.h | 25 ++-- > include/lcd_console.h | 86 +++++++++++++ > 8 files changed, 347 insertions(+), 355 deletions(-) > create mode 100644 common/lcd_console.c > create mode 100644 include/lcd_console.h > -- Regards, Nikita Kiryanov