All of lore.kernel.org
 help / color / mirror / Atom feed
From: Bo Shen <voice.shen@atmel.com>
To: u-boot@lists.denx.de
Subject: [U-Boot] [PATCH V2 00/13] common lcd refactor
Date: Wed, 4 Feb 2015 16:03:19 +0800	[thread overview]
Message-ID: <54D1D247.20405@atmel.com> (raw)
In-Reply-To: <1422963152-17634-1-git-send-email-nikita@compulab.co.il>

Hi Nikita Kiryanov,

On 02/03/2015 07:32 PM, Nikita Kiryanov wrote:
> This series is part of my ongoing efforts to cleanup common/lcd code (and at
> some point merge it with the CONFIG_VIDEO code).
> This series focuses on eliminating platform specific #defines from lcd.c code,
> and then adds a few platform independent code refactors and cleanups on top of
> that. A small note on the series:
>
> - The patch "lcd: split configuration_get_cmap" turned out to be a little
> problematic: the goal was to move all platform specific code to the appropriate
> lcd/fb drivers, and keep the generic case in lcd.c as a weak function.
> This was not possible to do for configuration_get_cmap(), because the weak
> version still has to compile even if it is overridden, and unfortunately the
> generic case references panel_info, which is a struct that varies depending on
> the configuration, and does not always have a cmap field. This demonstrated that
> the visibility of panel_info should be reviewed, and that there might be a need
> for some kind of lcd_generic driver.
> Since this may warrant a series of its own, I opted to tentatively implement
> the generic configuration_get_cmap() function in lcd.h as static function, and
> plan to revisit it in the next series.
>
> The end result was compile tested on arm and powerpc, and tested on cm_t35
> (splash screen feature). Rebased on current mainline.
>
> Changes in V2:
> - Minor commit message changes (such as s/platform specific/platform-specific/,
>    s/Raspberry Pi config file is updated to compile the new file/Raspberry Pi is updated to accommodate the changes/)
> - patch 2: define configuration_get_cmap() prototype only once.
>
> Cc: Bo Shen <voice.shen@atmel.com>
> Cc: Simon Glass <sjg@chromium.org>
> Cc: Anatolij Gustschin <agust@denx.de>
>
> Nikita Kiryanov (13):
>    lcd: move platform-specific structs to their own headers
>    lcd: split configuration_get_cmap
>    lcd: atmel: move atmel-specific fb_put_word to atmel_lcdfb
>    lcd: mpc8xx: move mpc823-specific fb_put_byte to mpc8xx_lcd.c
>    lcd: atmel: introduce lcd_logo_set_cmap
>    lcd: mpc823: move mpc823-specific lcd_logo_set_cmap code to
>      mpc8xx_lcd.c
>    lcd: logo: move generic cmap setting to lcd_logo_set_cmap()
>    lcd: introduce lcd_set_cmap
>    lcd: remove unused includes
>    lcd: various cleanups
>    lcd: rename bitmap_plot to better represent its functionality
>    lcd: dt: extract simplefb support
>    lcd: split splash code into its own function

Tested OK on at91sam9g10ek, at91sam9x5ek boards.

Tested-by: Bo Shen <voice.shen@atmel.com>

>   board/raspberrypi/rpi/rpi.c  |   1 +
>   common/Makefile              |   1 +
>   common/lcd.c                 | 358 ++++++++++---------------------------------
>   common/lcd_simplefb.c        |  59 +++++++
>   common/splash.c              |  16 ++
>   drivers/video/atmel_hlcdfb.c |  13 ++
>   drivers/video/atmel_lcdfb.c  |  51 ++++++
>   drivers/video/exynos_fb.c    |   9 ++
>   drivers/video/mpc8xx_lcd.c   |  29 ++++
>   drivers/video/pxa_lcd.c      |   6 +
>   include/atmel_lcd.h          |  38 +++++
>   include/exynos_lcd.h         |  81 ++++++++++
>   include/fdt_simplefb.h       |  14 ++
>   include/lcd.h                | 311 ++++++-------------------------------
>   include/mpc823_lcd.h         |  43 ++++++
>   include/pxa_lcd.h            |  80 ++++++++++
>   include/splash.h             |  11 +-
>   17 files changed, 574 insertions(+), 547 deletions(-)
>   create mode 100644 common/lcd_simplefb.c
>   create mode 100644 include/atmel_lcd.h
>   create mode 100644 include/exynos_lcd.h
>   create mode 100644 include/fdt_simplefb.h
>   create mode 100644 include/mpc823_lcd.h
>   create mode 100644 include/pxa_lcd.h
>

Best Regards,
Bo Shen

  parent reply	other threads:[~2015-02-04  8:03 UTC|newest]

Thread overview: 22+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2015-02-03 11:32 [U-Boot] [PATCH V2 00/13] common lcd refactor Nikita Kiryanov
2015-02-03 11:32 ` [U-Boot] [PATCH V2 01/13] lcd: move platform-specific structs to their own headers Nikita Kiryanov
2015-02-04  6:48   ` Bo Shen
2015-02-03 11:32 ` [U-Boot] [PATCH V2 02/13] lcd: split configuration_get_cmap Nikita Kiryanov
2015-02-04  7:25   ` Bo Shen
2015-02-08 11:35     ` Nikita Kiryanov
2015-02-09  3:43       ` Bo Shen
2015-02-03 11:32 ` [U-Boot] [PATCH V2 03/13] lcd: atmel: move atmel-specific fb_put_word to atmel_lcdfb Nikita Kiryanov
2015-02-04  7:26   ` Bo Shen
2015-02-03 11:32 ` [U-Boot] [PATCH V2 04/13] lcd: mpc8xx: move mpc823-specific fb_put_byte to mpc8xx_lcd.c Nikita Kiryanov
2015-02-03 11:32 ` [U-Boot] [PATCH V2 05/13] lcd: atmel: introduce lcd_logo_set_cmap Nikita Kiryanov
2015-02-03 11:32 ` [U-Boot] [PATCH V2 06/13] lcd: mpc823: move mpc823-specific lcd_logo_set_cmap code to mpc8xx_lcd.c Nikita Kiryanov
2015-02-03 11:32 ` [U-Boot] [PATCH V2 07/13] lcd: logo: move generic cmap setting to lcd_logo_set_cmap() Nikita Kiryanov
2015-02-03 11:32 ` [U-Boot] [PATCH V2 08/13] lcd: introduce lcd_set_cmap Nikita Kiryanov
2015-02-03 11:32 ` [U-Boot] [PATCH V2 09/13] lcd: remove unused includes Nikita Kiryanov
2015-02-03 11:32 ` [U-Boot] [PATCH V2 10/13] lcd: various cleanups Nikita Kiryanov
2015-02-03 11:32 ` [U-Boot] [PATCH V2 11/13] lcd: rename bitmap_plot to better represent its functionality Nikita Kiryanov
2015-02-03 11:32 ` [U-Boot] [PATCH V2 12/13] lcd: dt: extract simplefb support Nikita Kiryanov
2015-02-03 11:32 ` [U-Boot] [PATCH V2 13/13] lcd: split splash code into its own function Nikita Kiryanov
2015-02-04  2:37 ` [U-Boot] [PATCH V2 00/13] common lcd refactor Josh Wu
2015-02-04  8:03 ` Bo Shen [this message]
2015-02-10 12:43 ` Anatolij Gustschin

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=54D1D247.20405@atmel.com \
    --to=voice.shen@atmel.com \
    --cc=u-boot@lists.denx.de \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.