From mboxrd@z Thu Jan 1 00:00:00 1970 From: Michael Wang Subject: Re: [PATCH v8 00/23] IB/Verbs: IB Management Helpers Date: Tue, 12 May 2015 09:57:52 +0200 Message-ID: <5551B280.5040905@profitbricks.com> References: <1430830240-32389-1-git-send-email-yun.wang@profitbricks.com> <20150511234910.GA20027@phlsvsds.ph.intel.com> <1431390420.43876.4.camel@redhat.com> Mime-Version: 1.0 Content-Type: text/plain; charset=utf-8 Content-Transfer-Encoding: 7bit Return-path: In-Reply-To: <1431390420.43876.4.camel-H+wXaHxf7aLQT0dZR+AlfA@public.gmane.org> Sender: linux-rdma-owner-u79uwXL29TY76Z2rM5mHXA@public.gmane.org To: Doug Ledford , "ira.weiny" Cc: Roland Dreier , Sean Hefty , Hal Rosenstock , linux-rdma-u79uwXL29TY76Z2rM5mHXA@public.gmane.org, linux-kernel-u79uwXL29TY76Z2rM5mHXA@public.gmane.org, Tom Tucker , Steve Wise , Hoang-Nam Nguyen , Christoph Raisch , Mike Marciniszyn , Eli Cohen , Faisal Latif , Jack Morgenstein , Or Gerlitz , Haggai Eran , Tom Talpey , Jason Gunthorpe , Devesh Sharma , Liran Liss , Dave Goodell List-Id: linux-rdma@vger.kernel.org On 05/12/2015 02:27 AM, Doug Ledford wrote: > On Mon, 2015-05-11 at 19:49 -0400, ira.weiny wrote: >> I have run with this series and the only issue I have found is not with this >> patch set directly. >> >> This patch: >> >>> IB/Verbs: Use management helper rdma_cap_ib_mad() >> >> causes an error when you actually use the port passed from the ib_umad module. >> I have a patch to fix that which I found while trying to build on this series >> for the use of a bit mask. >> >> Doug, I don't know what you would like to do for this fix. I am submitting it >> shortly with a new version of the core capability bit patches. If you want to >> just add it after this series or force Michael to respin with the fix? > > As I recall, there was a comment from Or requesting to squash some of > the individual patches down, but I no longer have that email in my Inbox > to double check. And it seemed like there was one other review comment > not yet addressed. Do I have that right Michael? And if so, are you > working on a v9? AFAIK Or was asking to merge the #15~23, and want to reserve the changelog meanwhile reply the cover of prev version (I'm still confused on that...), I've replied but get no respond yet. I can make a v9 to merge the #15~#23 if that could benefit the maintainability, please let me know your opinion :-) About the Bug, if it was not introduced in this series, maybe including the fix in next series would be better? Regards, Michael Wang > >> Frankly >> I vote for the former because as it stands this series does not break directly. >> It was only after I changed the implementation of rdma_cap_ib_mad that it >> broke. >> >> >> For the rest of the series. >> >> Reviewed-by: Ira Weiny >> Tested-by: Ira Weiny >> -- Limited to mlx4, qib, and OPA (with additional patches.) >> >> >> On Tue, May 05, 2015 at 02:50:17PM +0200, Michael Wang wrote: >>> Since v7: >>> * Thanks to Doug, Ira, Devesh for the testing :-) >>> * Thanks for the comments from or, Doug, Ira, Jason :-) >>> Please remind me if anything missed :-P >>> * Use rdma_cap_XX() instead of cap_XX() for readability >>> * Remove CC list in git log for maintainability >>> * Use bool as return value >>> * Updated github repository to v8 >>> >>> There are plenty of lengthy code to check the transport type of IB device, >>> or the link layer type of it's port, but actually we are just speculating >>> whether a particular management/feature is supported by the device/port. >>> >>> Thus instead of inferring, we should have our own mechanism for IB management >>> capability/protocol/feature checking, several proposals below. >>> >>> This patch set will introduce query_protocol() to check management requirement >>> instead of inferring from transport and link layer respectively, along with >>> the new enum on protocol type. >>> >>> Mapping List: >>> node-type link-layer transport protocol >>> nes RNIC ETH IWARP IWARP >>> amso1100 RNIC ETH IWARP IWARP >>> cxgb3 RNIC ETH IWARP IWARP >>> cxgb4 RNIC ETH IWARP IWARP >>> usnic USNIC_UDP ETH USNIC_UDP USNIC_UDP >>> ocrdma IB_CA ETH IB IBOE >>> mlx4 IB_CA IB/ETH IB IB/IBOE >>> mlx5 IB_CA IB IB IB >>> ehca IB_CA IB IB IB >>> ipath IB_CA IB IB IB >>> mthca IB_CA IB IB IB >>> qib IB_CA IB IB IB >>> >>> For example: >>> if (transport == IB) && (link-layer == ETH) >>> will now become: >>> if (query_protocol() == IBOE) >>> >>> Thus we will be able to get rid of the respective transport and link-layer >>> checking, and it will help us to add new protocol/Technology (like OPA) more >>> easier, also with the introduced management helpers, IB management logical >>> will be more clear and easier for extending. >>> >>> Highlights: >>> The long CC list in each patches was complained consider about the >>> maintainability, it was suggested folks to provide their reviewed-by or >>> Acked-by instead, so for those who used to be on the CC list, please >>> provide your signature voluntarily :-) >>> >>> The 'mgmt-helpers' branch of 'git-9UaJU3cA/F/QT0dZR+AlfA@public.gmane.org:ywang-pb/infiniband-wy.git' >>> contain this series based on the latest 'infiniband/for-next' >>> >>> Patch 1#~14# included all the logical reform, 15#~23# introduced the >>> management helpers. >>> >>> Doug suggested the bitmask mechanism: >>> https://www.mail-archive.com/linux-rdma-u79uwXL29TY76Z2rM5mHXA@public.gmane.org/msg23765.html >>> which could be the plan for future reforming, we prefer that to be another >>> series which focus on semantic and performance. >>> >>> This patch-set is somewhat 'bloated' now and it may be a good timing for >>> staging, I'd like to suggest we focus on improving existed helpers and push >>> all the further reforms into next series ;-) >>> >>> Proposals: >>> Sean: >>> https://www.mail-archive.com/linux-rdma-u79uwXL29TY76Z2rM5mHXA@public.gmane.org/msg23339.html >>> Doug: >>> https://www.mail-archive.com/linux-rdma-u79uwXL29TY76Z2rM5mHXA@public.gmane.org/msg23418.html >>> https://www.mail-archive.com/linux-rdma-u79uwXL29TY76Z2rM5mHXA@public.gmane.org/msg23765.html >>> Jason: >>> https://www.mail-archive.com/linux-rdma-u79uwXL29TY76Z2rM5mHXA@public.gmane.org/msg23425.html >>> >>> Michael Wang (23): >>> IB/Verbs: Implement new callback query_protocol() >>> IB/Verbs: Implement raw management helpers >>> IB/Verbs: Reform IB-core mad/agent/user_mad >>> IB/Verbs: Reform IB-core cm >>> IB/Verbs: Reform IB-core sa_query >>> IB/Verbs: Reform IB-core multicast >>> IB/Verbs: Reform IB-ulp ipoib >>> IB/Verbs: Reform IB-ulp xprtrdma >>> IB/Verbs: Reform IB-core verbs >>> IB/Verbs: Reform cm related part in IB-core cma/ucm >>> IB/Verbs: Reform route related part in IB-core cma >>> IB/Verbs: Reform mcast related part in IB-core cma >>> IB/Verbs: Reform cma_acquire_dev() >>> IB/Verbs: Reform rest part in IB-core cma >>> IB/Verbs: Use management helper rdma_cap_ib_mad() >>> IB/Verbs: Use management helper rdma_cap_ib_smi() >>> IB/Verbs: Use management helper rdma_cap_ib_cm() >>> IB/Verbs: Use management helper rdma_cap_iw_cm() >>> IB/Verbs: Use management helper rdma_cap_ib_sa() >>> IB/Verbs: Use management helper rdma_cap_ib_mcast() >>> IB/Verbs: Use management helper rdma_cap_read_multi_sge() >>> IB/Verbs: Use management helper rdma_cap_af_ib() >>> IB/Verbs: Use management helper rdma_cap_eth_ah() >>> >>> drivers/infiniband/core/agent.c | 2 +- >>> drivers/infiniband/core/cm.c | 20 ++- >>> drivers/infiniband/core/cma.c | 257 +++++++++++---------------- >>> drivers/infiniband/core/device.c | 1 + >>> drivers/infiniband/core/mad.c | 43 +++-- >>> drivers/infiniband/core/multicast.c | 12 +- >>> drivers/infiniband/core/sa_query.c | 30 ++-- >>> drivers/infiniband/core/ucm.c | 3 +- >>> drivers/infiniband/core/ucma.c | 25 +-- >>> drivers/infiniband/core/user_mad.c | 26 ++- >>> drivers/infiniband/core/verbs.c | 6 +- >>> drivers/infiniband/hw/amso1100/c2_provider.c | 7 + >>> drivers/infiniband/hw/cxgb3/iwch_provider.c | 7 + >>> drivers/infiniband/hw/cxgb4/provider.c | 7 + >>> drivers/infiniband/hw/ehca/ehca_hca.c | 6 + >>> drivers/infiniband/hw/ehca/ehca_iverbs.h | 3 + >>> drivers/infiniband/hw/ehca/ehca_main.c | 1 + >>> drivers/infiniband/hw/ipath/ipath_verbs.c | 7 + >>> drivers/infiniband/hw/mlx4/main.c | 10 ++ >>> drivers/infiniband/hw/mlx5/main.c | 7 + >>> drivers/infiniband/hw/mthca/mthca_provider.c | 7 + >>> drivers/infiniband/hw/nes/nes_verbs.c | 6 + >>> drivers/infiniband/hw/ocrdma/ocrdma_main.c | 1 + >>> drivers/infiniband/hw/ocrdma/ocrdma_verbs.c | 6 + >>> drivers/infiniband/hw/ocrdma/ocrdma_verbs.h | 3 + >>> drivers/infiniband/hw/qib/qib_verbs.c | 7 + >>> drivers/infiniband/hw/usnic/usnic_ib_main.c | 1 + >>> drivers/infiniband/hw/usnic/usnic_ib_verbs.c | 6 + >>> drivers/infiniband/hw/usnic/usnic_ib_verbs.h | 2 + >>> drivers/infiniband/ulp/ipoib/ipoib_main.c | 15 +- >>> include/rdma/ib_verbs.h | 167 +++++++++++++++++ >>> net/sunrpc/xprtrdma/svc_rdma_recvfrom.c | 4 +- >>> net/sunrpc/xprtrdma/svc_rdma_transport.c | 45 ++--- >>> 33 files changed, 477 insertions(+), 273 deletions(-) >>> >>> -- >>> 2.1.0 >>> >> -- >> To unsubscribe from this list: send the line "unsubscribe linux-rdma" in >> the body of a message to majordomo-u79uwXL29TY76Z2rM5mHXA@public.gmane.org >> More majordomo info at http://vger.kernel.org/majordomo-info.html > > -- To unsubscribe from this list: send the line "unsubscribe linux-rdma" in the body of a message to majordomo-u79uwXL29TY76Z2rM5mHXA@public.gmane.org More majordomo info at http://vger.kernel.org/majordomo-info.html From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S932107AbbELH57 (ORCPT ); Tue, 12 May 2015 03:57:59 -0400 Received: from mail-wi0-f175.google.com ([209.85.212.175]:36361 "EHLO mail-wi0-f175.google.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1752893AbbELH54 (ORCPT ); Tue, 12 May 2015 03:57:56 -0400 Message-ID: <5551B280.5040905@profitbricks.com> Date: Tue, 12 May 2015 09:57:52 +0200 From: Michael Wang User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:31.0) Gecko/20100101 Thunderbird/31.6.0 MIME-Version: 1.0 To: Doug Ledford , "ira.weiny" CC: Roland Dreier , Sean Hefty , Hal Rosenstock , linux-rdma@vger.kernel.org, linux-kernel@vger.kernel.org, Tom Tucker , Steve Wise , Hoang-Nam Nguyen , Christoph Raisch , Mike Marciniszyn , Eli Cohen , Faisal Latif , Jack Morgenstein , Or Gerlitz , Haggai Eran , Tom Talpey , Jason Gunthorpe , Devesh Sharma , Liran Liss , Dave Goodell Subject: Re: [PATCH v8 00/23] IB/Verbs: IB Management Helpers References: <1430830240-32389-1-git-send-email-yun.wang@profitbricks.com> <20150511234910.GA20027@phlsvsds.ph.intel.com> <1431390420.43876.4.camel@redhat.com> In-Reply-To: <1431390420.43876.4.camel@redhat.com> Content-Type: text/plain; charset=utf-8 Content-Transfer-Encoding: 7bit Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On 05/12/2015 02:27 AM, Doug Ledford wrote: > On Mon, 2015-05-11 at 19:49 -0400, ira.weiny wrote: >> I have run with this series and the only issue I have found is not with this >> patch set directly. >> >> This patch: >> >>> IB/Verbs: Use management helper rdma_cap_ib_mad() >> >> causes an error when you actually use the port passed from the ib_umad module. >> I have a patch to fix that which I found while trying to build on this series >> for the use of a bit mask. >> >> Doug, I don't know what you would like to do for this fix. I am submitting it >> shortly with a new version of the core capability bit patches. If you want to >> just add it after this series or force Michael to respin with the fix? > > As I recall, there was a comment from Or requesting to squash some of > the individual patches down, but I no longer have that email in my Inbox > to double check. And it seemed like there was one other review comment > not yet addressed. Do I have that right Michael? And if so, are you > working on a v9? AFAIK Or was asking to merge the #15~23, and want to reserve the changelog meanwhile reply the cover of prev version (I'm still confused on that...), I've replied but get no respond yet. I can make a v9 to merge the #15~#23 if that could benefit the maintainability, please let me know your opinion :-) About the Bug, if it was not introduced in this series, maybe including the fix in next series would be better? Regards, Michael Wang > >> Frankly >> I vote for the former because as it stands this series does not break directly. >> It was only after I changed the implementation of rdma_cap_ib_mad that it >> broke. >> >> >> For the rest of the series. >> >> Reviewed-by: Ira Weiny >> Tested-by: Ira Weiny >> -- Limited to mlx4, qib, and OPA (with additional patches.) >> >> >> On Tue, May 05, 2015 at 02:50:17PM +0200, Michael Wang wrote: >>> Since v7: >>> * Thanks to Doug, Ira, Devesh for the testing :-) >>> * Thanks for the comments from or, Doug, Ira, Jason :-) >>> Please remind me if anything missed :-P >>> * Use rdma_cap_XX() instead of cap_XX() for readability >>> * Remove CC list in git log for maintainability >>> * Use bool as return value >>> * Updated github repository to v8 >>> >>> There are plenty of lengthy code to check the transport type of IB device, >>> or the link layer type of it's port, but actually we are just speculating >>> whether a particular management/feature is supported by the device/port. >>> >>> Thus instead of inferring, we should have our own mechanism for IB management >>> capability/protocol/feature checking, several proposals below. >>> >>> This patch set will introduce query_protocol() to check management requirement >>> instead of inferring from transport and link layer respectively, along with >>> the new enum on protocol type. >>> >>> Mapping List: >>> node-type link-layer transport protocol >>> nes RNIC ETH IWARP IWARP >>> amso1100 RNIC ETH IWARP IWARP >>> cxgb3 RNIC ETH IWARP IWARP >>> cxgb4 RNIC ETH IWARP IWARP >>> usnic USNIC_UDP ETH USNIC_UDP USNIC_UDP >>> ocrdma IB_CA ETH IB IBOE >>> mlx4 IB_CA IB/ETH IB IB/IBOE >>> mlx5 IB_CA IB IB IB >>> ehca IB_CA IB IB IB >>> ipath IB_CA IB IB IB >>> mthca IB_CA IB IB IB >>> qib IB_CA IB IB IB >>> >>> For example: >>> if (transport == IB) && (link-layer == ETH) >>> will now become: >>> if (query_protocol() == IBOE) >>> >>> Thus we will be able to get rid of the respective transport and link-layer >>> checking, and it will help us to add new protocol/Technology (like OPA) more >>> easier, also with the introduced management helpers, IB management logical >>> will be more clear and easier for extending. >>> >>> Highlights: >>> The long CC list in each patches was complained consider about the >>> maintainability, it was suggested folks to provide their reviewed-by or >>> Acked-by instead, so for those who used to be on the CC list, please >>> provide your signature voluntarily :-) >>> >>> The 'mgmt-helpers' branch of 'git@github.com:ywang-pb/infiniband-wy.git' >>> contain this series based on the latest 'infiniband/for-next' >>> >>> Patch 1#~14# included all the logical reform, 15#~23# introduced the >>> management helpers. >>> >>> Doug suggested the bitmask mechanism: >>> https://www.mail-archive.com/linux-rdma@vger.kernel.org/msg23765.html >>> which could be the plan for future reforming, we prefer that to be another >>> series which focus on semantic and performance. >>> >>> This patch-set is somewhat 'bloated' now and it may be a good timing for >>> staging, I'd like to suggest we focus on improving existed helpers and push >>> all the further reforms into next series ;-) >>> >>> Proposals: >>> Sean: >>> https://www.mail-archive.com/linux-rdma@vger.kernel.org/msg23339.html >>> Doug: >>> https://www.mail-archive.com/linux-rdma@vger.kernel.org/msg23418.html >>> https://www.mail-archive.com/linux-rdma@vger.kernel.org/msg23765.html >>> Jason: >>> https://www.mail-archive.com/linux-rdma@vger.kernel.org/msg23425.html >>> >>> Michael Wang (23): >>> IB/Verbs: Implement new callback query_protocol() >>> IB/Verbs: Implement raw management helpers >>> IB/Verbs: Reform IB-core mad/agent/user_mad >>> IB/Verbs: Reform IB-core cm >>> IB/Verbs: Reform IB-core sa_query >>> IB/Verbs: Reform IB-core multicast >>> IB/Verbs: Reform IB-ulp ipoib >>> IB/Verbs: Reform IB-ulp xprtrdma >>> IB/Verbs: Reform IB-core verbs >>> IB/Verbs: Reform cm related part in IB-core cma/ucm >>> IB/Verbs: Reform route related part in IB-core cma >>> IB/Verbs: Reform mcast related part in IB-core cma >>> IB/Verbs: Reform cma_acquire_dev() >>> IB/Verbs: Reform rest part in IB-core cma >>> IB/Verbs: Use management helper rdma_cap_ib_mad() >>> IB/Verbs: Use management helper rdma_cap_ib_smi() >>> IB/Verbs: Use management helper rdma_cap_ib_cm() >>> IB/Verbs: Use management helper rdma_cap_iw_cm() >>> IB/Verbs: Use management helper rdma_cap_ib_sa() >>> IB/Verbs: Use management helper rdma_cap_ib_mcast() >>> IB/Verbs: Use management helper rdma_cap_read_multi_sge() >>> IB/Verbs: Use management helper rdma_cap_af_ib() >>> IB/Verbs: Use management helper rdma_cap_eth_ah() >>> >>> drivers/infiniband/core/agent.c | 2 +- >>> drivers/infiniband/core/cm.c | 20 ++- >>> drivers/infiniband/core/cma.c | 257 +++++++++++---------------- >>> drivers/infiniband/core/device.c | 1 + >>> drivers/infiniband/core/mad.c | 43 +++-- >>> drivers/infiniband/core/multicast.c | 12 +- >>> drivers/infiniband/core/sa_query.c | 30 ++-- >>> drivers/infiniband/core/ucm.c | 3 +- >>> drivers/infiniband/core/ucma.c | 25 +-- >>> drivers/infiniband/core/user_mad.c | 26 ++- >>> drivers/infiniband/core/verbs.c | 6 +- >>> drivers/infiniband/hw/amso1100/c2_provider.c | 7 + >>> drivers/infiniband/hw/cxgb3/iwch_provider.c | 7 + >>> drivers/infiniband/hw/cxgb4/provider.c | 7 + >>> drivers/infiniband/hw/ehca/ehca_hca.c | 6 + >>> drivers/infiniband/hw/ehca/ehca_iverbs.h | 3 + >>> drivers/infiniband/hw/ehca/ehca_main.c | 1 + >>> drivers/infiniband/hw/ipath/ipath_verbs.c | 7 + >>> drivers/infiniband/hw/mlx4/main.c | 10 ++ >>> drivers/infiniband/hw/mlx5/main.c | 7 + >>> drivers/infiniband/hw/mthca/mthca_provider.c | 7 + >>> drivers/infiniband/hw/nes/nes_verbs.c | 6 + >>> drivers/infiniband/hw/ocrdma/ocrdma_main.c | 1 + >>> drivers/infiniband/hw/ocrdma/ocrdma_verbs.c | 6 + >>> drivers/infiniband/hw/ocrdma/ocrdma_verbs.h | 3 + >>> drivers/infiniband/hw/qib/qib_verbs.c | 7 + >>> drivers/infiniband/hw/usnic/usnic_ib_main.c | 1 + >>> drivers/infiniband/hw/usnic/usnic_ib_verbs.c | 6 + >>> drivers/infiniband/hw/usnic/usnic_ib_verbs.h | 2 + >>> drivers/infiniband/ulp/ipoib/ipoib_main.c | 15 +- >>> include/rdma/ib_verbs.h | 167 +++++++++++++++++ >>> net/sunrpc/xprtrdma/svc_rdma_recvfrom.c | 4 +- >>> net/sunrpc/xprtrdma/svc_rdma_transport.c | 45 ++--- >>> 33 files changed, 477 insertions(+), 273 deletions(-) >>> >>> -- >>> 2.1.0 >>> >> -- >> To unsubscribe from this list: send the line "unsubscribe linux-rdma" in >> the body of a message to majordomo@vger.kernel.org >> More majordomo info at http://vger.kernel.org/majordomo-info.html > >