On 05/08/2015 11:21 AM, Kevin Wolf wrote: > Eventually we want to be able to change options at runtime. As a first > step towards that goal, separate some option handling code from the > general initialisation code in qcow2_open(). > > Signed-off-by: Kevin Wolf > --- > block/qcow2.c | 135 +++++++++++++++++++++++++++++++++------------------------- > 1 file changed, 76 insertions(+), 59 deletions(-) > > + } else { > + error_setg(errp, "Unsupported value '%s' for qcow2 option " > + "'overlap-check'. Allowed are either of the following: " > + "none, constant, cached, all", opt_overlap_check); Pre-existing due to code motion, but I find s/either/any/ easier to read. Reviewed-by: Eric Blake -- Eric Blake eblake redhat com +1-919-301-3266 Libvirt virtualization library http://libvirt.org